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1. Introduction
This document explains how to install and setup ASFALIS Slave Node.

2. Setup of Shared Network Folder
The computers where ASFALIS Slave Node is installed and the client computers which uses
ASFALIS Slave Node need to share one folder with the same file path (Ex. N:\share). Here, I
explain how to set a shared folder.

Be careful of the followings when you set a shared folder.

• A shared folder needs to be assigned in a large-capacity drive because the output folder
and the work folder of data processing are created under the shared folder.

• UNC path (path whose initial is "\\") cannot be used as the shared folder.

• Root directories of drives (like "N:\") cannot be used as the shared folder.

The folder "\\server1\asfalis\share" in the computer named "server1" is used as the shared
folder in the above example. In this regard, we change the path "\\server1\asfalis\share" to
"N:\share" with assigning the folder "\\server1\asfalis" to N drive ("N:\") and use the path
"N:\share" as the shared folder, because UNC paths cannot be used as the shared folder.

How to assign a drive letter to UNC path

1. Right-click on "Computer (or My Computer)" and select "Map Network Drive."
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2. Select a drive letter from pull-down menu, enter UNC path in the Folder field and click
[Finish].

Please perform the above-mentioned setting to all the computers where ASFALIS Slave
Node is installed and the computers which uses ASFALIS Slave Node.
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3. Installation
We use the installer of ASFALIS Slave Node to install CAD adapter and optimizer components.
Please install ASFALIS Slave Node according to the following procedure.

3.1. Install .NET Framework
Please note that, since ASFALIS EX7.1, you may need to manually install “.NET Framework”
prior to the installation of ASFALIS Slave Node depending on your environment. (It was
automatically installed when installing ASFALIS EX7.0 or earlier.)
See below and install it if necessary.

A) .NET Framework 4.0 - 4.5.1 is installed

Run the following installer to install .NET Framework prior to the installation of ASFALIS
Slave Node.

• <ASFALIS Slave Node installation package>
\ISSetupPrerequisites{C4366B56-BE8F-41DA-AEFC-CB5165ADB5D3}\NDP452-KB2901907-
x86-x64-AllOS-ENU.exe

B) .NET Framework 3.* or earlier is installed / .NET Framework is not installed

Skip this process, and start the installation of ASFALIS Slave Node. .NET Framework 4.5.2 will
be installed automatically.

C) .NET Framework 4.5.2 or later is installed

Skip this process, and start the installation of ASFALIS Slave Node. An appropriate .NET
Framework version is already installed.

3.2. Install ASFALIS Slave Node
1. Run the installer of ASFALIS Slave Node.

◦ <ASFALIS Slave Node installation package >\setup.exe

2. Select the language for the installation and click [OK]. Japanese and English can be selected.

3. If this dialog appears, click [Install].
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4. The installer of Ruby for Elysium ASFALIS starts. If Ruby for Elysium ASFALIS is already
installed, please go to 11.

5. Select the language for the installation and click [OK].

6. Installation wizard starts. Click [Next].
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7. Please read the license agreement carefully. If you accept the license agreement, select “I
accept the terms in the license agreement” and click [Next]. If you don’t accept, you cannot
continue the installation.

8. The dialog to specify a destination folder appears. If you would like to change the
destination folder from default, click [Change] and specify the new destination folder. When
the setting finished, click [Next].
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9. Click [Install], and the installation starts.

10. When the installation finishes, the following dialog appears. Click [Finish].
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The installer of Ruby for Elysium ASFALIS finishes, and the processing backs to the installer
of ASFALIS Slave Node.

11. Installation wizard starts. Click [Next].

12. Please read the license agreement carefully. If you accept the license agreement, select “I
accept the terms in the license agreement” and click [Next]. If you don’t accept, you cannot
continue the installation.
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13. The dialog to specify a destination folder appears. If you would like to change the
destination folder from default, click [Change] and specify the new destination folder. When
the setting finishes, click [Next].

14. Specify the server name and the port number where ELYSIUM License is registered. After
designation, click [Next]. About ELYSIUM License, please refer to Sentinel RMS License
Manager Setup & Quick Start Guide. (LicenseServer_QuickStartGuide_en.pdf)
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15. Specify the port number which ASFALIS Slave Node uses in the server computer. The
default value is 59859. Click [Next] without changing the value because the value usually
doesn’t need to change.


The case you need to change the port:
When another program already uses the port number 59859, you need to
specify the port number which any programs don’t use.
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16. Click [Install], and the installation starts.

17. When the installation finishes, the following dialog appears. Click [Finish] to finish the
installer.

With that, the installation of ASFALIS Slave Node finishes. Please refer to 4, “Set up ASFALIS
Slave Node” to activate CAD adapter and optimizer component.
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
Please ensure that the host name resolution works bi-directionally between the
computer on which ASFALIS Controller/ASFALIS TransServer are running and
Slave Node.

ASFALIS Slave Node Installation Guide

 © Elysium Co. Ltd. All rights reserved. Page 11 | 29



4. Set up ASFALIS Slave Node
We set up ASFALIS Slave Node. When we click [Start] > [All Programs] > [Elysium ASFALIS
Component] > [EX*.*] > [setup node], the following dialog appears. EX*.* means the version of
ASFALIS Slave Node. We set up ASFLIS Slave Node on this dialog.

Please refer to 4.8, “Copy Configuration of Existing Slave Node” for how to set up ASFALIS Slave
Node by copying the configuration of existing Slave Node.

4.1. Common Settings
We set the required items which do not depend on using CAD adapter and optimizer component
in "Common" tab.
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[Slave node settings]

• Listen port
Specify the port number used to communicate with the client computer.
Please ensure to specify a port which is not used by other programs.

• Label
Specify a label to classify Slave Nodes into groups. Slave Nodes which have the same
label will be regarded as the group.
This is useful when you wish to assign a Slave Node to use for a certain process. Specify a
Slave Node group by the label with a parameter “SlaveNodeLabel” for each Component,
then the Component will be processed on one of Slave Nodes in the specified group.
You can skip this field when you do not need to classify Slave Nodes into groups.

• Protocol version
Please specify the protocol version 1.0 to use node for ASFALIS TransServer and ASFALIS
Desktop, and specify the protocol version 2.0 to use node for Aras Connection Option.

[Elysium License Server settings]

• Hostname / Port number
The information of the license server which CAD adapter and optimizer components use.

4.2. Component Settings
We set the information which is necessary to execute components, including activation of
components to use, destination folders of CADs, and so on.
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[ASFALIS Common settings]

• ASFALIS module folder
Specify the folder where the ASFALIS module which is used by ASFALIS Slave Node is
installed. You don’t need to change the value in general operation, because the folder of
ASFALIS module included in ASFALIS Slave Node is specified.

[Settings of enabled components]

• Selectable components
The list of the components (CAD adapter and optimizer components) which are selectable
in this Slave Node.

• Enabled components
Lists all Components which are available to run on that Slave Node. Please refer to 4.3,
“Add / Delete Components” for how to enable / disable Components for each Slave Node.

4.3. Add / Delete Components
1. Select the component you want to use in the list of "Selectable components," and click [Add].

◦ You have to add “Heal” component.
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2. When you add the component which has the required parameters, the following dialog
appears. Click [Yes] and the parameter setting starts. If you click [No], you can set
parameters later with clicking [Setting] at the top of "Enabled components" list.

3. Component Detailed Setting dialog appears in the case you click [Yes] or [Setting] in Step 2.
You can set the required parameters including destination folders of CAD or boot programs
(the background of the value column is colored red), and the optional parameters including
template files or the timeout in getting licenses.
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Below are the descriptions on the legacy and the new adapter components.

◦ Legacy adapter:
This is the adapter component which has been used since before ASFALIS version EX5.2.
Regarding adapters which have been available since before ASFALIS version EX5.2,
basically this legacy type adapter will be used by default even with ASFALIS version
EX6.0 or later.

◦ New adapter:
This is the adapter component which is newly introduced since ASFALIS version EX6.0.
New adapter will be used by default for some adapters.

4. Click [OK], and the setting finishes.

Slave Node can also run as a Windows service. However, some of the ASFALIS components are
not capable of running on Slave Node that is running as a service.
At this point, the following is the ASFALIS component availability on Slave Node registered as
Windows service. Non-supported components should be run on Slave Node that are not
registered as Windows service.

Component Name Availability Note

CATIA V5(CAA) Yes -
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Component Name Availability Note

3DEXPERIENCE 3DEXPERIENCE to ENF:Yes
ENF to 3DEXPERIENCE:No

-

CATIA V4 Yes -

NX I-deas No -

Parasolid Yes -

NX(UFUNC) Yes -

Creo Parametric Yes -

Autodesk Inventor Yes -

Creo Elements/Direct Modeling \Yes -

ACIS Yes -

STEP Yes -

STEP AP242 BOM Yes -

IGES Yes -

SOLIDWORKS No -

JT Yes -

PLM XML Yes -

iCAD Yes -

CATIA V5 (standalone) Yes -

Creo Parametric (standalone) Yes -

NX (standalone) Yes -

CADmeister (standalone) Yes -

XVL Yes -

STL Yes -

3D PDF Yes -

3DXML Yes -

Healing Yes -

PDQ Checker Yes -
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Component Name Availability Note

Geometry Simplifier Yes -

CAD Validator Yes -

ENF Polygon Yes -

Polygon Optimizer Yes -

Attribute Editor Yes -

Assembly Editor Yes -

Interference Checker Yes -

ENF Editor Yes -


Whether the custom component can operate as a service depends on the
service support of the executable or batch file called from the custom
component.

4.4. Register and Delete Windows Service
ASFALIS Slave Node can be registered and started as a Windows service. When registered, Slave
Node will automatically start when the computer starts, so the user is not required to
interactively log in and start.
To register or delete the Windows service, follow these steps:

a. Register Windows Service

1. Select [Windows Service] > [Register] from the menu.

2. A dialog will appear. Enter the user name and password of the service execution user.


When you click [OK] without specifying a user name and password, the
local system account will be set as the service execution user.
In this case, please ensure to set the user name and password of the
user used to access the network folder path in step 6.



When the CAD license setting is associated with a user profile (e.g.,
CATIA V5), translation may fail if the service execution user is not
associated with the license settings.(e.g., local system account)
In such a case, the service execution user should be set as the user
associated with the CAD license setting.

3. When "User Account Control" warning dialog appears, click [Yes] if it is okay to execute.

4. Confirm the displayed dialog which indicates a successful registration of service.
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5. Select [File] > [Common Configuration] from the menu.

6. Enter the drive letter and network folder path (the same content that you specified in 2,
“Setup of Shared Network Folder”) in "Working Directory Settings". Also, if the user who
is running the service configured in step 2 does not have permission to access this path,
enter the user name and password of the user who has access right.

b. Delete Windows Service

1. Select [Windows Service] > [Delete] from the menu.

2. When "User Account Control" warning dialog appears, click [Yes] if it is okay to execute.

3. Confirm the displayed dialog which indicates a successful deletion of service.



When you register Slave Node as Windows service, it will automatically
start when the computer is booted. Therefore, the user does not have to
interactively log on to the computer and start it.
When you don’t register Slave Node as Windows service, the processing
information will be output to command prompt, so if an error occurs,
you will have more information.
An example of a usage would be to use the service for normal operation
of Slave Node, and when a problem occurs which needs to be
investigated or tested temporarily, interactively start it.
Depending on the purpose of use and assumptions, please select the
appropriate method.

4.5. Start ASFALIS Slave Node
ASFALIS Slave Node has the following three ways to start as a normal process. In addition,
ASFALIS Slave Node can run as a Windows service (ASFALIS Component Service EX*.*). EX*.*
means the version of ASFALIS Slave Node.


Please ensure that ASFALIS Slave Node running as a Windows service and
ASFALIS Slave Node running as a normal process do not coexist on the same
computer.
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

If ASFALIS Slave Node is running as a Windows service, do not start or stop
ASFALIS Slave Node from the [Slave Node Setting] window. When adding or
changing a node while ASFALIS Slave Node is running as a Windows service,
stop the service, change settings from [Node Settings], and start the service
again.



If ASFALIS Slave Node is running as a normal process, do not start the
Windows service of ASFALIS Slave Node. By default, ASFALIS Slave Node
service automatically starts when the computer is started. Disable automatic
start of the Windows service of ASFALIS Slave Node if necessary. When adding
a node or changing settings when executing as a normal process, stop the
node, change the settings from [Slave Node Settings], and start the node again.

4.5.1. Start as Normal Process

There are three ways to start / stop ASFALIS Slave Node as a normal process.

[Start/Stop from Program menu]

Start:
Execute [Start] > [All Applications] > [Elysium ASFALIS Component] > [start node EX*.*].
(EX*.* means the version of ASFALIS Slave Node)

Stop:
Press the X button at the top right of the window to close the command prompt whose name
begins with "ASFALIS-…"

[Start/Stop from Slave Node Setting dialog]

Start:

a. Right-click the node you want to start, and select [Start] from the context menu.

b. Execute the menu command [Run as Process] > [Start All].
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When the booting of ASFALIS Slave Node succeeds, the following window appears.

Stop:

a. Right-click the node you want to stop, and select [Stop] from the context menu.

b. Execute the menu command [Run as Process] > [Stop All].

[Start/Stop from the Command Line Interface]

You can start / stop Slave Nodes using the command line interface.
Execute “<Install folder>\bin_launcher\WorkerLauncher.exe” specifying arguments as
follows. For further information, execute “WorkerLauncher.exe /?.”

Starting / Stopping All the Slave Nodes Together
Start:
Execute specifying an argument “/Mode=start” to start all the Slave Nodes

> WorkerLauncher.exe /Mode=start

Stop:
Execute specifying an argument “/Mode=stop” to stop all the Slave Nodes >
WorkerLauncher.exe /Mode=stop

Starting / stopping Slave Node at Specified Port Start:
Execute specifying arguments “/Mode=start” and “/ListenPort={Port number}” to start Slave
Node using the specified port number only.

> WorkerLauncher.exe /Mode=start /ListenPort={Port number (*)}
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Stop:
Execute specifying arguments “/Mode=stop” and “/ListenPort={Port number}” to stop Slave
Node using the specified port number only.

> WorkerLauncher.exe /Mode=stop /ListenPort={Port number (*)}

(*) Specify the Slave Node to start/stop by the port number.

e.g., specify the following arguments to start Slave Node at port number 59859

> WorkerLauncher.exe /Mode=start /ListenPort=59859


Add an argument “/NoWindow” when executing “WorkerLauncher.exe” to
close it without showing the error details in case of an error. Otherwise, it
remains running with error details displayed when an error occurs.

4.5.2. Start as Windows Service

Use the following procedure to start and stop the service.

a. Start Windows Service

1. Select [Windows Service] > [Run] from the menu.


Please note that if the work directory is not set, an error dialog will
appear. Select [File] > [Common Settings] and specify the work
directory in the displayed dialog.

2. When "User Account Control" warning dialog appears, click [Yes] if it is okay to execute.

3. Confirm the displayed dialog which indicates that the service started successfully.

b. Stop Windows Service

1. Select [Windows Service] > [Stop] from the menu.

2. When "User Account Control" warning dialog appears, click [Yes] if it is okay to execute.

3. Confirm the displayed dialog which indicates that the service stopped successfully.


ASFALIS Slave Node can only be started as Windows service if all ports
configured to each node are available. Please note that if any port is used by
ASFALIS Slave Node started as a normal process or another application, the
Windows service will fail to start
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4.6. Set up more than one Slave Node
More than one node with different settings can be set in Slave Node Setting.

Duplicate existing node

One node can perform only one processing at once. So if you have more than one license
(ELYSIUM license and CAD license) for the same component, you can utilize your licenses by
setting more than one node with same settings.

Add new node

Add new nodes in the case that you want to create nodes which have completely different
components from existing nodes, such as creating dedicated node for specific CAD.

4.7. Advanced Settings
Check in the checkbox of [View] > [Show Advanced Setting] to show “Advanced settings” tab.
You can specify the environment variables which will be used only for ASFALIS Slave Node, and
so on.
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[Custom component]

• Custom component folder
This is the folder to add modules of external (non-ASFALIS) components.

[Common settings]

• Environment variables
This is to specify the environment variables which will be used for ASFALIS Slave Node.
The value specified in this section will be effective only for ASFALIS Slave Node.

4.8. Copy Configuration of Existing Slave Node
You can also set up Slave Node by copying the configuration of an existing Slave Node as
follows;

1. Select [Start] > [All Programs] > [Elysium ASFALIS Component] > [EX*.*] > [Setup Slave Node
EX*.]. ( “.*” will be replaced by the Slave Node version.)

2. Select [File] > [Import] in the “Slave Node Setting” dialog.

3. Select the configuration file of an existing Slave Node (stored at the path below), and click
[Open] in the dialog.

◦ <Slave Node installation folder>\<config>\ServiceConfig.xml

4. Confirm in the “Slave Node Setting” dialog that all the fields are filled for your needs, and
then click [OK] to start importing the settings.

5. Once the import is completed, click [Apply] in the dialog.

ASFALIS Slave Node Installation Guide

 © Elysium Co. Ltd. All rights reserved. Page 24 | 29





Please note that this includes the setting on adapter type (whether to use
legacy adapter or new adapter). This means that, even when installing a
version which is set to use new adapters by default, legacy adapters will be
used if the copy source Slave Node is set to use legacy adapters. 
If you wish to use new adapters with the new Slave Node, please modify the
adapter type setting after completing the Slave Node set-up by configuration
file copy.
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5. Notes

5.1. User Type to Run ASFALIS Slave Node
Please ensure to run ASFALIS Slave Node as a user with administrative privileges.

5.2. How to Check the Status of ASFALIS Slave
Node
Run the following command to check the status of corresponding ASFALIS Slave Node, and it
will return a value as follows (Please replace <port number> by the actual port number which
ASFALIS Slave Node uses.);

• "0" when ASFALIS Slave Node is running

• "1" when ASFALIS Slave Node is not running

• Command:
<ASFALIS Slave Node installation folder>\bin\check-slave-node-status.bat <port number>

E.g.,

• a) ASFALIS Slave Node on port number 59859 is running

>C:\ELYSIUM\ASFALIS_Component\EX*_*\bin\check-slave-node-status.bat 59859
>echo %ERRORLEVEL%
>0

• b) ASFALIS Slave Node on port number 59860 is not running

>C:\ELYSIUM\ASFALIS_Component\EX*_*\bin\check-slave-node-status.bat 59860
>echo %ERRORLEVEL%
>1

“EX*_*” will be replaced by the ASFALIS Slave Node version.

5.3. Troubleshooting when Running as a Windows
Service
Q1 : ASFALIS Slave Node running as a Windows service (ASFALIS Component Service
EX*.*) is active, but cannot be connected from other computers
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 Please note that "EX*.*" is a version of ASFALIS Slave Node.

• On the computer where ASFALIS Slave Node is installed, configure the firewall to allow
connection to the following executable file (Ruby).

<Elysium Ruby Installation folder>\v9\rubies\ruby-2.6.5\bin\ruby.exe

(Example: C:\ELYSIUM\Ruby\v9\rubies\ruby-2.6.5\bin\ruby.exe)

Q2 : Only a part of the configured nodes need to be started

• If ASFALIS Slave Node is running as a Windows service, starting or stopping only a part
of the configured nodes is not possible.

• When attempting to start a Windows service, all nodes will attempt to start. When all
nodes successfully start, the Windows service is in the "Running" state. If some nodes fail
to start, the Windows service will remain in the "Starting" state. In this case, check the
event log if there are any related events.

• When attempting to stop a Windows service, all nodes will attempt to stop. When all
nodes successfully stop, the Windows service is in the "Stopped" state. If some nodes fail
to stop, the Windows service will remain in the "Stopping" state. In this case, check the
event log if there are any related events.

Q3 : ASFALIS Slave Node running as a Windows service will not start

• For some reason ASFALIS Slave Node running as a Windows service fail to start, the
event log will record ID 828 or ID 829 event. Use the contents of the event as a reference
for troubleshooting. Note that if the Windows service starts/stops successfully, an event
with ID 0 is logged.

• If the cause cannot be identified from the event log, perform such operations as
rebooting the operating system to stop ASFALIS Slave Node running as a Windows
service. From [Slave Node Setting], start ASFALIS Slave Node as a normal process and
make sure it’s running properly. If any error is output, perform troubleshooting based on
the content as a clue.

Q4 : Windows service status remains "Starting" or "Stopping" and does not change

• There may have been some problems while the service was starting or stopping.
Information may have been output to the event log. Please check if an event with ID 828
or ID 829 has been recorded.

• If the status does not change after waiting for more than 20 minutes, stop all related
processes from Task Manager. Processes related to ASFALIS Slave Node are as follows.

◦ cmd.exe (Command line contains the string "start-slave-node.bat")

◦ cmd.exe (Command line contains the string "check-slave-node-status.bat")

◦ ruby.exe (Command line contains the string "start-slave-node.bat")
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◦ ruby.exe (Command line contains the string "check-slave-node-status.bat")

◦ ruby.exe (Command line contains the string "start-slave-node")

• If the cause cannot be identified from the event log, perform such operations as
rebooting the operating system to stop ASFALIS Slave Node running as a Windows
service. From [Slave Node Setting], start ASFALIS Slave Node as a normal process and
make sure it’s running properly. If any error is output, perform troubleshooting based on
the content as a clue.

Q5 : ID 1053 error appears when Windows service is started from the service management
tool

• If the service takes a long time to start due to heavy computer load, the error "Error 1053:
The service did not respond to the start or control request in a timely fashion." may be
output. "Error 1053: " is an error issued by the service management tool, and the service
continues to start after the error is displayed.

• Wait awhile, then refresh the display to make sure the status of the service is "Started" or
"Running". Also, if you start from the Services tab of the Task Manager, this error will not
be output even if the service takes a long time to start.

Q6 : Failed to translate

• Stop ASFALIS Slave Node running as a Windows service. Then from [Slave Node Setting],
run ASFALIS Slave Node as a normal process, and confirm that translation is successful.

◦ If translation fails even though the node is started as a normal process, check the log
file on ASFALIS Slave Node. Logs are output to the following folder:

▪ <ASFALIS Slave Node Installation folder>\log

◦ If translation succeeds when the node is started as a normal process, the service’s
logon user may not be able to access the share folder. Check the logon user’s access
privileges and network drive settings.

Q7 : How to prevent ASFALIS Slave Node from running as the Windows service
automatically

• From the service management tool, open the property of the ASFALIS Slave Node
running as the Windows Service (ASFALIS Component Service EX*.*), and change
"Startup Type" to "Manual". "EX*.*" is the version of ASFALIS Slave Node.

• If you no longer need the former version of ASFALIS Slave Node due to an upgrade and
such, change the "Startup Type" to "Manual".
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