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1. Introduction
This tutorial enables you to learn the operations of DFM Studio through expected use cases in
the design to manufacturing workflow.

A) Manufacturability consideration at the design stage

Expected users Product designer

Objective Improving design quality for manufacturability

B) Feedback to the design department at the production engineering stage for
manufacturability

Expected users Production engineering engineers

Objective Pre-consideration for manufacturability issues

C) Feedback to the product design department at the mold design phase for
manufacturability and mold requirements

Expected users Product manufacturers, mold manufacturers

Objective Improving the accuracy of manufacturing estimates and quoting

This tutorial aims to cover the A) use case.

Designers can use DFM Studio to improve the overall design quality by streamlining the check
by DFM Studio and redesign by CAD system.
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2. Overview of DFM Studio
This section explains the overview of DFM Studio solution. You will use the following
applications to run DFM check, analyze and evaluate the check result, export the check result,
and customize the parameter settings as required.

Application Description

DFM Studio Tool to run DFM check on CAD models
Check options (check criteria and threshold) are defined in the
parameter file (*.ini).

ASFALIS
SmartLauncher

One of the front-ends to use DFM Studio
This is to run DFM check from either CAD plug-in menu, or Windows
Explorer context menu.

ASFALIS TransServer One of the front-ends to use DFM Studio
This is to run DFM check via web browser.

DFM Studio Inspector
(hereinafter,
"Inspector")

Tool to analyze and evaluate the check result, and save the updated
check result file (*.far), and/or export the check result report (*.xlsx)

Model Viewer Tool to analyze and evaluate the check result visually on the CAD
model
(Launched automatically when launching Inspector)

Parameter Settings
Tool

Tool to customize the parameter settings of DFM Studio, and save as
the parameter file (*.ini)
(Launched from ASFALIS SmartLauncher dialog)
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3. Preparation
1. Confirm that "tutorial_setting.ini" (the parameter file pre-set for this tutorial) is placed in

Scenario folder (e.g., C:\Elysium\scenario\shared_param\plastic_check)".
Please refer to "DFM_Studio_Installation_Guide_en.pdf" for the details about Scenario
folder.

2. Find a sample CAD model. Sample CAD models are available for each CAD format as follows.
In this tutorial, we use Creo Parametric sample model as an example.

Creo Parametric

…\base\doc\DfmStudioInspector\tutorial\models\Creo

NX

…\base\doc\DfmStudioInspector\tutorial\models\NX

SOLIDWORKS

…\base\doc\DfmStudioInspector\tutorial\models\SOLIDWORKS

ENF (Elysium Neutral File)

…\base\doc\DfmStudioInspector\tutorial\models\ENF


◦ Use ENF model if you are using CAD systems other than Creo

Parametric, NX, or SOLIDWORKS, or if you do not have DFM
Studio Creo Connector, DFM Studio NX Connector, nor DFM
Studio SOLIDWORKS Connector.
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4. Inspector Window Layout

Name Description

A Title Bar Shows the filename of currently opened check result file.

B Menu Bar Lists commands for Inspector and the check result file.

C Command Bar Lists commands for Item List.

D Breadcrumb
Navigation

Shows the location in Item List.

E Item List Shows the list of items (check criteria, checked areas, etc.).

F Property List Shows the properties of the checked area item selected in Item List.

G Status Bar Shows the statistics of Item List.
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5. Inspector Command Lineup

5.1. Menu Bar
This is a command lineup of Menu Bar at the top in Inspector.

Command name Description

A [File] To open/save the check result file (*far), etc.

B [Zoom Out] / [Zoom In] To change the zoom factor of Inspector.

C [Launch Model Viewer] To launch Model Viewer.

D [Re-run DFM Check] To launch "Run Scenario" dialog, and re-run check
after engineering changes, etc.

E [Export Report] To launch "Run Scenario" dialog, and export the check
result report.

F [Help] > [Open Inspector
Operation Manual]

To open Inspector operation manual.

F [Help] > [About License] To open the license agreement.

F [Help] > [About DFM Studio
Inspector]

To open version information.

G [Notification] To show the notifications.
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5.2. Command Bar
This is a command lineup of Command Bar located below Menu Bar in Inspector.

Command name Description

H [View Operation] To switch the view mode in Model Viewer.

I [Edit Property] To edit/bulk-edit property values (Evaluation,
Comment) on the selected checked area(s).

J [Show/Hide Column] To show/hide each property in Item List.

K [Assign a View Command] To assign a view command to operations (select item(s)
/ double-click an item) in Inspector.

L [Filter Result] To filter Item List.
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6. DFM Check Workflow

Checking within DFM Studio requires the following steps:

Step 1: Check Execution

Step 2: Result Evaluation

Step 3: Model Modification and Re-check

Step 4: Share Result

The following section will explain the operation to check for design issues that could decrease
manufacturability, modify CAD model and re-check, and export a report.
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7. Operation Flow

7.1. Step 1: Check Execution
Step 1 explains the check execution flow.

Step 1.1 Open CAD Model

1. Open the following file from ASFALIS SmartLauncher for Creo.

…\base\doc\DfmStudioInspector\tutorial\models\Creo\before_creo.prt


Refer to
"ASFALIS_SmartLauncher_for_DFM_Studio_Installation_Guide_en.
pdf" for installation and operation details.
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Step 1.2 Launch ASFALIS Smart Launcher

1. Select [Run DFM Scenario] from the Elysium menu to launch ASL.
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Step 1.3 Select Scenario and Parameters

1. Select "DFM Check | Plastic | Creo Parametric Plug-in" from the Scenario section
dropdown list.

2. Select "tutorial_setting" from the Parameter section pull-down menu.

3. Confirm that the output folder is set, and then click [OK] to execute the check.


Refer to 8.1, “Parameter Settings” or
"DFM_Studio_Parameter_Settings_Tool_Admin_Manual_en.pdf" for
details on how to set parameters.
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Step 1.4 Check Progress

1. After the check starts, the translation list dialog as below will appear automatically to
show the progress of the check.

Step 1.5 Open the Check Result from the Translation List

1. After the check ends, a notification will appear, and the check result can be opened.
Click  to launch Inspector and Model Viewer, and open the check result file.
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7.2. Step 2: Result Evaluation
Step 2 will explain the check result confirmation and evaluation flow.

In the check result file (*.far),

[Result] property (Pass / Fail)

Shows whether the checked area passed the check.

[Evaluation] property (TBD / Pass / Fail)

Shows the evaluation status as described in the table below.
The table below shows the correspondence between two properties.

[Result] property [Evaluation] property

Pass • Pass: This means that you can exclude this area from the
evaluation. All checked areas which passed the check will
be set to this automatically.

Fail • TBD: This means that you need to analyze and evaluate this
checked area. All checked areas which failed the check will
be set to this by default.

• Pass: Change to this if the checked area is fine as is.

• Fail: Change to this if the checked area needs to be
modified. Use [Comment] property to leave comments as
required.

Refer to 8.3, “Check Result Evaluation Flow” for check result evaluation flow details.
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Step 2.1 Confirm Check Results Using Inspector

1. Select "Plastic" within Inspector to display the list of the checked items.

Confirm check item list

The check item list shows the result using the following criteria.

Column header Description

Name Check item name

Pass Number of results within the check threshold

Fail Number of results evaluated as an error and the model needs
to be modified

TBD Number of results that are out of range of the check threshold,
but the evaluation has not yet been made
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Step 2.2 Check the Detected Result (Zoom, Section View)

This tutorial will focus on "wall thickness", which is a common issue in plastic
manufacturing.

1. Select "1.1 Thick wall".
All thick walls in the model will be listed (default threshold is 3.5 mm or more).


Thick walls could lead to manufacturability issues such as sink
marks.

2. Select the check next to "Name" which highlights all results and shows the dimensions.

3. Select ID 1 to focus on the specific result. Double-click the list to zoom to the specific area.
The zoom is synchronized with the CAD system as well.
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

◦ Using the section view can be convenient for viewing the
check result in Model Viewer.

▪ Select a checked area, and select [Section View] from the
context menu to show the selected checked area in section
view.

4. Confirm the zoom synchronization at the checked area in the CAD system as well.

5. Confirm the thick wall threshold by referring to the information in the "Property" tab at
the lower part of Inspector.

Step 2.3 Evaluate and Add Comments

1. Add comments to thick wall check results where the geometry needs to be modified.

a. Change the value of Evaluation property from "TBD" to "Fail" in [Property (Property)]
List.

▪ E.g., the wall thickness value of [1.1 Thick Wall] > [ID 1] ("before_creo.prt") is
greater than the threshold (default threshold: 3.5 mm), so Result property is set to
"Fail".
The wall thickness value of this area is outside the allowed range, and needs to be
modified, so change the value of Evaluation property to "Fail".

b. Add a comment if there are any messages that needs to be communicated for the
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check result.

▪ Open [Property (Comment)] List, and insert a comment text to add a comment to
the selected checked area.

▪ Or select a checked area in Item List, and select [Edit Property] from the context
menu to edit the value of Evaluation property and/or add a comment.

Step 2.4 Save Check Result File (*.far)

1. Select [File] > [Save] / [Save As] from the top left of the Inspector screen to save the edits
on the check result file (*.far).
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

◦ A message will appear to prompt you to save edits on the result file if
unsaved changes exist when closing Inspector, or running re-check,
etc.
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7.3. Step 3: Model Modification and Re-check
Step 3 explains the flow to modify the model as needed based on the check result and perform a
re-check of the model. This step will also cover the confirmation of other check items.

Step 3.1 Zoom into the Checked Area

1. Modify the CAD model based on the check result.

a. Zoom into ID 1 of "1.1 Thick Wall".


▪ Zoom will be synchronized between Inspector and the CAD

system.
This will make it easier to find the area to modify in the
CAD system.

Step 3.2 Modify CAD Model



• Step 3.2 to Step 3.3 are the processes to modify the detected areas
back in the CAD system, which you are most probably confident
at. Go to [Step-3.4] if you wish to skip those processes. Tutorial
CAD models whose names start with "after_" (available in
…\base\doc\DfmStudioInspector\tutorial\models\<CAD format>)
are the after-the-modification state models.

1. Modify the CAD geometry within the CAD system.

a. Change the wall thickness at ID 1 area from "4 mm" to "3 mm".
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Step 3.3 Save CAD Model

1. After modifying the model, save the CAD model.

Step 3.4 Launch ASL

1. As with the first check execution (refer to Step 1), select "Run DFM Scenario" in the CAD
Elysium menu to launch ASL.

Step 3.5 Start Check

1. Use the same Scenario ("DFM Check | Plastic | Creo Parametric Plug-in") and also use the
same parameter ("tutorial_setting") as before for the check.

Step 3.6 Confirm Modified Areas

1. Close Inspector if it is running.

2. Click  to launch Inspector and Model Viewer, and open the check result file.


◦ If the translation list does not appear, select the blinking

application at the tool bar.

3. Confirm that the modified area is no longer detected.
You can also confirm that the other area which has not been modified yet are still
detected.

a. Modify this area back in the CAD system as well so that it will be no longer detected.
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Step 3.7 Additional Confirmation and View Capture

1. Check the result of "1.2 Thin Wall".


Thin walls could lead to manufacturability issues such as non-filling and
overfilling.

2. Select all checked areas (ID 1 to ID 4) as below to highlight them in Model Viewer.

a. ID 2 and ID 3 areas are the thin walls on blind holes. Check the blind hole depth in
section view, and modify the hole depth back in the CAD system so that the wall
thickness satisfies the minimum allowed thickness.
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

▪ Refer to the image below for the CAD modification in Creo
Parametric.

b. ID 1 and ID 4 areas are the engaging parts. Therefore, they are fine to be thinner than
the threshold, so change the Evaluation property from "TBD" to "Pass".
Evaluate the checked areas in this manner considering the design background.

DFM Studio Tutorial

 © 2022 Elysium Page 21 | 31



i. Check ID 1 area in section view, and update Evaluation property and add a
comment to it.
Refer to [Step-2.3] for the details about evaluating the check result and adding
comments as required.

c. Add view captures of the checked area.

i. Click [Capture Current View ] at [Capture #1] in [Property (Property)] List to
take a capture of 3D View in Model Viewer.

d. Click [Show ] to preview the saved view, and click again to close it.

DFM Studio Tutorial

 © 2022 Elysium Page 22 | 31





▪ You can include these view captures in the check result
report (*.xlsx) explained at [Step-4.2].

e. Select [File] > [Save] / [Save As] from the top left of the Inspector screen to save the
edits on the check result file (*.far).
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7.4. Step 4：Share Result
Automatically create a report from the edited check result and share with a third party.

Step 4.1 Export Report

1. Select [Menu Bar] > [Export Report] in Inspector.

Step 4.2 Share Report

1. Select "Export Report (Include Auto-capture) | Plastic" Scenario in the dialog.

2. Select "default" parameter setting and confirm the output folder, and then click [OK].

◦ Refer to "DFM_Studio_Parameter_Settings_Tool_User_Manual_en.pdf" for the details
about parameter settings.

◦ After the Excel report is created, you can open the folder where the Excel report is
saved from the "Open output directory" button in the translation list.
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▪ Open the Excel report and confirm that the first sheet is an overview of all the
check items.

▪ To confirm the details of each item, click on the check item name link.

▪ In addition to the manually added screen captures, an overall 3D view of the
check result as well as the section view screen capture that is automatically
captured will be shown as well.

▪ Any evaluations and comments will also be shown in the report. This will be
convenient for communications with other departments and customers or
suppliers.
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8. Tips

8.1. Parameter Settings
The tutorial used a pre-defined parameter file for the check, but different thresholds can be
specified based on the use case and/or material.

Refer to "DFM_Studio_Parameter_Settings_Tool_User_Manual_en.pdf" for how to use Parameter
Settings Tool.
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8.2. Run DFM Check from Windows Explorer
You can run DFM check from the Windows Explorer context menu as well. Use this way if you
are using CAD systems other than the followings.

• Select a CAD file in Windows Explorer and select [Elysium] > [Run Scenario] from the
context menu. Refer to Step 1.3 for scenario and parameter settings and execute check.

◦ Creo Parametric

◦ NX

◦ SOLIDWORKS
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8.3. Check Result Evaluation Flow
• Step A: Confirm automatically judged result

◦ For each checked area, DFM Studio automatically judges the result based on the design
standards (specified parameters).

▪ The initial result will be classified to either "Pass" or "TBD".
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• Step B: Implement evaluation

◦ Select the check item that has results for "TBD" and confirm the "Fail" results. Use
Inspector’s filter  function to show only the "Fail" results.

▪ The evaluation can be changed to "Pass" for "Fail" areas considering design
standards and past experiences.
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• Step C: Save evaluation result

◦ When all the check results are evaluated, "TBD" items would be 0, which completes the
evaluation step.

◦ Save check result (*.far).

 It is recommended to save frequently while evaluating the check result.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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