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1. What is DFM Studio Inspector?
DFM Studio Inspector (hereinafter "Inspector") is a tool to analyze the check result (*.far)
created in DFM Studio Checker.
It facilitates you to analyze the result synchronizing with Model Viewer which visualizes the
result on 3D CAD models. It lists all the result, and you can sort and/or filter the result to reach
the significant errors efficiently. You can also visually check the selected result in Model Viewer.
In Model Viewer, you can switch the view mode between 3D view with or without
surroundings, 2D section view, etc. for your needs.

Moreover, you can update the check result (*.far) in Inspector by adding information as
property values (Evaluation, Capture, and Comment). You can utilize the check result (*.far)
updated in Inspector as a proof that the product/mold is designed in conformity to the
standards, basis for decision of engineering changes, etc.

This manual explains the operation flow and functions of Inspector and Model Viewer.
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2. Inspector Window Layout

Name Description

A Title Bar Shows the filename of currently opened check result file.

B Menu Bar Lists commands for Inspector and the check result file.

C Command Bar Lists commands for Item List.

D Breadcrumb
Navigation

Shows the location in Item List.

E Item List Shows the list of items (check criteria, checked areas, etc.).

F Property List Shows the properties of the checked area item selected in Item List.

G Status Bar Shows the statistics of Item List.
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3. Inspector Command Lineup

3.1. Menu Bar
This is a command lineup of Menu Bar at the top in Inspector.

Command name Description

A [File] To open/save the check result file (*far), etc.

B [Zoom Out] / [Zoom In] To change the zoom factor of Inspector.

C [Launch Model Viewer] To launch Model Viewer.

D [Re-run DFM Check] To launch "Run Scenario" dialog, and re-run check
after engineering changes, etc.

E [Export Report] To launch "Run Scenario" dialog, and export the check
result report.

F [Help] > [Open Inspector
Operation Manual]

To open Inspector operation manual.

F [Help] > [About License] To open the license agreement.

F [Help] > [About DFM Studio
Inspector]

To open version information.

G [Notification] To show the notifications.
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3.2. Command Bar
This is a command lineup of Command Bar located below Menu Bar in Inspector.

Command name Description

H [View Operation] To switch the view mode in Model Viewer.

I [Edit Property] To edit/bulk-edit property values (Evaluation,
Comment) on the selected checked area(s).

J [Show/Hide Column] To show/hide each property in Item List.

K [Assign a View Command] To assign a view command to operations (select item(s)
/ double-click an item) in Inspector.

L [Filter Result] To filter Item List.
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4. Launch Inspector / Model Viewer
1. Launch Inspector by one of the following four ways.

Launch from the desktop shortcut created during the installation.

Launch from the Windows Start menu.

Launch from the translation list of ASFALIS SmartLauncher.

◦ Click  to launch Inspector if it is not running.

Launch from the plug-in menu of ASFALIS SmartLauncher.

◦ Click [Open] to launch Inspector and open the result file.
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◦ The plug-in is available for the following CAD systems only:

▪ Creo Parametric

▪ NX

▪ SOLIDWORKS


It requires a license on CAD Connector to launch Inspector
from ASFALIS SmartLauncher CAD plug-in.

2. A dialog will appear when launching Inspector.
Click [Yes] to launch Model Viewer as well.



You can also launch Model Viewer from [Menu Bar] > [Launch Model
Viewer] in Inspector.


Inspector and Model Viewer will be displayed side-by-side to each
other, and cannot be separated.
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5. Open Check Result (*.far)
1. Open the check result file (*.far) by one of the following four ways.

Drag-and-drop the result file to Inspector or Model Viewer.


Please note that dragging-and-dropping to Model Viewer functions
only when Model Viewer is connected to Inspector.

Open from [Menu Bar] > [File] in Inspector.

Open from the translation list of ASFALIS SmartLauncher.

◦ Click  to open the check result file.

◦ Inspector will be launched automatically if it is not running.
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Open from the plug-in menu of ASFALIS SmartLauncher.

◦ Open from [Menu Bar] > [Open].

◦ Inspector will be launched automatically if it is not running.

◦ You can synchronize the 3D view between the CAD system and Model Viewer when
opening the check result file from the CAD plug-in. Please refer to [anchor-7] for how
to synchronize the 3D view.

◦ The plug-in is available for the following CAD systems only:

▪ Creo Parametric

▪ NX

▪ SOLIDWORKS


It requires a license on CAD Connector to open the result
file from ASFALIS SmartLauncher CAD plug-in.
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6. Check File Information
• Select [Menu Bar] > [File] in Inspector to check the file location and the last updated date.

• Select an item on the first level in Item List to check the FAR version of the check result file,
the start / end date and time, and the used parameter settings that are common for all check
criteria per category in Property List.

◦ Check the checkbox  on the left of the item to select it, and then the properties will be
displayed in Property List.
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◦ Click  to check the common parameter settings.
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7. Analyze Result Summary
1. Move to Check Criteria List level in Item List to check the summary of the check result.

◦ Select a check type in Item List to move to Check Criteria List level.

7.1. Check Evaluation Status ([Pass] / [Fail] / [TBD])
• The check result summary is shown per check criterion in Item List.

After the check, checked areas that passed will be counted as [Pass], and those that did not
pass will be counted as [TBD].

• Item List will be updated as you update the value for Evaluation property in Property List.

7.2. Check Used Parameter Settings
• Click  to check the parameter settings for the selected check criterion.
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7.3. Check Explanation of Check Criteria
1. Click  at [Check Criterion Overview] in [Property (Property)] List to show an image that

explains the corresponding check criterion.

◦ Please refer to Check Item Guide for the details about each check criterion.
Check Item Guide is versioned per product release, and downloadable from the
dedicated URL. Please contact to your system admin if missing.
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8. Analyze Result in Detail
1. Move to Checked Area List level in Item List to check the details of the check result.

◦ Select a check, and then a check criterion in Item List to move to the Checked Area List.

2. Select a checked area in Checked Area List level to analyze it in detail in Model Viewer.

◦ The following details will synchronize between the 3D model in CAD system and the 3D
model in Model Viewer when opening the check result file from the CAD plug-in.

▪ Viewpoint

▪ Highlight on the part, face, edge, or vertex
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• The 3D view synchronizes under either of the following conditions.

When opening a part model (*.far) in Model Viewer

◦ The part with the same part name is opened in the CAD system.

◦ The parent assembly model is opened in the CAD system, and the part with the same
part name is activated (or set to "work part" in NX).

When opening an assembly model (*.far) in Model Viewer

◦ The assembly with the same assembly name is opened in the CAD system, and the top
assembly is activated.

8.1. Analyze Checked Area in Detail
• Select a checked area in Item List, and its property values will be displayed in Property List.

Please refer to "DFM_Studio_CheckItem_Guide_Plastic/Sheet-metal_en.pdf" for the
properties for each check criterion.

• You can also show the property values in Item List.

◦ Add / Remove properties to show in Item List from [Command Bar] > [Show/Hide
Column].
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8.2. Switch View Mode of 3D View
• Switch the view mode of 3D View of Model Viewer from Inspector by selecting one of the

following three ways.

◦ Set up the view mode for selecting / double-clicking an item in Item List from [Command
Bar] > [Assign a View Command].

▪ Select [None (Don’t assign a command)] not to assign a view command for selecting
row(s) or double-clicking on a row.

◦ Click [Command Bar] > [View Operation] to switch the view mode.

◦ Select an item in Item List, and right-click to switch the view mode from the context
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menu.


Please note that the view mode will be switched to the default
mode set from [Command Bar] > [Assign a View Command] when
selecting / double-clicking another item in Item List.
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8.3. Select Checked Area in 3D View
Select an element in 3D View of Model Viewer to check the corresponding checked area in
Inspector.

• Move to Checked Area List level in Item List, and then select an element (a face or an edge
depending on the check criterion) in 3D View. The corresponding checked area will be
selected in Item List.

◦ Please refer to 9, Filter Result for how to filter Item List using this function.
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8.4. Analyze Boss / Rib
• Some features including Boss and Rib for plastic models require the evaluation based on

many details.
Inspector shows the check result on such features collecting results on all related check
criteria, and the overall judgment based on them.
The overall judgment on DFM check will appear in [Result] column. It will be marked as
"Fail" when at least 1 criterion in that feature fails.

◦ Select a checked area in Item List, and select [Section View] from the context menu to
analyze it in section view without dimensions and formulas, or [Section View <Check
criterion>] to analyze it in section view focusing on that check criterion with the related
dimension(s) and the used formula.

◦ Please refer to "DFM_Studio_CheckItem_Guide_Plastic_en.pdf" for the details.
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8.5. Analyze Draft Angle
• For some features including the draft angle for plastic models, Inspector shows the check

result in multiple levels: the result overview on the first level, and the result details on the
lower levels.

◦ E.g., for the draft angle for plastic models, Inspector shows the overall judgment per
draft direction on the first level, and the check result overview of each draft direction on
the second level, and the result details of each draft direction on the third level.

▪ Set "Draft angle | Whether to show the check result for each draft direction
(CheckEachErrorArea.Flag)" parameter to "true" to enable this display method. (This
is set to "false" by default.)

▪ Please refer to "DFM_Studio_CheckItem_Guide_Plastic_en.pdf" for the details.
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9. Filter Result
• Click a column header to sort Item List by the value in that column.

◦ An arrow on the right of the column header shows the sort order,  for the descending
order, and  for ascending order.

• Click [Command Bar] > [Filter Result], and then set the filtering condition to filter Item List.

◦ The background color of [Filter Result] icon will change to  when filtering is active
in Item List.

◦ You can filter not only by Evaluation property value, but also, e.g., whether the height is
lower than the specified value, whether a capture is set, whether a comment is added,
and more.
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◦ Click [Command Bar] > [Clear Filter] to clear filtering.

▪ Move to Checked Area List level in Item List, and then select an element (a face or an
edge depending on the check criterion) in 3D View. The corresponding checked area
will be selected in Item List.
Click [Command Bar] > [Pull-down Menu] > [Show Selected Only] to show the
selected checked areas only.

DFM Studio Inspector Operation Manual

 © 2022 Elysium Page 23 | 41



10. Update Result with Evaluation
• Update Evaluation property value in Property List to add the evaluation to each checked

area.

◦ The value [Pass] means that the checked area passed the check, [Fail] means failed, and
[TBD] means the checked area needs to be determined, respectively.
After the check, checked areas that passed will be marked as [Pass], and those that did
not pass will be marked as [TBD].

▪ Analyze checked areas marked as [TBD], and update Evaluation property value in
Property List to [Pass] if it is fine as is, or [Fail] if it needs to be modified.

◦ Status Bar will be updated as you update Evaluation property value in Property List.

• Add a capture to each checked area at Capture #1 / Capture #2 / Capture #3 properties in
Property List.

◦ Click [Capture Current View ] to take a capture of 3D View in Model Viewer.

◦
Click [Show ] to preview the saved view, [Delete ] to delete the saved view, and
[Capture Current View ] to retake a capture.

• Add a comment to each checked area at Comment property in Property List ([Comment]
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tab).

• Select multiple checked areas, and then select [Bulk-edit Property] from the context menu to
bulk-edit the property values (Evaluation, Comment).


Please note that [Capture Current View ] will not function when
Model Viewer is not launched from Inspector.
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11. Save Updated Check Result (*.far)
Select [Menu Bar] > [File] > [Save] / [Save As] to save the updated check result file (*.far).
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12. Re-run Check
Re-run check on the currently opened CAD model with different parameter settings.

1. Select [Menu Bar] > [Re-run DFM Check], and "Run Scenario" dialog of ASFALIS
SmartLauncher will appear.

◦ The result file (*.far) currently opened in Inspector will be auto-set as the input file.

◦ A message will appear to prompt you to save edits when unsaved changes exist.

2. Select a Scenario.

3. Select parameter settings.

◦ [default] is pre-set.

◦ The administrator is authorized to register parameter settings on recheck beforehand,
and the registered settings will also be available in the pull-down list.


 on the left of parameter settings means that it is registered by

the administrator and is uneditable. Save it as a different name to
customize for your needs.

◦ Click  to launch DFM Studio Parameter Settings Tool, and view the details of the
selected setting, customize the registered settings, etc.

4. Specify the output folder.

5. Click [OK ] to re-run check.

6. Select a Job, and click [Open ] in the translation list of ASFALIS SmartLauncher to open
the new result (*.far) in Inspector once the Job is completed.
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13. Export Report (*.xlsx)
Export the check result report in Excel format as follows.

1. Select [Menu Bar] > [Export Report], and "Run Scenario" dialog of ASFALIS SmartLauncher
will appear.

◦ The result file (*.far) currently opened in Inspector will be auto-set as the input file.

◦ A message will appear to prompt you to save edits when unsaved changes exist.

2. Select a Scenario.

[Export Report | Plastic] / [Export Report | Sheet Metal] Scenario

◦ The check result report will include captures created with [Capture Current View
] only (no auto-captures).

[Export Report (Include Auto-capture) | Plastic] / [Export Report (Include Auto-
capture) | Sheet Metal] Scenario

◦ The check result report will include auto-captures as well as captures created with
[Capture Current View ].

3. Select a parameter setting.
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◦ [default] is pre-set.

◦ The administrator is authorized to register parameter settings on report export
beforehand, and the registered settings will also be available in the pull-down list.


 on the left of parameter settings means that it is registered by

the administrator and is uneditable. Save it as a different name to
customize for your needs.

◦ Click  to launch DFM Studio Parameter Settings Tool, and view the details of the
selected setting, customize the registered settings, etc.

◦ Set parameters on report settings for your needs.

Parameter name Description Allowed values

Language Setting Specify the language for the
check result report (*.xlsx).
This is set to "en" (English) by
default when running DFM
Studio in English.

"en": English
"ja": Japanese
"zh-CN": Chinese (Simplified)

Whether to export
Fail areas only

Specify whether to limit the
export target to Fail areas only.
This is set to "FALSE" by
default.

TRUE: Limit to Fail areas only
FALSE: Don’t limit (Export all
checked areas (Pass / Fail /
TBD))
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Parameter name Description Allowed values

Whether to export
Pass / TBD areas
with comments

Specify whether to export Pass
/ TBD areas with comments in
addition to Fail areas.
This is set to "FALSE" by
default.
This is effective only when
"Whether to export Fail areas
only" parameter is set to
"TRUE".

TRUE: Export Pass / TBD areas
with comments as well
FALSE: Don’t export Pass / TBD
areas with comments

Whether to export
Pass / TBD areas
with captures

Specify whether to export Pass
/ TBD areas with captures in
addition to Fail areas.
This is set to "FALSE" by
default.
This is effective only when
"Whether to export Fail areas
only" parameter is set to
"TRUE".

TRUE: Export Pass / TBD areas
with captures as well
FALSE: Don’t export Pass / TBD
areas with captures

Number of used
cores

Specify the number of cores to
use in result report export
(auto-capture generation) by a
positive integer number.
This is set to "1" by default.
Please note that it may cause a
high CPU consumption to set a
large value.
The specified value will be
treated as "all cores" when it
exceeds the total number of
cores of the environment.

An integer number from "1" up
to the total number of cores of
the environment

▪ Please refer to "DFM_Studio_Quick_Start_Guide_en.pdf" for the details of report
parameter settings using DFM Studio Parameter Settings Tool.

4. Specify the output folder.

5. Click [OK ] to export a report.

6. Select a Job, and click [Open output directory ] in the translation list of ASFALIS
SmartLauncher to open the output folder once the Job is completed.
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
It requires a license on DFM Studio Reporter to export check result
reports.
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14. Model Viewer
This chapter explains the key features of Model Viewer. Please refer to Model Viewer Help file
for details.

14.1. Panel
Each panel shows information of the currently opened CAD model. They are tabbed by default.

• Move the mouse over the tab on the left edge of the application window to open the panel.

• Click  at the top right corner of the panel to pin the panel.

Panel name Description

[Main] panel This is a panel to show the assembly structure. You can also
show/hide elements in 3D View window.

[Property] panel This is a panel to show properties and coordinates.

[Information]
panel

This is a panel to show dimensions measured in Model Viewer.

[Control] panel This is a panel to manage captures.
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14.2. View Mode
Switch the view mode as appropriate to increase the visibility.

14.3. Fix Rotation Center
Set the rotation center manually when the auto-set rotation center is not good.

1. Right-click an empty space in 3D View and select [View Center] from the context menu, and
then select an element to set the rotation center at where you clicked.
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14.4. Smart Filter
Use Smart Filter to filter the selectable elements in 3D View by the element category. It is set to
"Smart Filter" (no filtering) by default.

14.5. Show/Hide Part
Hide unnecessary parts to increase the visibility when analyzing an assembly model.
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

Please note that the active Camera set in [Control (View system)] panel
will be prioritized.
Click [Reset] in [Control (View system)] panel beforehand when a
Camera is active to show/hide desired part(s).

14.6. Display in Original CAD Color
Click [Display in Original CAD Colors] to show the CAD model in 3D View in its original colors.
Otherwise, CAD models will be displayed in a basic single color (Model Viewer default color) so
that you can easily distinguish the highlighted area from the rest.

14.7. Dimension
Use dimension tools to measure the distance between two elements.
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14.8. Check Wall Thickness (Entire Part)
Measure the wall thickness of the entire part. The result will be displayed in color map.
This is effective when you wish to check the wall thickness distribution.

1. Select [Menu Bar] > [Tool] > [Analysis] > [Thickness] > [Check Thickness (Entire Part)].

2. Select the target part in 3D View or in [Main] panel when working on an assembly model.
Skip this when working on a single part model.

3. Specify the maximum thickness to measure and the measurement interval, and then click
[OK] in the dialog.

The result will be shown in color map once the measurement is completed.
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How to customize the maximum thickness and the display settings

1. Select [Menu Bar] > [Tool] > [Analysis] > [Thickness] > [Display Settings].

2. Edit the display settings, and then click [OK] in the dialog. The customized settings
will be discarded when closing Model Viewer.

3. Click [Save Setting] to save the settings.

4. Click [Load Setting] to apply another saved setting.

5. Select a setting, and then click [OK] in "Load Setting" dialog. The selected setting
will be applied in "Color Setting" dialog.

DFM Studio Inspector Operation Manual

 © 2022 Elysium Page 37 | 41



14.9. Check Wall Thickness (Specified Point Only)
Measure the wall thickness of the specified point.

1. Select [Menu Bar] > [Tool] > [Analysis] > [Thickness] > [Check Thickness (Specified Point
Only)].

2. Select a point on a face to measure the thickness. The target point will be indicated with an
inscribed sphere, and the result will be shown in [Information] panel.
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14.10. Display Settings - Configuration File
Edit the configuration file (*.ini) as follows to customize the display settings of Model Viewer.

1. Create a configuration file to the following path.

<Model Viewer installation folder>\bin.x64\Addon\AddonDfmViewer.ini

2. Write "DfmViewer" section, and set the following parameter(s).

Parameter key Description Allowed values

ShowHidingEleme
nt

Specify whether to show the
hidden lines.

true: Show hidden line

HiddenLineColorRa
tePerFace

Specify the brightness of the
hidden lines by a positive
integer number.

An integer number between "0"
(dark) to "100" (same as the face
color)

DrawLineComposi
ngPolygonMesh

Specify whether to show the
polygon lines except for the
model outline.

true: Show polygon lines

HiddenLineWeight
OfFace

Specify the line weight of the
hidden lines by an integer
number.

An integer number between "0"
(light) to "5" (heavy)

HiddenLineColorOf
PolygonMesh

Specify the line color of the
hidden lines.

0: Black
1: Red
2: Green
3: Blue
4: Yellow
7: White

Here are sample settings for your reference.

[DfmViewer]
ShowHidingElement=true
HiddenLineColorRatePerFace=80
DrawLineComposingPolygonMesh=true
HiddenLineWeightOfFace=3
HiddenLineColorOfPolygonMesh=7
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15. Configuration File
Edit the configuration file (*.toml) with a text editor as follows to customize the settings of
Inspector.

1. Create a configuration file to the following path when it does not exist there.

%APPDATA%\ELYSIUM\DFM Studio Inspector\config.toml

2. Set the following parameter(s).

Parameter
key

Description Allowed values

modelViewe
rAutoViewer
Start

Specify whether to launch Model
Viewer automatically when
launching Inspector.
This is set to "confirm" by default.

true: Launch automatically
false: Don’t launch
confirm: Open a confirmation
dialog every time

zoomFactor Specify the default zoom factor of
Inspector window.
This is set to "0.9" by default.

A positive decimal number
(E.g., "0.75", "1.2" )

Here are sample settings for your reference.

• To automatically launch Model Viewer when launching Inspector.

modelViewerAutoViewerStart = true

• To increase the default zoom factor of Inspector window to 115 percent.

zoomFactor = 1.15


Please ensure to place a single half-width space before and after the
equal sign ("=").
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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