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1. Overview
This document explains how to install DFM Studio applications. Installers are provided per
application.
You can run DFM Studio either via ASFALIS SmartLauncher or ASFALIS TransServer.
So, please install applications as appropriate considering the workflow, the number of licenses,
load balancing, etc.

1.1. List of Applications to Install
The table below shows the installation package of each application and the installation guide.

Table 1. Installation package and installation guide

Application Installation package Installation guide

Sentinel RMS
License Manager

license_server_for_dfmstudio
_v#.#.#.zip

• 1.2, “Install Sentinel RMS License
Manager”

• Sentinel RMS License Manager
Setup & Quick Start Guide

◦ Available in
license_server_for_dfmstudio_v#
.#.#\document

DFM Studio
Parameter Settings
Tool

dfmstudio_v#.#.#_parameter_
settings_tool.zip

• 2.2, “Prepare & Set Parameter File”

• DFM Studio Parameter Settings Tool
Administrator’s Manual

◦ Available in
dfmstudio_v#.#.#_parameter_sett
ings_tool\document

ASFALIS
SmartLauncher
for DFM Studio

smartlauncher_for_dfmstudi
o_v#.#.#.zip

• 2.1, “Install ASFALIS
SmartLauncher”

• Elysium ASFALIS SmartLauncher
for DFM Studio Installation Guide

◦ Available in
smartlauncher_for_dfmstudio_v
#.#.#\document
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Application Installation package Installation guide

ASFALIS
TransServer for
DFM Studio

transserver_for_dfmstudio_v
#.#.#.zip
dfmstudio_v#.#.#_scenario_ch
eck.zip
dfmstudio_v#.#.#_scenario_ch
eck_report.zip
dfmstudio_v#.#.#_scenario_re
port.zip

• 3.2, “Install ASFALIS TransServer”

• ASFALIS TransServer Installation
Guide

◦ Available in
transserver_for_dfmstudio_v#.#.
#\document

ASFALIS Slave
Node for DFM
Studio

slavenode_for_dfmstudio_v#.
#.#.zip

• 3.1, “Install ASFALIS Slave Node”

• ASFALIS Slave Node Installation
Guide

◦ Available in
slavenode_for_dfmstudio_v#.#.#\
document

DFM Studio
Inspector

dfmstudio_v#.#.#_inspector.zi
p

• 2.3, “Install DFM Studio Inspector”

• DFM Studio Installation Guide (This
document)

3DxSUITE Viewer
(Model Viewer) for
DFM Studio

modelviewer_for_dfmstudio_
v#.#.#.zip

• 2.4, “Install 3DxSUITE Viewer
(Model Viewer)”

• DFM Studio Installation Guide (This
document)

DFM Studio Installation Guide
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1.2. Install Sentinel RMS License Manager
The licenses for Elysium products are managed by "Sentinel RMS License Manager" from Thales
Corporation.

1. Copy "license_server_for_dfmstudio_v#.#.#.zip" to a local folder (e.g., C:\temp) of a computer
to install to, and extract all.

2. Run the following installer to install Sentinel RMS License Manager.
Please refer to "Sentinel RMS License Manager Setup & Quick Start Guide" for the details.

Installer of Sentinel RMS License Manager

license_server_for_dfmstudio_v#.#.#\installer\setup.exe

Sentinel RMS License Manager Setup & Quick Start Guide

license_server_for_dfmstudio_v#.#.#\document\LicenseServer_QuickStartGuide_en.p
df



◦ It is not necessary to install Sentinel RMS License Manager to
the same computer as the computer which DFM Studio
application(s) are installed to.

◦ When installing Sentinel RMS License Manager to a different
computer, please ensure that the computer can communicate
with the computer which DFM Studio application(s) are
installed to.

◦ It is not necessary to install Sentinel RMS License Manager to
all computers which DFM Studio application(s) are installed to.
(Please install to one of the computers in your environment.)

DFM Studio Installation Guide
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2. With ASFALIS SmartLauncher
This chapter explains about the installation and setup of DFM Studio run via ASFALIS
SmartLauncher. Please refer to 3, With ASFALIS TransServer to run DFM Studio via ASFALIS
TransServer.

2.1. Install ASFALIS SmartLauncher
1. Copy "smartlauncher_for_dfmstudio_v#.#.#.zip" to a local folder (e.g., C:\temp) of a computer

to install to, and extract all.

2. Run the following installer to install ASFALIS SmartLauncher.
Please refer to "Elysium ASFALIS SmartLauncher for DFM Studio Installation Guide" for the
details.

Installer of ASFALIS SmartLauncher

smartlauncher_for_dfmstudio_v#.#.#\installer\setup.exe

Elysium ASFALIS SmartLauncher for DFM Studio Installation Guide

smartlauncher_for_dfmstudio_v#.#.#\document\ASFALIS_SmartLauncher_for_DFM_
Studio_Installation_Guide_en.pdf

DFM Studio Installation Guide
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2.2. Prepare & Set Parameter File
Prepare parameter file(s) in conformity to your company/organization standards, and place
them under Scenario folder registered to ASFALIS SmartLauncher so that pre-defined
parameter settings will become selectable in ASFALIS SmartLauncher.



• The parameter file explained here is to define the thresholds and
tolerances for geometry feature recognition and manufacturability
check during the check process in DFM Studio.

• Scenarios define the process details including CAD format of input
models, input model category (plastic / sheet metal), and whether to
export the result report.
E.g., "DFM Check & Report | Plastic | CATIA V5 Plug-in" is to run DFM
check on plastic models designed in CATIA V5, and then export the
result file (*.far) as well as the result report (*.xlsx).

DFM Studio Installation Guide
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1. Copy "dfmstudio_v#.#.#_parameter_settings_tool.zip" to a local folder (e.g., C:\temp) of a
computer to install to, and extract all.

2. Prepare parameter file(s) (*.ini) in conformity to your company/organization standards
using Parameter Settings Tool.
Parameter Settings Tool and the administrator’s manual are contained as follows in the
extracted folder.

DFM Studio Parameter Settings Tool - For Admin / For Plastic Model

dfmstudio_v#.#.#_parameter_settings_tool\util\dfms_param_set_plastic_admin_en.xls
m

DFM Studio Parameter Settings Tool - For Admin / For Sheet Metal Model

dfmstudio_v#.#.#_parameter_settings_tool\util\dfms_param_set_sheet-
metal_admin_en.xlsm

DFM Studio Parameter Settings Tool Administrator’s Manual

dfmstudio_v#.#.#_parameter_settings_tool\document\DFM_Studio_Parameter_Settin
gs_Tool_Admin_Manual_en.pdf

◦ Please refer to "DFM Studio Parameter Settings Tool Administrator’s Manual"
(another document) for how to prepare parameter files using Parameter Settings
Tool.

3. Use the following folder as Scenario folder, or copy it to any local or shared folder.

dfmstudio_v#.#.#_parameter_settings_tool\scenario


◦ Please ensure that Scenario folder is located in a shared folder

where related persons have Read permission to use the same
parameter settings in common among multiple persons.

4. Place the prepared parameter files to Scenario folder in the following folder structure.

DFM Studio Installation Guide
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"scenario" folder (Top folder)

This folder is specified as the scenario folder in ASFALIS SmartLauncher.

"dfms" folder

◦ scenario\dfms\check

This folder contains Scenarios to run DFM check.
Scenarios are classified by the CAD format. Delete unnecessary CAD format(s)
(scenario\dfms\check\<cad format>) if any, so that only the necessary Scenarios will
be selectable from ASFALIS SmartLauncher.

◦ scenario\dfms\param_set_exe

This folder contains the tool to edit parameter settings from the user interface of
ASFALIS SmartLauncher.


Please ensure not to add, remove, and/or modify the content of
this folder.

DFM Studio Installation Guide
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◦ scenario\dfms\recheck

This folder contains Scenarios to re-run DFM check.
Scenarios are common for all CAD formats.


Please ensure not to add, remove, and/or modify the content of
this folder.

◦ scenario\dfms\report

This folder contains Scenarios to export the result reports (*.xlsx).


Please ensure not to add, remove, and/or modify the content of
this folder.

"shared_param" folder

◦ scenario\shared_param\plastic_check

scenario\shared_param\plastic_report

scenario\shared_param\sheet-metal_check

scenario\shared_param\sheet-metal_report

These folders contain parameter files for the corresponding Scenario type
respectively.
Parameter files of the default parameter settings are provided in the standard
package of DFM Studio.


▪ Add prepared parameter files to appropriate folders so that

they will become selectable in ASFALIS SmartLauncher.

▪ Parameter files are common for all CAD formats.

DFM Studio Installation Guide
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5. Select [Elysium ASFALIS SmartLauncher] > [Preference] from Windows Start Menu.

6. Select [Feature] tab in the dialog.

7. Specify Scenario folder prepared above to "Scenario Folder" field by its absolute path, and
then click [OK].
E.g.)

\\share-server\scenario

DFM Studio Installation Guide
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Pre-defined parameter settings saved under Scenario folder will become selectable in
ASFALIS SmartLauncher.

DFM Studio Installation Guide
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2.2.1. Parameter Settings Tool



The authentication using the digital certificate will be required to enable
macros for Parameter Settings Tool (For Admin / For User) in case a
security warning message appears.
Please refer to the image below, and contact to your system
administrator accordingly.

DFM Studio Installation Guide
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2.3. Install DFM Studio Inspector
1. Copy "dfmstudio_v#.#.#_inspector.zip" to a local folder (e.g., C:\temp) of a computer to install

to, and extract all.

2. Run the following installer to install DFM Studio Inspector.

Installer of DFM Studio Inspector

dfmstudio_v#.#.#_inspector\installer\setup.exe

 Please ensure to run the installer as administrator.

2.3.1. Run DFM Studio Inspector

It requires Modify permission to the following to run DFM Studio Inspector.

• %TMP% / %TEMP%

• %APPDATA%

• DFM Studio check result file (*.far) output folder

2.3.2. System Requirements

Machine / CPU Machine and CPU capable of running OS listed below

OS Windows 10 Pro 64-bit (*1)

Memory 4GB or more (8GB or more is recommended)

Storage Min. 500MB free space

Graphic - Display capable of min. 1280 x 1024
- Graphic card that supports OpenGL and double buffering (*2)

(*1): Windows is a registered trademark of Microsoft Corp.
(*2): OpenGL is a registered trademark of Hewlett Packard Enterprise.

DFM Studio Installation Guide
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2.3.3. Install DFM Studio Inspector

1. Run the following installer to install DFM Studio Inspector.

dfmstudio_v#.#.#_inspector\installer\setup.exe

2. Select the language for the installation.

◦ Select "English", and then click [OK].

3. Install prerequisite(s) to the installation of DFM Studio Inspector.

◦ Click [Install] to install Runtime when this page appears.
This page will be skipped when prerequisites are already installed.

4. Set up DFM Studio Inspector.

◦ Click [Next].

5. Agree to the license agreement.

DFM Studio Installation Guide
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◦ Read the license agreement, select "I accept the terms in the license agreement" option,
and then click [Next].

6. Specify the installation folder.

◦ Specify the folder to install DFM Studio Inspector to, and then click [Next].

7. Confirm to start the installation.

◦ Click [Install] to start the installation of DFM Studio Inspector.
This page shows the progress of the installation.

DFM Studio Installation Guide
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8. Confirm the completion of the installation.

◦ Click [Finish] to exit the wizard.
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2.3.4. Silent-install DFM Studio Inspector

Silent-installation is a feature to install applications with no interactions on the graphical user
interface. This is useful to install the same application to multiple computers.

Silent-installation

Run a command from the command line interface to install / upgrade DFM Studio Inspector.
Please refer to the sample command below, and a list of available command line arguments.
E.g.)

D:\share\installer\setup.exe /s
/v"/l* "^""C:\temp\install.log"^"" INSTALLDIR="^""C:\Program Files\Elysium\DFM
Studio\v"^"" /qn"

Silent-uninstallation

Run a command from the command line interface to uninstall DFM Studio Inspector.
Please refer to the sample command below, and a list of available command line arguments.
E.g.)

D:\share\installer\setup.exe /s /x /v"/l* "^""C:\temp\uninstall.log"^"" /qn"


• Please ensure to use the installer of the same version as the

currently-installed DFM Studio Inspector.

DFM Studio Installation Guide
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Command Line Arguments

The following table shows the list of available command line arguments for the installer
("setup.exe") in the silent-installation / silent-uninstallation.

Argument Description

/s Set to run the installer in silent mode.
(Common for installation and uninstallation)

/x Set to uninstall the application.
The application will be installed / upgraded when this is omitted.

/v Set to pass following arguments to Msiexec.
Set as /v"<argument 1> <argument 2> …".

• /qn:
Set not to show the dialog during the installation.

• /qn+:
Set to show the completion notice upon the completion of the installation.

• /l* \"<File path to log file>\":
Set to output the installation log.
Specify the log file by its absolute file path. Please ensure to insert a half-
width space between this argument and the file path.

• INSTALLDIR=\"<Installation folder>\":
Set to specify the folder to install DFM Studio Inspector to by its absolute
folder path.
This is mandatory in installation.

DFM Studio Installation Guide
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2.4. Install 3DxSUITE Viewer (Model Viewer)
1. Copy "modelviewer_for_dfmstudio_v#.#.#.zip" to a local folder (e.g., C:\temp) of a computer

to install to, and extract all.

2. Run the following installer to install Elysium 3DxSUITE Viewer (3DxSUITE Viewer).

Installer of ASFALIS Model Viewer

modelviewer_for_dfmstudio_v#.#.#\installers\Elysium_3DxSUITE_EX*.*_Viewer.exe

 You need Administrator privileges to install Elysium products.

2.4.1. System Requirements

CPU Microsoft Windows 8.1 Pro 64-bit, Windows 10 Pro 64-bit
(1909 - 21H1) (*1) capable CPU

Memory 2GB or more (4G or more is recommended.)

OS Windows 8.1 Pro 64-bit, Windows 10 Pro 64-bit (1909 - 21H1)
(*1)

Supported
Language

Japanese, English, Simplified Chinese

Display Display capable of minimum 1280 x 1024
Graphics Board: OpenGL Board that supports double
buffering. (*2)

(*1): Windows is a registered trademark of Microsoft Corp.
(*2): OpenGL is a registered trademark of Hewlett Packard Enterprise.

2.4.2. Manual Installation

1. Run the installer for 3DxSUITE Viewer.

◦ Installer: Elysium_3DxSUITE_EX*.*_Viewer.exe
(EX*.* is a version of 3DxSUITE)

2. Select the language for the installation and click [OK].
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3. If the dialog below is displayed, click [Install] to start the installation.

◦ If these installers are already installed, this dialog will not appear.

4. If 3DxSUITE Setting Utility is not installed, the 3DxSUITE Setting Utility installer will start.
Follow the steps below to perform the installation. If 3DxSUITE Setting Utility is already
installed, skip to the step after installing 3DxSUITE Setting Utility.

a. Select which language to use when installing, and click [OK].

b. Installation Wizard starts. Click [Next].

c. Select "I accept the terms in the license agreement" if you accept the license agreement

DFM Studio Installation Guide
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and click [Next]. If you don’t accept, you cannot continue the installation.

d. "License Client Setting" dialog will appear. Enter the hostname of the computer where
you installed Sentinel RMS License Manager, and if necessary, change the port number.
And then click [Next].

e. "Set up Scenario Folder" dialog will appear. Change the folder path if necessary, and then
click [Next].

DFM Studio Installation Guide
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f. Click [Install] to start the installation.

g. When the installation of 3DxSUITE Setting Utility is completed, the following dialog will
appear. Click [Finish] to end the installer.
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5. Viewer Install Wizard will appear. Click [Next].

6. After reading through carefully, select "I accept the terms in the license agreement" if you
agree, then click [Next].

7. The dialog to specify a destination folder will appear. To change the destination folder from
default setting, click [Change] and specify the new destination folder. When the setting is
finished, click [Next].
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
Please ensure that the destination folder path consists of ASCII characters
only. If the folder path contains non-ASCII characters, the application may
not work as expected.

8. The following dialog will appear. Disable "Create a desktop shortcut" if you do not want to
create a desktop shortcut. Click [Install] to start the installation.

9. When the installation is finished, the following dialog will appear. Click [Finish].
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2.4.3. Silent Installation

By using the command, you can install or upgrade 3DxSUITE Viewer without GUI operations.

• Example of command

Elysium_3DxSUITE_EX9.0_Viewer.exe /s /v"/l* \"C:\temp\install.log\"
INSTALLDIR=\"C:\Program Files\Elysium\3DxSUITE\EX9.0\Viewer\" /qn"

This is a list of command arguments to pass to the installer when executing silent installation.

Command
Argument

Description Mandatory /
Optional

/s Execute installation or uninstallation in silent mode. Mandatory

/v Specify the following arguments in the form of /v"arg1 arg2
…":

• /l* \"<Log file>\" : Specify the log file path. A space is
required between "/ l *" and the filename.

• INSTALLDIR=\"<Installation Folder>\" : Specify the folder
where you want to install. This can be specified only
when installing.

• /qn : Install or uninstall without displaying the dialog.

• /qn+ : Dialog is displayed when installation or
uninstallation is completed.

Optional

DFM Studio Installation Guide
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2.4.4. Launch

In Windows start menu, select [Elysium 3DxSUITE Viewer] > [3DxSUITE Viewer EX*.*] to launch
3DxSUITE Viewer. (*.* is the version of 3DxSUITE Viewer.)

Setting License

After the installation, the license settings dialog may appear the first time you start 3DxSUITE
Viewer. This dialog will not appear the next time you start. Also, this dialog can be opened by
selecting [Help] > [License] after starting 3DxSUITE Viewer.

Confirm the status of license usage from "License Status."



• If you change the initial value in "License Information" dialog and click
[OK], the license information will be saved as the setting common for all
users using 3DxSUITE Viewer. So even if you change the license settings
from 3DxSUITE Setting later on, the license information in 3DxSUITE
Viewer will not change.

• If you change the initial value in "License Information" dialog but not
clicking [OK] at all, the license will be obtained by referring to the settings
in 3DxSUITE Setting. In that case, if the license settings in 3DxSUITE Setting
are changed, the license information in 3DxSUITE Viewer will also change.

2.4.5. Exit

Select [File] > [Exit] from the menu or close the window to exit.

2.4.6. Uninstallation
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Manual Uninstallation

1. From Windows start menu, select [Start] > [Settings](Gear mark).

2. Then select [Apps].

3. From the list of applications displayed in "Apps & features", select "Elysium 3DxSUITE EX*.* -
Viewer" to uninstall. (*.* is the version of 3DxSUITE Viewer)

Silent Uninstallation

Silent uninstallation can be performed by a command. Installer of the currently installed
version will be required.

• Example of command

Elysium_3DxSUITE_EX9.0_Viewer.exe /s /x /v"/l* \"C:\temp\uninstall.log\" /qn"

This is a list of command arguments to pass to the installer when executing silent
uninstallation.

Command
Argument

Description Mandatory /
Optional

/s Execute installation or uninstallation in silent mode. Mandatory

/x Execute uninstallation. Mandatory

/v Specify the following arguments in the form of /v"arg1 arg2
…":

• /l* \"<Log file>\" : Specify the log file path. A space is
required between "/ l *" and the filename.

• /qn : Install or uninstall without displaying the dialog.

• /qn+ : Dialog is displayed when installation or
uninstallation is completed.

Optional
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3. With ASFALIS TransServer
This chapter explains about the installation and setup of DFM Studio run via ASFALIS
TransServer. Please refer to 2, With ASFALIS SmartLauncher to run DFM Studio via ASFALIS
SmartLauncher.

3.1. Install ASFALIS Slave Node

3.1.1. Fresh Installation of ASFALIS Slave Node

Install Slave Node to the computer to run DFM Studio, and set it up as Slave Node for ASFALIS
TransServer to run DFM Studio via ASFALIS TransServer.

1. Copy "slavenode_for_dfmstudio_v#.#.#.zip" to a local folder (e.g., C:\temp) of a computer to
install to, and extract all.

2. Run the following installer to install ASFALIS Slave Node.
Please refer to "ASFALIS Slave Node Installation Guide" for the details.

Installer of ASFALIS Slave Node

slavenode_for_dfmstudio_v#.#.#\installer\setup.exe

ASFALIS Slave Node Installation Guide

slavenode_for_dfmstudio_v#.#.#\document\SlaveNode_InstallationGuide_en.pdf

3. Add DFM Studio as follows.

a. Apply "DFM Studio module" patch.

▪ Replace the following folders:

<ASFALIS Slave Node installation folder>\module\CADfeature

<ASFALIS Slave Node installation folder>\module\tools

by the following DFM Studio module patch:

slavenode_for_dfmstudio_v#.#.#\slavenode_patch\component_64bit\bin\CADfeat
ure
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slavenode_for_dfmstudio_v#.#.#\slavenode_patch\component_64bit\bin\tools

▪ Replace the following config file:

<ASFALIS Slave Node installation folder>\config\AsfalisConfig_Setting.xml

by the following config file of Slave Node for DFM Studio:

slavenode_for_dfmstudio_v#.#.#\slavenode_patch\SlaveNode_64bit\config\Asfalis
Config_Setting.xml

b. Confirm that DFM Studio modules listed below exist in the following folder.

<ASFALIS Slave Node installation folder>\module\tools\win

▪ "dfmstudio" folder

▪ dscheck.cmd

▪ dsreport.cmd

c. Select [Windows Start Menu] > [Elysium ASFALIS Component] > [EX#.#] > [setup node],
and add following Components in the dialog.
E.g.)

▪ "CATIAV5 – R28" Component: To translate CATIA V5 R28 data to ENF

▪ "NX – NX12" Component: To translate NX12 data to ENF

▪ "DFM Studio Checker" Component: To run DFM check

▪ "DFM Studio Reporter" Component: To export DFM check result report

E.g.) Adding "CATIAV5 – R28", "DFM Studio Checker", and "DFM Studio Reporter"
Components
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

Please ensure to select "Use new adapter" option for CAD to
ENF translation when using NX or Creo Parametric.

4. Start ASFALIS Slave Node.

◦ [Start] / [Start All]

▪ Please refer to ASFALIS Slave Node Installation Guide
(SlaveNode_InstallationGuide_en.pdf) for the details about how to start/stop ASFALIS
Slave Nodes, add Components, etc.
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3.1.2. DFM Studio Version-up Steps for DFM Studio Module



• If you are using DFM Studio via ASFALIS TransServer with an
existing version, refer to the steps below for version-up steps.

1. Apply "DFM Studio module" patch to Slave Node. Replace
<ASFALIS Slave Node installation folder>\module\tools\dfmstudio
folder to the dfmstudio folder in
slavenode_for_dfmstudio_v#.#.#\slavenode_patch\component_64b
it\bin\tools\win\.

2. Disable the currently used DFM Studio Scenarios from
[Administration] > [Scenario Administration].

3. Import the new version scenario (*.zip) from [Scenario
Administration].

▪ Newly installing ASFALIS TransServer is not required.
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3.2. Install ASFALIS TransServer

3.2.1. Fresh Installation of ASFALIS TransServer

This section explains how to install ASFALIS TransServer for the first time.

1. Copy "transserver_for_dfmstudio_v#.#.#.zip" to a local folder (e.g., C:\temp) of a computer to
install to, and extract all.

2. Run the following installer to install ASFALIS TransServer.
Please refer to "ASFALIS TransServer Installation Guide" for the details.

Installer of ASFALIS TransServer

transserver_for_dfmstudio_v#.#.#\installer\setup.exe

[ASFALIS TransServer Installation Guide]

transserver_for_dfmstudio_v#.#.#\document\TransServerInstallationGuide_en.pdf
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3.3. Set up ASFALIS TransServer
1. Launch ASFALIS TransServer.

◦ Please refer to "ASFALIS TransServer Installation Guide"
(TransServerInstallationGuide_en.pdf) > "3. Boot Procedure" for how to launch ASFALIS
TransServer.

2. Log in to ASFALIS TransServer, and then register Slave Node from [Administration] >
[Services Monitor].

a. Click [Edit] and then [Add] when other Slave Nodes are already registered.

b. Specify the Slave Node computer name to "Host" field and the port number for DFM
Studio Components (e.g., "59859") to "Port" field, and then click [Save].

3. Enable DFM Studio Components ("dscheck" / "dsreport") from [Administration] >
[Component Administration].

4. Import the following DFM Studio Scenarios from [Administration] > [Scenario
Administration].

transserver_for_dfmstudio_v#.#.#\scenario\english\dfmstudio_v#.#.#_scenario_check.zi
p

This contains Scenarios to run DFM check.

transserver_for_dfmstudio_v#.#.#\scenario\english\dfmstudio_v#.#.#_scenario_check_r
eport.zip

This contains Scenarios to run DFM check, and then export the result report (*.xlsx).

transserver_for_dfmstudio_v#.#.#\scenario\english\dfmstudio_v#.#.#_scenario_report.z
ip

This contains Scenarios to export the result report (*.xlsx).

 ◦ Please ensure to import as the ZIP file.


◦ It requires a license on DFM Studio Reporter to export check

result reports.

5. Confirm that following Scenarios are added to the Scenario list from [Administration] >
[Scenario Administration].
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ZIP file to import Scenario name on ASFALIS TransServer

dfmstudio_v#.#.#_scenari
o_check.zip

DFM Check | Plastic | CATIA V5 Plug-in
DFM Check | Sheet Metal | CATIA V5 Plug-in
DFM Check | Plastic | NX Plug-in
DFM Check | Sheet Metal | NX Plug-in
DFM Check | Plastic | Creo Parametric Plug-in
DFM Check | Sheet Metal | Creo Parametric Plug-in
DFM Check | Plastic | SOLIDWORKS Plug-in
DFM Check | Sheet Metal | SOLIDWORKS Plug-in
DFM Check | Plastic | ENF
DFM Check | Sheet Metal | ENF

dfmstudio_v#.#.#_scenari
o_check_report.zip

DFM Check & Report | Plastic | CATIA V5 Plug-in
DFM Check & Report | Sheet Metal | CATIA V5 Plug-in
DFM Check & Report | Plastic | NX Plug-in
DFM Check & Report | Sheet Metal | NX Plug-in
DFM Check & Report | Plastic | Creo Parametric Plug-in
DFM Check & Report | Sheet Metal | Creo Parametric Plug-in
DFM Check & Report | Plastic | SOLIDWORKS Plug-in
DFM Check & Report | Sheet Metal | SOLIDWORKS Plug-in
DFM Check & Report | Plastic | ENF
DFM Check & Report | Sheet Metal | ENF

dfmstudio_v#.#.#_scenari
o_report.zip

Export Report (Include Auto-capture) | Plastic
Export Report | Plastic
Export Report (Include Auto-capture) | Sheet Metal Export
Report | Sheet Metal

6. Delete unnecessary Scenario(s) if any, so that only the necessary Scenarios will be selectable
on ASFALIS TransServer.

7. Submit Jobs of DFM Studio Component(s) ("dscheck" / "dsreport") to ASFALIS TransServer
using Scenarios listed above to confirm that it works as expected. Please refer to
"DFM_Studio_Quick_Start_Guide_en.pdf" > "1.1. With ASFALIS TransServer" for how to
submit Jobs to ASFALIS TransServer.
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3.4. Install DFM Studio Inspector
1. Copy "dfmstudio_v#.#.#_inspector.zip" to a local folder (e.g., C:\temp) of a computer to install

to, and extract all.

2. Run the following installer to install DFM Studio Inspector.

Installer of DFM Studio Inspector

dfmstudio_v#.#.#_inspector\installer\setup.exe

 Please ensure to run the installer as administrator.

3.4.1. Run DFM Studio Inspector

It requires Modify permission to the following to run DFM Studio Inspector.

• %TMP% / %TEMP%

• %APPDATA%

• DFM Studio check result file (*.far) output folder

3.4.2. System Requirements

Machine / CPU Machine and CPU capable of running OS listed below

OS Windows 10 Pro 64-bit (*1)

Memory 4GB or more (8GB or more is recommended)

Storage Min. 500MB free space

Graphic - Display capable of min. 1280 x 1024
- Graphic card that supports OpenGL and double buffering (*2)

(*1): Windows is a registered trademark of Microsoft Corp.
(*2): OpenGL is a registered trademark of Hewlett Packard Enterprise.
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3.4.3. Install DFM Studio Inspector

1. Run the following installer to install DFM Studio Inspector.

dfmstudio_v#.#.#_inspector\installer\setup.exe

2. Select the language for the installation.

◦ Select "English", and then click [OK].

3. Install prerequisite(s) to the installation of DFM Studio Inspector.

◦ Click [Install] to install Runtime when this page appears.
This page will be skipped when prerequisites are already installed.

4. Set up DFM Studio Inspector.

◦ Click [Next].

5. Agree to the license agreement.
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◦ Read the license agreement, select "I accept the terms in the license agreement" option,
and then click [Next].

6. Specify the installation folder.

◦ Specify the folder to install DFM Studio Inspector to, and then click [Next].

7. Confirm to start the installation.

◦ Click [Install] to start the installation of DFM Studio Inspector.
This page shows the progress of the installation.
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8. Confirm the completion of the installation.

◦ Click [Finish] to exit the wizard.
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3.4.4. Silent-install DFM Studio Inspector

Silent-installation is a feature to install applications with no interactions on the graphical user
interface. This is useful to install the same application to multiple computers.

Silent-installation

Run a command from the command line interface to install / upgrade DFM Studio Inspector.
Please refer to the sample command below, and a list of available command line arguments.
E.g.)

D:\share\installer\setup.exe /s
/v"/l* "^""C:\temp\install.log"^"" INSTALLDIR="^""C:\Program Files\Elysium\DFM
Studio\v"^"" /qn"

Silent-uninstallation

Run a command from the command line interface to uninstall DFM Studio Inspector.
Please refer to the sample command below, and a list of available command line arguments.
E.g.)

D:\share\installer\setup.exe /s /x /v"/l* "^""C:\temp\uninstall.log"^"" /qn"


• Please ensure to use the installer of the same version as the

currently-installed DFM Studio Inspector.
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Command Line Arguments

The following table shows the list of available command line arguments for the installer
("setup.exe") in the silent-installation / silent-uninstallation.

Argument Description

/s Set to run the installer in silent mode.
(Common for installation and uninstallation)

/x Set to uninstall the application.
The application will be installed / upgraded when this is omitted.

/v Set to pass following arguments to Msiexec.
Set as /v"<argument 1> <argument 2> …".

• /qn:
Set not to show the dialog during the installation.

• /qn+:
Set to show the completion notice upon the completion of the installation.

• /l* \"<File path to log file>\":
Set to output the installation log.
Specify the log file by its absolute file path. Please ensure to insert a half-
width space between this argument and the file path.

• INSTALLDIR=\"<Installation folder>\":
Set to specify the folder to install DFM Studio Inspector to by its absolute
folder path.
This is mandatory in installation.
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3.5. Install 3DxSUITE Viewer (Model Viewer)
1. Copy "modelviewer_for_dfmstudio_v#.#.#.zip" to a local folder (e.g., C:\temp) of a computer

to install to, and extract all.

2. Run the following installer to install Elysium 3DxSUITE Viewer (3DxSUITE Viewer).

Installer of ASFALIS Model Viewer

modelviewer_for_dfmstudio_v#.#.#\installers\Elysium_3DxSUITE_EX*.*_Viewer.exe

 You need Administrator privileges to install Elysium products.

3.5.1. System Requirements

CPU Microsoft Windows 8.1 Pro 64-bit, Windows 10 Pro 64-bit
(1909 - 21H1) (*1) capable CPU

Memory 2GB or more (4G or more is recommended.)

OS Windows 8.1 Pro 64-bit, Windows 10 Pro 64-bit (1909 - 21H1)
(*1)

Supported
Language

Japanese, English, Simplified Chinese

Display Display capable of minimum 1280 x 1024
Graphics Board: OpenGL Board that supports double
buffering. (*2)

(*1): Windows is a registered trademark of Microsoft Corp.
(*2): OpenGL is a registered trademark of Hewlett Packard Enterprise.

3.5.2. Manual Installation

1. Run the installer for 3DxSUITE Viewer.

◦ Installer: Elysium_3DxSUITE_EX*.*_Viewer.exe
(EX*.* is a version of 3DxSUITE)

2. Select the language for the installation and click [OK].
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3. If the dialog below is displayed, click [Install] to start the installation.

◦ If these installers are already installed, this dialog will not appear.

4. If 3DxSUITE Setting Utility is not installed, the 3DxSUITE Setting Utility installer will start.
Follow the steps below to perform the installation. If 3DxSUITE Setting Utility is already
installed, skip to the step after installing 3DxSUITE Setting Utility.

a. Select which language to use when installing, and click [OK].

b. Installation Wizard starts. Click [Next].

c. Select "I accept the terms in the license agreement" if you accept the license agreement
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and click [Next]. If you don’t accept, you cannot continue the installation.

d. "License Client Setting" dialog will appear. Enter the hostname of the computer where
you installed Sentinel RMS License Manager, and if necessary, change the port number.
And then click [Next].

e. "Set up Scenario Folder" dialog will appear. Change the folder path if necessary, and then
click [Next].
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f. Click [Install] to start the installation.

g. When the installation of 3DxSUITE Setting Utility is completed, the following dialog will
appear. Click [Finish] to end the installer.
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5. Viewer Install Wizard will appear. Click [Next].

6. After reading through carefully, select "I accept the terms in the license agreement" if you
agree, then click [Next].

7. The dialog to specify a destination folder will appear. To change the destination folder from
default setting, click [Change] and specify the new destination folder. When the setting is
finished, click [Next].
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
Please ensure that the destination folder path consists of ASCII characters
only. If the folder path contains non-ASCII characters, the application may
not work as expected.

8. The following dialog will appear. Disable "Create a desktop shortcut" if you do not want to
create a desktop shortcut. Click [Install] to start the installation.

9. When the installation is finished, the following dialog will appear. Click [Finish].
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3.5.3. Silent Installation

By using the command, you can install or upgrade 3DxSUITE Viewer without GUI operations.

• Example of command

Elysium_3DxSUITE_EX9.0_Viewer.exe /s /v"/l* \"C:\temp\install.log\"
INSTALLDIR=\"C:\Program Files\Elysium\3DxSUITE\EX9.0\Viewer\" /qn"

This is a list of command arguments to pass to the installer when executing silent installation.

Command
Argument

Description Mandatory /
Optional

/s Execute installation or uninstallation in silent mode. Mandatory

/v Specify the following arguments in the form of /v"arg1 arg2
…":

• /l* \"<Log file>\" : Specify the log file path. A space is
required between "/ l *" and the filename.

• INSTALLDIR=\"<Installation Folder>\" : Specify the folder
where you want to install. This can be specified only
when installing.

• /qn : Install or uninstall without displaying the dialog.

• /qn+ : Dialog is displayed when installation or
uninstallation is completed.

Optional
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3.5.4. Launch

In Windows start menu, select [Elysium 3DxSUITE Viewer] > [3DxSUITE Viewer EX*.*] to launch
3DxSUITE Viewer. (*.* is the version of 3DxSUITE Viewer.)

Setting License

After the installation, the license settings dialog may appear the first time you start 3DxSUITE
Viewer. This dialog will not appear the next time you start. Also, this dialog can be opened by
selecting [Help] > [License] after starting 3DxSUITE Viewer.

Confirm the status of license usage from "License Status."



• If you change the initial value in "License Information" dialog and click
[OK], the license information will be saved as the setting common for all
users using 3DxSUITE Viewer. So even if you change the license settings
from 3DxSUITE Setting later on, the license information in 3DxSUITE
Viewer will not change.

• If you change the initial value in "License Information" dialog but not
clicking [OK] at all, the license will be obtained by referring to the settings
in 3DxSUITE Setting. In that case, if the license settings in 3DxSUITE Setting
are changed, the license information in 3DxSUITE Viewer will also change.

3.5.5. Exit

Select [File] > [Exit] from the menu or close the window to exit.

3.5.6. Uninstallation
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Manual Uninstallation

1. From Windows start menu, select [Start] > [Settings](Gear mark).

2. Then select [Apps].

3. From the list of applications displayed in "Apps & features", select "Elysium 3DxSUITE EX*.* -
Viewer" to uninstall. (*.* is the version of 3DxSUITE Viewer)

Silent Uninstallation

Silent uninstallation can be performed by a command. Installer of the currently installed
version will be required.

• Example of command

Elysium_3DxSUITE_EX9.0_Viewer.exe /s /x /v"/l* \"C:\temp\uninstall.log\" /qn"

This is a list of command arguments to pass to the installer when executing silent
uninstallation.

Command
Argument

Description Mandatory /
Optional

/s Execute installation or uninstallation in silent mode. Mandatory

/x Execute uninstallation. Mandatory

/v Specify the following arguments in the form of /v"arg1 arg2
…":

• /l* \"<Log file>\" : Specify the log file path. A space is
required between "/ l *" and the filename.

• /qn : Install or uninstall without displaying the dialog.

• /qn+ : Dialog is displayed when installation or
uninstallation is completed.

Optional

DFM Studio Installation Guide

 © 2022 Elysium Page 48 | 49



All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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