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1. Plane Modeling
This section explains how to model equipment and frameworks by connecting planes that are
automatically extracted by the Extract Planes and Pipes function/command.

Preparing for plane modeling

• If planes are not yet extracted, run [Extract Planes and Pipes] first. Refer to "Extracting
Planes and Pipes" in "InfiPoints Operation Manual Vol.1. Data Pre-processing" for
details.

• Select [Home] tab > [Display Status] > [Show/Hide Planes] (  ) to display the
extracted planes.


When selecting [Show/Hide Planes], you can toggle between [Show
Planes] (  ) and [Hide Planes] (  ).

• Select [Modeling] tab > [Start Modeling Plane Elements] from the Ribbon menu.

[Plane] tab appears. Users can perform plane modeling using functions in this tab.
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About the display area of the 3D View Window

• Limiting the display area by using the Clipping Box function can be useful when
modeling an equipment partially. A Clipping Box can be created/edited with the
[Create clipping box] (  ) and the [Edit Box Section] (  ) functions from the
[Clipping] panel.

Changing/Fixing the rotating center of the 3D View Window

• Fixing the rotating center also can help change the viewpoint readily/smoothly. Set the
rotating center with the [Fix (Fix at Selected Element)] function/command on the
upper right side of the 3D View Window.
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1.1. Creating Planes

1.1.1. Creating Planes

1. Select [Plane] tab > [Create] > [Create Plane] (  ).

2. In [Option] panel, specify how to create a plane. In this case, select "By selecting 2 semi-
perpendicular planes (perpendicular to them)".

3. Select the first plane in the 3D View Window. The plane that will be created can be
previewed while selecting the second plane and moving the cursor over it.

4. Pick/choose the second plane to create the new plane.
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

If point cloud appears to be on a plane, create a plane by selecting "By
selecting 3 points" in [Option] panel.

1.1.2. Creating Blocks(Solid)

1. Select [Plane] tab > [Create] > [Create Block] (  ).

2. In [Option] panel, select "Complement" in "Complement planes".

 Select "Don’t complement" (  ) to create a sheet (i.e., plane with free edge.

3. Pick 2 or more planes to form a block and press [Done] (  ).
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
When selecting "Complement", you can select two or more planes to create
a six-sided block even if all six planes are not extracted.
A block is created at the position of the picked plane. In addition, "Plane
group without free edges" (  ) is added to [Tree (Plane)] panel.

1.1.3. Creating Cubes

1. Select [Plane] tab > [Create] > [Create Cube] (  ).

2. In the 3D View Window, select the plane at the position where you would like to create a
cube. A cube will be created based on the size of the selected plane.


If you would like to change the size of the cube you created, you can do so
by moving each plane using [Move Plane Parallel] (  ).

1.1.4. Extruding Planes

1. Select [Plane] tab > [Create] > [Extrude Plane] (  ).
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2. In the 3D View Window, select the plane you would like to extrude.

3. Once the "Extrude Plane" dialog appears, select "Extrude to a specified point or a plane" and
then click [Edit].

4. Pick a plane to extrude to, and a preview of the extruded shape will be displayed on "3D
View" window.
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5. In "Extrude Plane" dialog, click [OK]. A solid extruded from the plane is created.



Note that side planes may get divided into multiple parts when extruding
complicated planes. Simplify the shape of the plane first by using [Edit
Plane Boundary] (  ) to avoid this.

◦ Extrusion without editing the plane

◦ Extrusion after editing the plane
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1.2. Editing Planes

1.2.1. Editing Plane Boundaries

1. Select [Plane] tab > [Edit] > [Edit Boundary] (  ).

2. In [Option] panel, select "Edit the boundary of a plane" in "Mode".

3. Select an independent plane that is not connected with any other.


You can disconnect planes by selecting [Disconnect] (  ) in case that the
plane is connected to other planes.

4. Draw the boundary of the plane. The plane will be updated once the boundary is complete.
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1.2.2. Editing a Part of Plane Boundary

1. Select [Plane] tab > [Edit] > [Edit Boundary] (  ).

2. In [Option] panel, select "Edit part of the boundary" in "Mode".

3. Select an independent plane that is not connected with any other.
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
You can disconnect planes by selecting [Disconnect] (  ) in case that the
plane is connected to other planes.

4. Pick the boundaries to edit in order and press [Done] (  ).


Boundaries which are not connected to already-picked one are not
pickable.

5. Draw a new boundary line by clicking in "3D View" window at breakpoints.


Option for "Align the plane boundary" can be specified in the [Option]
panel.
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The plane will be updated once the boundary is complete.

1.2.3. Connecting Planes (by Selecting a Plane)

1. Select [Plane] tab > [Edit] > [Connect] > [Connect Planes] (  ).

2. On "3D View" window, pick two planes to preview the result.
To connect the two planes, press [Done] (  ).

If you select an additional plane, all three planes will be connected.



◦ You cannot connect planes if the orientations are not aligned. You can
flip the orientations of planes with [Reverse Planes] (  ).

◦ You cannot use this functionality when neighboring planes do not exist.
In such a case, create a plane first.
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1.2.4. Connecting Planes (by Selecting Plane Group)

You can create a solid model by extending the surfaces of an equipment toward walls and
floors.

1. Select [Plane] tab > [Edit] > [Connect] > [Connect Plane Groups] (  ).

2. In the 3D View Window, select a Plane Group from an equipment first, and then a Plane
Group from a framework.

3. "Connect 2 Plane Groups" dialog will appear. Select "Create a solid (for equipment)" and
click [OK].

A solid model will be created from the Plane Groups.
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
If you cannot select Plane Groups or fail to extend selected Plane Groups,
make sure there are no unconnected thick edges left except for ones
parallel to walls and floors. If there are any left, connect those first using
the [Connect Planes] > [By 2 or 3 Planes] (  ) option.

1.2.5. Connecting Planes (by Composing Wall)

Create a new plane group by connecting the planes at the wall, floor, and ceiling positions.

1. Select [Plane] tab > [Edit] > [Connect] > [Compose Wall] (  ).

2. On "3D View" window, pick the planes positioned to surround an area(walls) in sequential
order.
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
Please note that the planes should be selected in the order you want to
connect them. Select a plane to preview it on "3D View" window.

After picking all the planes you want to connect, press [Done] (  ).

3. When connecting the floor and the ceiling, select the planes in the order of floor, then
ceiling, and press [Done] (  ).


Please note that specifying the floor and the ceiling are optional. If you
press [Done] (  ) without specifying the floor or the ceiling, only the
walls are created.

The new plane group is created.
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

Please note that the planes connected by the function [Compose Wall]
(  ) will be named floor, ceiling, and wall, respectively.

1.2.6. Merging Planes

1. Select [Plane] tab > [Edit] > [Merge] (  ).

2. Select three independent planes in the 3D View Window.


You can select multiple planes by using the [Area Selection Mode] (  ) or
by dragging over planes while holding down the [Ctrl] key.

3. By pressing [Confirm] (  ), the planes will merge into a single plane.
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1.3. Copying/Moving Planes

1.3.1. Copying Planes

1. Select [Plane] tab > [Edit] > [Copy] (  ).

2. Select the plane or plane group you want to copy in the 3D View Window and a guide will be
displayed.


Plane is set as default for [Pick filter]. Select [Plane Group] to change this to
plane group.


Select an "Extracted Planes" to copy to option will be displayed in [Option]
panel when there are multiple "Extracted Planes" in [Tree (Overview)]
panel. You can specify the "Extracted Planes" to copy to by selecting this
option.
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3. Move the cursor along the guide and left-click to fix the position.


The guide axes correspond to the XYZ direction of the current coordinate
system.


It is also possible to move a plane or a plane group by specifying the
distance in the "Option" dialog.

4. To continue copying another plane, press [Done] (  ).
Press [Cancel] (  ) to finish.


The direction of the copied plane can be aligned with other planes by
selecting [Edit] > [Flip Plane] (  ).
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1.3.2. Moving Planes Parallelly

1. Select [Plane] tab > [Edit] > [Move Parallel] (  ).

2. Select the plane to move in the 3D View Window.

"Move Plane" dialog will appear.
In this case, select "Move to specified point or plane" and click [Edit].

3. In the 3D View Window, select the plane of the new location and a preview of the displaced
plane will be displayed.

4. Click [OK] on "Move Plane" dialog, and the plane will be moved to the location you specified.
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1.3.3. Moving Plane Groups

1. Select [Analysis] tab > [Move] > [Move] (  ).

2. In the 3D View Window, select the plane group you would like to move and a move handle
will appear.

 It is not possible to select only a part of the planes from a plane group.

3. Drag the move handle to move the plane group.

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 20 | 151




It is also possible to move a plane group by specifying the values in "Move"
dialog.

4. Press [Cancel] (  ) and the plane group will be displaced.
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1.4. Deleting Planes
[Extract planes and pipes] will automatically extract detailed planes and pipes from point cloud
data. You can remove unnecessary planes and pipes with the filtering functionality before
exporting the data to other software packages in order to increase efficiency of post-processes.

1.4.1. Deleting Planes

1. Select [Plane] tab > [Delete] > [Plane] (  ).

2. Select the plane you would like to delete in the 3D View Window. The selected plane will be
deleted.


If you want to delete the entire plane group, use [Plane Group] (  )
instead of [Plane].

1.4.2. Deleting Unnecessary Planes Collectively

1. Select [Plane] tab > [Delete] > [Over-extracted Planes] (  ).

2. Specify [Minimum area of plane] in the "Delete Over-extracted Planer Elements" dialog.
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 You can change the value with the slide bar.

The planes to be deleted are highlighted in red in the 3D View Window.

3. Click [OK] and the planes will be deleted.
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1.5. Aligning Planes
This function will align planes within a Plane Group in parallel or perpendicular to each other.

1.5.1. Aligning the entire planes within a plane group

1. Select [Plane] tab > [Align] > [Align All Plane Groups] (  ).

2. "Align Plane Group" dialog will appear. Set the angle tolerance and the alignment options
and click [OK].


When the [Align to horizontal or vertical direction] option is enabled,
alignment will be adjusted parallel/perpendicular to the Z-axis of the world
coordinate system.

All the planes in the plane groups will be aligned based on the criteria specified in the
dialog.


Planes automatically extracted by [Extract planes and pipes] are not subject to
alignment.
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
Use [Align Plane Group] (  ) if you would like to align only the ones you
select.
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1.6. Generating CAD Models from Planes
This section explains how to generate CAD models from planes created in InfiPoints.

About the [Generate CAD Model] Command

The CAD models generated by [Generate CAD Model] is used to detect collision in
InfiPoints. However, note that there is no need to generate CAD models before "Export"
CAD models.

1.6.1. Generating CAD Models from Plane Groups

1. Select [Plane] tab > [CAD] > [Generate CAD Model] (  ).


You can also generate a CAD model in the color displayed in the 3D View
Window.

2. On "3D View" window, pick the plane group from which you would like to generate a CAD
model and press [Done] (  ).
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 Multiple plane groups can be selected in succession.

The CAD model is generated from the selected plane groups.

"Created_Plane_Group" is added to the [Tree (Overview)] panel.
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1.7. Editing the Tree Structure of Planes
The configuration of planes can be checked on the [Tree (Plane)] panel. This can be useful in
cases such as:

• To group multiple pieces of equipment together.

• To classify plane groups by category (framework, equipment, etc.).

• To switch show/hide status with a single-click when exporting CAD format files.

1.7.1. Checking Planes with the [Tree (Plane)] Panel

• You can check the configuration of planes/plane groups in the model with the [Tree (Plane)]
panel.

• By selecting planes/plane groups in the tree, corresponding planes/plane groups in the 3D
View Window will be highlighted.

◦ When a plane group is selected on [Tree (Plane)] panel
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Conversely, by selecting a plane or plane group in the 3D View Window, corresponding
planes/plane groups in the tree will be highlighted.

◦ When a plane is selected on "3D View" window



◦ Switching the pick filter to either [plane] or [plane group] may help
make selection easier.

◦ You can select multiple planes by pressing down the [Shift] or [Ctrl]
keys while making the selection.

• To view the point cloud around the selected plane, right-click on a plane element or a plane
group in [Tree (Plane)] panel, and select [Fit View to Element size] or [Display Surroundings
Only] from the context menu.
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• Right-click on an element in [Tree (Plane)] panel, and select "Collapse All Plane Groups"
from the context menu to close the entire plane groups.

• In the [Property] panel, you can check the properties of a plane, such as the coordinates of a
vertex and the normal direction.
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1.7.2. Creating Plane Groups

1. Right-click on "Extracted Planes" in the [Tree (Plane)] panel and select [Group Plane Groups]
to create a Plane Group.

2. Drag and drop plane groups to move them to different groups.

 You can also further divide plane groups into smaller subgroups.
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1.7.3. Renaming Plane/Plane Groups

You can rename plane groups and planes by right-clicking on a plane or a plane group in the
[Tree (Plane)] panel and select [Rename].


• You can also rename plane groups or planes by pressing [F2] while

selecting a plane or a plane group in the [Tree (Plane)] panel.

• Delete the name using the [Backspace] key to restore the default name.

1.7.4. Switching Show/Hide Status of Planes

In the [Tree (Plane)] panel, check/uncheck the check box to show/hide items inside the tree
view.
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

• Checking/unchecking the check box of a plane will show/hide all of the
planes that are part of the same group plane.

• If you would like to show/hide individual planes, check/uncheck "Extracted
Planes" on [Tree (Overview)] panel.
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1.7.5. Changing the Display Color of Planes

1. Right-click on a plane or plane group in the [Tree (Plane)] panel and select [Edit Display
Color] to change the display color of the [Tree (Plane)] panel.

2. "Color" dialog will appear. Select any color you prefer and click [OK].

The selected color will be reflected in the tree view.
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

To clear the selected color, right-click on the plane or plane group and
choose [Reset to Default Color].
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2. Pipe Modeling
You can easily add, remove and edit pipes using the automatically extracted pipes by "Extract
Planes and Pipes."

Preparing for Pipe Modeling

• If the pipes are not extracted, perform "Extract Planes and Pipes" beforehand.
Refer to "Extracting Planes and Pipes" in "InfiPoints Operation Manual Vol.1. Data Pre-
processing" for details.



[Extract Planes and Pipes] automatically extracts planes and cylinders in
the point cloud data thoroughly. If excess features are extracted such as
thin pipes, bulk delete the excess features using [Delete Excess Elements]
(  ).
Refer to 2.1.1, “Deleting All Excess Pipes” for details.
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• If the pipes are not displayed in the 3D View Window, select [Home] tab > [Display
Status] > [Show Piping Elements] (  ).


Click [Show/Hide Pipes] to change from [Hide Pipes] (  ) to [Show
Pipes] (  ).


In this section, the pipes are displayed as "Classify by Piping Type" (  )
for better visibility in the 3D View Window. This is a function to display
pipes in different colors according to the piping group.

• Select [Modeling] tab > [Piping] from the Ribbon menu.

[Pipe Modeling Tool] tab appears. Use the pipe modeling function to create the model.
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2.1. Deleting Pipes
[Extract Planes and Pipes] automatically extracts planes and pipes thoroughly. Use this filtering
function to delete excess elements for other software’s modeling and improve efficiency of
downstream processes.

2.1.1. Deleting All Excess Pipes

1. Select [Pipe] tab > [Delete] > [Excess Elements] (  ).

2. "Delete Unnecessary Elements" dialog will appear. Check [Consists of a single element which
is shorter than].

The piping elements to be deleted in the 3D View Window will be highlighted in red.

3. Click [Run]. The piping elements will be deleted.
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2.1.2. Deleting Piping Elements

1. Select [Pipe] tab > [Delete] > [Piping Elements] (  ).

2. Pick the Pipes you want to delete on the 3D View Window. The Pipes will be deleted.

 Use [Piping Groups] (  ) to delete piping groups.
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2.2. Creating Pipes

2.2.1. Specify Points and Create New Piping Elements (Straight
Pipes)

1. Select [Pipe] tab > [Create Straight Pipe] > [Based on Point Cloud] (  ).

2. "Option" dialog will appear. This time, select "Auto-calculate from point cloud" for Pipe outer
diameter and "Select 2 points on pipe ends" for Pipe axis.

3. Pick two points at the position where pipes will be created in the 3D View Window.

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 40 | 151



 Pick two points to be approximately parallel with the axis of the new pipe.

The new pipe with the specified two points at both ends of the length will be created based
on the point cloud close to the picked points.

4. Press [Cancel] (  ) to end the creation of pipe.

2.2.2. Specify Size and Create New Piping Elements (Straight Pipes)

1. Select [Pipe] tab > [Create Straight Pipe] > [At Specified Location] (  ).

2. [Option] panel will appear. Specify the standard name or the pipe radius and length in the
"Size" tab. In this case, a standard straight pipe (50A) with a length of 1m will be created.
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3. Specify the orientation of the pipe to be placed from "Layout plane" tab. In this case, click
[Arrow] ( ) to select an existing straight pipe and set the orientation.

4. Select a pipe on "3D View" window facing the same direction as the plane (layout plane)
where the pipe’s axis will be created.

5. Layout plane is set, and the newly created straight pipe can be previewed on "3D View"
window. Specify the position to place the straight pipe.
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6. A straight pipe is created. Select a white guide line on the side of the created straight pipe
where you want to add.

The side to add the pipe is set. If necessary, continue to create pipes based on that point.
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

While creating the pipe, if you wish to change the direction, you can
change the setting in [Option] panel.

7. Press [Cancel] (  ) to end the creation of pipe.

2.2.3. Connecting Pipe Elements (Straight Pipes)

1. Select the [Pipe] tab > [Create] > [Connect Straight Pipes] (  ).

2. In [Option] panel, specify the type of connection part. This time, select "Elbow".
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3. Pick two straight pipes in the 3D View Window to connect them.

Picked pipes will be connected and it will become one piping group.


The created piping group will be added to the piping group to which the
first-picked pipe belonged.

2.2.4. Extending Piping Elements (Straight Pipes)

1. Select the [Pipe] tab > [Create] > [Extend Existing Piping] (  ).
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2. Pick the straight pipe you want to extend on "3D View" window.



◦ [Option] panel will appear as well; however, this time, you do not need
to change the default settings.

◦ If you select a straight pipe with no connecting elements on both ends, a
white guide line will appear on both ends. Select the white guide line on
the end to connect first.

3. A guide will appear. Drag the guide in order to extend the selected straight pipe, and left-
click at the preferred position.

4. Click [Cancel] (  ) and confirm the length of the straight pipe.
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2.2.5. Adding Piping Elements(Flange, Box, Valve)

[1] Adding piping elements in the middle of the straight pipe

Below is the way to add piping elements (flange, box, valve) in the middle of the straight pipe.

1. Select [Pipe] tab > [Create] > [Insert to Straight Pipe] > [Insert Flange] (  ).



◦ Select [Insert to Straight Pipe] > [Insert Box] (  ) to add the box.

◦ Select [Edit Boxes] (  ) to change the size or the direction of the box.

◦ Select [Insert to Straight Pipe] > [Insert Valve] (  ) to add the valve.

◦ Select [Edit] > [Edit Valve Handle] (  ) to change the size and the
direction of the valve. Please refer to 2.3.4, “Editing the Valve Handles”
for details.

2. Pick the straight pipe in the 3D View Window to add the flange. The flange will be added at
the picked position.
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[2] Adding piping elements to the end of the straight pipe

Below is the way to add the piping elements (flange, box) to the end of the straight pipe.

1. Select [Pipe] tab > [Create] > [Add to End] > [Add Flanges to Ends of Straight Pipes] (  ).


Select [Add to End] > [Add Boxes to Ends of Straight Pipes] (  ) to add
box.
Select [Edit Boxes] (  ) to change the size or the direction of the box.

2. Pick the straight pipe in the 3D View Window to add the flange. The Flange will be added at
the picked end.
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2.3. Editing Pipes

2.3.1. Adjusting the Length of Piping Elements

1. Select [Pipe] tab > [Edit] > [Edit Straight Pipe Length] (  ).

2. Pick the straight pipe to edit in "3D View" window.

3. Pick one of its edges to edit.

4. "Edit Straight Pipe Length" dialog will appear. This time, select "Specify by preview (To any
location)" and click [Edit]. ("Also move connected elements as is" option is disabled)
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5. The preview will be updated as you move the mouse cursor. Left-click at your desired length
to extend or shorten the structural element.

6. In "Edit Straight Pipe Length" dialog, click [OK]. The change of the length is fixed.
Like in this case, if "Also move connected elements as is" is disabled and the length of the
straight pipe connected to an element such as "elbow" is changed, the shape of that element
will change accordingly.
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2.3.2. Adjusting the Outside Diameter of the Straight Pipes

1. Select [Pipe] tab > [Edit] > [Edit Straight Pipe Diameter] (  ) .

2. Pick the straight pipe to edit in "3D View" window.

3. Pick either the end part or the center part.

4. "Edit Straight Pipe Diameter" dialog will appear. This time, select [Specify by preview],
enable "Align connected elements when editing the piping axis", and then click [Edit].
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
When "Align connected elements when editing the piping axis" is enabled,
the position of the adjacent piping elements will also change to match the
edited straight pipe.

5. The "3D View" window will switch to [Section Mode]. Hold down the left mouse button and
drag the handle to adjust the size and center position of the outside diameter. Then press
[Done] (  ).


◦ Red arrow handles ( ) allow you to change the size of the outer shape.

◦ Yellow arrow handle ( ) allows you to change the center position of
the straight pipe.

6. In "Edit Straight Pipe Diameter" dialog, click [OK]. The adjustment of the size of the outside
diameter will be fixed.
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2.3.3. Replacing Boxes with Valves

1. Select [Pipe] tab > [Edit] > [Replace Box with Valve] (  ).

2. Pick the box to be replaced with the valve in "3D View" window.

Picked box will be replaced with a valve.
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2.3.4. Editing the Valve Handles

1. Select the [Pipe] tab > [Edit] > [Edit Valve Handle] (  ).

2. In [Option] panel, select "Edit handle orientation".

3. Pick the valve to edit its handle direction in "3D View" window. Adjustment handle will be
displayed.

4. Move the mouse cursor in "3D View" window to change the direction of the adjustment
handle. Left-click the mouse at any position to fix the direction.
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5. Select [Edit handle size] in [Option] panel. Adjustment handle will turn to the mode for
adjusting the size of the valve handle.

6. Move forward and back the mouse cursor in "3D View" window to change the length of the
valve handle along the guide line.

Move the mouse cursor left or right to change the size of the valve handle along the guide
line.

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 55 | 151



Left-click at any point in "3D View" window to fix the size of the valve handle.

7. Press [Cancel] (  ) to finish adjusting the valve handle.
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2.3.5. Merging Straight Pipes

[1] Merging Coaxial Straight Pipes

Below is the way to merge two or more straight pipes whose axes and the outside diameters are
almost the same.

1. Select [Pipe] tab > [Merge] > [Merge Coaxial Pipes] (  ).

2. Pick the straight pipes to merge in "3D View" window and press [Done] (  ).



When the following dialog is displayed, select the pipes whose axes'
direction and the radius are almost the same.

"Merge Coaxial Pipes" dialog will appear when there is another straight pipe or flange
between picked straight pipes.
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3. Specify how to process the piping elements between the straight pipes. This time, select
"Merge while keeping flanges" and click [OK].

Picked straight pipes will be connected while highlighted flange will be kept.
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

Use [Merge All Connected Pipes] (  ) to connect all selected straight
piping elements.

[2] Merging Straight Pipes by Deleting Flanges and Complement Pipes

Below is the way to merge straight pipes by deleting flanges or complement pipes between
them.

1. Select [Pipe] tab > [Merge] > [Delete Flanges / Complement Pipes] (  ) .

2. Pick complement pipes or flanges to delete in "3D View" window. The straight pipes on both
sides are joined into one straight pipe.


If the point cloud is insufficient to generate a pipe for reasons such as a
part of one piping being hidden, the complement pipe will be inserted
there by the estimation during the automatic extraction. The complement
pipe is displayed in dark blue (in case of default setting.)


Use [Eliminate All Complement Pipes] (  ) to delete all complement pipes
and connect straight pipes.
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2.4. Copying and Moving Pipes

2.4.1. Copying Piping Group

1. Select [Pipe] tab > [Edit] > [Copy Piping Group] (  ).


Use the command [Copy Piping Element] ( ) when you want to copy the
piping element.

2. Pick piping groups to copy in the 3D View Window. A guide will appear.

3. Move the mouse cursor along the guide, and left-click at the point where you want to place
the copied pipe.

4. To continue copying the piping group, press [Done] (  ).
Press [Cancel] (  ) to finish copying the piping group.
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
The axes of displayed guide correspond to the XYZ direction on the present
coordinate system.

2.4.2. Moving Piping Group

1. Select [Analysis] tab > [Move] > [Move] (  ).

2. Pick the piping group to move in the 3D View Window. The move handle will be displayed.

 You cannot select only some of the piping elements in the piping group.

3. Drag the move handle to move the piping group.
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
It is also possible to move piping group by specifying the value in "Move"
dialog.

4. Press [Cancel] (  ) to confirm the movement.

2.4.3. Moving the End of the Piping Elements (Straight Pipe)

Below is the way to move the end of the straight pipes. This is useful when the straight pipes
cannot be connected since their position do not match.

1. Select [Pipe] tab > [Edit] > [Move Vertex of Straight Pipes] (  ).

2. Select straight pipe in the 3D View Window.
Select the end of the straight pipe in the piping group. This time, select the pipe that one of
its end is connected to the other piping element and the other end is not connected to any
element.
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3. Move the mouse cursor along the guide in the 3D View Window and left-click.

The position of the moved end will be confirmed.



◦ It is a movement with the connected straight pipe’s end fixed. The
length of the straight pipe will not be changed.

◦ When an independent straight pipe is selected, the movement will be
the rotation around the center of the straight pipe.

4. Press [Cancel] (  ) to finish editing.
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2.5. Replacing Pipes with Standard Parts
Below is the way to replace modeled piping elements with standard parts.

2.5.1. Replacing All Piping Elements with Standard Parts

1. Select [Pipe] > [Standard Parts] > [Replace All] (  ).

2. "Replace All Elements with Standard Parts" dialog will appear. Set tolerances and click [OK].

The piping elements will be replaced with standard parts fulfilling the specified conditions.
Select [Highlight Standard Parts] (  ) to display each standard pipe in colors.
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

• [Highlight Standard Parts] (  ) can be selected from [Home] tab >
[Display Method of Piping Elements].

• Use [Individual Selection] (  ) to replace only the specified piping
elements with standard parts.
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2.6. Aligning Pipes
Below is the way to align the axes of the modeled piping elements to connect each pipe
adequately.

2.6.1. Aligning All Axes Directions of Piping Groups

1. Select [Pipe] > [Align] > [Align All Elements] (  ).

2. "Align Piping Elements Automatically" dialog will appear. Set the angle tolerance and the
aligning option, and click [OK].

All piping group’s axes will be aligned to fulfill the specified conditions.

 Use [Align Piping Group] (  ) to align only specified piping groups.
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2.7. Generating CAD Models
Below is the way to generate a CAD model from the modeled piping elements or piping groups.

About the [Generate CAD Model] command

Use the CAD model created by the [Generate CAD Model] command to detect collision in
InfiPoints. Performing [Generate CAD Model] beforehand is not necessary if you want to
export the modeled elements as a CAD model.

2.7.1. Generating CAD Models from Piping Groups

1. Select [Pipe] > [CAD] > [Generate CAD Model] (  ).

2. Enable "Convert to solid model" in [Option] panel.

3. On "3D View" window, pick a piping element or a piping group from which you want to
generate a CAD model, and press [Done] (  ).
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

Change the [Smart Filter] to [Piping Element / Plane / Duct Element] or
[Piping Group / Plane Group / Duct Group] to easily pick elements.

A CAD model of a specified piping element or piping group will be created.

"Created_Piping_Group" will be added to the [Tree (Pipe)] panel.
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2.8. Editing Piping Tree
The structure of the piping elements is displayed in the [Tree (Pipe)] panel. This can be useful in
cases such as:

• Classifying piping elements into groups such as a "Cooling System" or an "Exhaust System."

• Switch between show and hide of the "Cooling System" piping group.

• Export only the "Cooling System" piping group to a CAD system.

2.8.1. Checking Pipes on [Tree (Pipe)] Panel

• Check the structure of the piping elements in the [Tree (Pipe)] panel.

Supported types of pipes:

• Straight Pipe ( )

• Flange ( )

• Elbow ( )

• Pipe Tee ( )

• Reducer ( )

• Valve ( )

• Others ( )

• By selecting piping elements or piping groups in the [Tree (Pipe)] panel, they will be
highlighted in the 3D View Window.

◦ When selecting a plane system on [Tree (Pipe)] panel
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Also, by selecting piping elements or piping groups in the 3D View Window, they will be
highlighted in the [Tree (Pipe)] panel.

◦ When a piping element is selected on "3D View" window



◦ Change the [Smart Filter] to [Piping Element / Plane / Duct Element] or
[Piping Group / Plane Group / Duct Group] to pick piping elements or
piping groups easily.

◦ Multiple pipes can be selected by selecting them while holding the
[Shift] or the [Ctrl] key.

• To confirm the point cloud around the selected piping, right-click on the piping element or
piping group on [Tree (Pipe)] panel, and select [Fit View to Element size] or [Display
Surroundings Only] from the context menu.

• Right-click on an element on [Tree (Pipe)] panel, and select "Collapse All Piping Groups"
from the context menu to close the entire piping groups.
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• Check the property of the selected piping elements or piping groups in the [Property] panel.

2.8.2. Creating Piping Groups

1. Right-click "Extracted Piping System" at the top of [Tree (Pipe)] panel, and select [Grouped
Piping Groups] in the context menu to create a "Grouped Piping Groups" folder.

2. Drag and drop the piping group to the created group folder to move into the group.
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 It is also possible to further break down groups into smaller subgroups.

2.8.3. Renaming Pipes

• Right-click on the group, piping groups or piping elements in the [Tree (Pipe)] panel and
select [Rename] to change the name.



◦ It is also possible to rename by selecting the group, piping groups or
piping elements in the [Tree (Pipe)] panel and pressing [F2].

◦ Delete the name by using the [Backspace] key to reset the changed
name.

2.8.4. Showing / Hiding Pipes

• Click the check box left of the group, piping group, or piping element in the [Tree (Pipe)]
panel to switch the show/hide status of pipes.
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

◦ By clicking the check box of each piping element will switch show/hide
status of the piping group which the element belongs to.

◦ Click the check box of [Extracted Piping System] in the [Tree (Pipe)]
panel to switch the show/hide status of piping system.
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2.8.5. Switching the Display Method of Pipes

1. Select [Home] tab > [Display Status] > [Display Method of Piping Elements] and select the
method to color pipes from the displayed pull-down list.

◦ Below are the five methods to color pipes.

▪ Default Color (  )

▪ Classify by Piping Type (  )

▪ Highlight Standard Parts (  )
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▪ Show Axes of Piping Elements (  )

▪ Texture (  )
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2.8.6. Changing the Display Color of Pipes

1. Select [Home] > [Display Status] > [Display Method of Piping Elements] > [Classify by Piping
Type] (  ).

2. Right-click on the piping group or the group to change the display color in the [Tree (Pipe)]
panel, and select [Edit Display Color….] in the context menu.

3. "Color" dialog will appear. Specify any color your prefer, and click [OK].

The specified display color will be reflected.
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
To clear the selected color, right-click on the color edited piping group or
the group and select [Reset to Default Color].
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3. Structure Modeling
This section explains how to create, delete, and manually edit structures based on the
automatically extracted planes in advance.

Preparing for Structure Modeling

• If planes are not extracted, please perform [Extract Planes and Pipes] beforehand.
Refer to "Extracting Planes and Pipes" in "InfiPoints Operation Manual Vol.1. Data Pre-
processing" for details.

• If structures are not displayed, select [Home] tab > [Display Status] > [Show/Hide
Structure] (  ). Similarly, select [Show/Hide Plane] if planes are not displayed.


Click [Show/Hide Structure] to change [Hide Structural Elements] (  )
and [Show Structural Elements] (  ).

• Select [Modeling] tab > [Structure] from the Ribbon menu.

[Structure] tab will appear. Users can perform structure modeling using functions in
this tab.
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3.1. Creating Structure Elements

3.1.1. Creating Structures on Specified Planes

1. Select [Structure] tab > [Create] > [Create on Specified Planes] (  ).

2. In [Option (Property)] panel, select a structural element (such as [H-beam]) from "Type"
column.



Standard Parts can be specified by Standards column on [Option
(Property)] panel. In addition, [Option (Option)] panel allows you to specify
whether to keep or delete the two planes that form the structural element.
(Right figure)

3. Select two planes (bottom and sides) that will form the structure and press [Done] (  ).
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4. Specify the size of the structural element. Select [2D View] at the top right of "3D View"
window to switch to 2D View mode.

5. Drag the handles (green/yellow/red) to adjust the cross-sectional size and the shape. Once
you start dragging, point for registered standards will be displayed in white circle, and you
can snap to it.

6. Press [3D View] to switch to 3D View mode again.

Click [Extend Structure Axis] in [Option (Edit)] panel to specify the length of the structural
element.

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 80 | 151





◦ Use command in [Option (Tool)] panel to further edit (rotate /fit to point
cloud) structural element.

◦ These commands are available in both [2D View] / [3D View] mode.

◦ You can create groups, edit groups, and change the name of groups in
[Tree (Structure)] panel. Refer to 3.6, “Editing Tree (Structure)” for more
detailed information.

7. Select a point or a plane (or a structural element if available) to define an endpoint. You can
also select structure if you have a previously created structure.
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8. Press [Done] (  ) to create a structural element. You can continue creating structural
elements.

To finish creating structural elements, press [Cancel] (  ) or [Esc] key.

3.1.2. Creating Structures at Specified Point

1. Select [Structure] tab > [Create] > [Create at Specified Point] (  ).

2. Specify the structural element information to be created in [Option (Structure type)] panel.
The structure which will be created with the current settings will be previewed in "3D View"
window.

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 82 | 151



◦ Select Type, Standard, Length in [Option (Structure type)] panel.

◦ Select Yaw/Pitch angle, Rotation angle and Axis location in [Option (Layout plane/ Axis
tab)] panel.
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

If you wish to create a structural element parallel to an existing
structural element, use (  ) in [Option (Layout plane/ Axis)] panel
(next to [Rotate at] field) to specify the angle by selecting a structural
element in 3D View Window. The [Rotate at] value will be automatically
updated accordingly.

3. Select a point on "3D View" window to place the defined structural element. You can
continue creating structural elements.

To finish creating structural elements, press [Cancel] (  ) or [Esc] key.

3.1.3. Adding Structural Elements

1. Select [Structure] tab > [Create] > [Add Structure] (  ).

2. Select a structural element to add a structural element to in "3D View" window. Click the
side to add to.
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3. Specify the structural element information to be added in [Option (Structure type)] panel.
The same settings as the selected structural element will be entered automatically. Change
the settings on the shape, etc. as required. The structure element which will be added with
the current settings will be previewed in "3D View" window.

◦ In [Structure type] tab, specify "Type" and "Standard".

◦ Orientation, Yaw/ Pitch angle, Rotation angle and Axis location by [Option (Layout plane/
Axis)] panel

4. Click on 3D View Window to specify the endpoint, and place the defined structural element.
You can continue creating structural elements.
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To finish creating structural elements, press [Cancel] (  ) or [Esc] key.



◦ Newly created structural elements will be added to the same sub-group
as the "added to" structural element.

◦ Refer to 3.2, “Editing Structural Elements” to further edit (rotate, change
the length and fit to point cloud) created structural elements.
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3.2. Editing Structural Elements

3.2.1. Editing Structural Elements

1. Click [Structure] tab > [Edit] > [Edit] (  ).

2. Select a structural element to edit in "3D View" window.


The subsequent operations are the same as 3.1.1, “Creating Structures on
Specified Planes”.

3. Select a structural element type ([H-beam] this time) in [Option (Property)] panel.

4. Press [2D View] in the upper right of "3D View" window to switch to 2D View mode.
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5. Drag green/yellow/red handles to adjust the cross-sectional size and the shape. Once you
start dragging, point for registered standards will be displayed in white circle, and you can
snap to it.

6. Click [3D View] to switch to 3D View mode.

Use command in [Option (Edit)] panel to further edit (rotate /fit to point cloud) structural
elements.
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7. Drag the blue handle to move the start and end of structure, and press [Done] (  ).

3.2.2. Changing Structure Standard Parts

1. Select [Structure] tab > [Edit] > [Edit] (  ).

2. Select structural elements in 3D View Window to change the standard.
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3. Standard Parts can be specified by Standards column on [Option (Property)] panel.

4. Press [Done] (  ) to change the structural element to the specified Standard size.

3.2.3. Fitting Structural Axes

1. Click [Structure] tab > [Edit] > [Edit] (  ).
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2. Select a structural element to edit in 3D View Window.

3. Click [Extend Structure Axis] in [Option (Edit)] panel.

4. Specify a plane to extend to in 3D View Window.
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5. Press [Done] (  ). The axis of the structural element to be edited is extended to the target
axis.

6. Follow the same steps to align the end point with the axis of the previous step. Two
structural axis will be fit.

■ Structure and Axis
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3.2.4. Extending Structural Elements to Specified Plane

1. Select [Structure] tab > [Edit] > [Edit] (  ).

2. Select a structural element to edit in "3D View" window.

3. Click [Extend Structure Axis] in [Option (Edit)] panel.
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4. Select a plane to extend to in "3D View" window.

5. Press [Done] (  ). The axis of structural element to be edited is extended to the target
plane element.

■ Point Cloud and Structure
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3.2.5. Fitting Structural Elements to Point Cloud

This is a function to move the structure along the surrounding point cloud. This is useful when
the structural elements created using [Create Structure on Specified Planes] do not match the
point cloud.

1. Click [Structure] tab > [Edit] > [Edit] (  ).

2. Select a structural element to edit in "3D View" window.

3. Click [Fit Structure to Point Cloud] in [Option (Tool)] panel.
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The structural element will be fit to point cloud.

 Please note that it may take time to fit structural elements to point cloud.
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3.3. Copying and Moving Structure

3.3.1. Copying Structure

Copy by structural element or structural group unit. This is effective when you wish to reuse a
structure, which has already been created, at a different location.

1. Click [Structure] tab > [Edit] > [Copy] (  ).

2. Select a structural element or structural group to copy in "3D View" window. A guide will
appear.



◦ Default setting of [Smart Filter] is "Structure". To select a structural
group, switch to "Structural Group".

◦ Please note that the axis of the displayed guide corresponds to the XYZ
direction in the current coordinate system.

3. Move the mouse cursor along the guide and left-click at any position to confirm.
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

You can also specify the moving distance of the copied structure
numerically in [Option] panel.

4. To continue copying the structure, press [Done] (  ).
To finish copying the structure, press [Cancel] (  ).

3.3.2. Moving Structural Elements

1. Select [Analysis] tab > [Move] > [Move] (  ).

2. Select the structural element or structure group you want to move on "3D View" Window.
The move handle will appear.
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3. Drag the move handle to move the structural element or structural group.



It is also possible to move piping group by specifying the value in the
"Move" dialog.

4. Press [Cancel] (  ) to confirm the movement.
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3.4. Aligning Structures
This is a function to align structural elements in a same structure group automatically. You can
align either a selected group only, or all structure groups at a time.

3.4.1. Aligning Selected Structure Group

1. Click [Structure] tab >[Align] > [Align Structure Group] (  ).

2. Select a structural group and press [Done] (  ).

3. "Align Structural Group" dialog will appear. Specify the angle tolerance and alignment
direction, and click [OK].

The selected structure group will be aligned.

3.4.2. Aligning All Structure Groups

1. Click [Structure] tab > [Align] > [Align All Structure Groups] (  ).

2. "Align Structural Group" dialog will appear. Specify the angle tolerance and alignment
direction, and click [OK].
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All structure groups will be aligned.
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3.5. Generating CAD Models from Structural
Elements or Structural Groups
This section explains how to generate CAD models from structural elements or structural
groups created in InfiPoints.

About the [Generate CAD Model] Command

The CAD models generated by [Generate CAD Model] is used to detect collision in
InfiPoints. However, note that there is no need to generate CAD models before "exporting"
CAD models

3.5.1. Generating CAD Models from Structural Groups

1. Click [Structure] tab > [CAD] > [Generate CAD Model] (  ).


You can also generate a CAD model in the color displayed in the 3D View
Window.
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2. On "3D View" window, pick the structural group from which you would like to generate a
CAD model and press [Done] (  ).


Edit the structural tree before generating CAD models as needed. Please
refer to 3.2, “Editing Structural Elements” for details.



◦ Multiple structural elements or structural groups can be selected in
succession.

◦ Switch the pick filter to [Structure] and pick structural element if you
would like to generate a CAD model from structural element.

The CAD model is generated from the selected structural groups.

Generated CAD models will be shown in [Tree (Overview)] panel as
[Created_Structural_Element] or [Created_Structural_Group].

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 104 | 151



Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 105 | 151



3.6. Editing Tree (Structure)
• You can edit tree structure, names, etc. in [Tree (Structure)] panel. This is to edit property

values only, and the shape and the location of structural elements will remain the same.

• CAD models are exported maintaining the tree structure, names, etc. when exporting with
[Export] (  ). Please note that only CAD models shown in 3D View Window will be
exported.

3.6.1. Checking Structural Elements

• [Tree (Structure)] panel shows the tree structure information of structural elements created
in InfiPoints.

• Select a structural element in [Tree (Structure)] panel, and the selected element will be
highlighted in 3D View Window.

◦ When a structure is selected on [Tree (Structure)] panel

Or select a structural element in 3D View Window, and the selected element will be
highlighted in [Tree (Structure)] panel.

◦ When structure is selected on "3D View" window
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 Select multiple structures while pressing down [Shift] or [Ctrl] key.

• To confirm the point cloud around the selected structure, right-click on [Tree (Structure)]
panel and select [Fit View to Element size] or [Display Surroundings Only] from the context
menu.

• Right-click on an element on [Tree (Structure)] panel, and select [Collapse All Structural
Groups] from the context menu to close the entire structural groups.
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• Select a structural element in either [Tree (Structure)] panel or 3D View Window. The
element information such as length and standard type will be displayed in [Property] panel.
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3.6.2. Grouping Structural Elements

1. Right-click "Structure" in [Tree (Structure)] panel, and select [Group Structural Groups] from
the context menu to create a new structure group.

2. Structural elements can be moved to another structure group either by dragging and
dropping structural element(s) in [Tree (Structure)] panel or by right-clicking a structural
element, selecting [Move] from the context menu and selecting a group.


You can also group structural elements in a structure group in the same
way.

3.6.3. Renaming Structural Elements

• To rename, right-click a structural element or structure group in [Tree (Structure)] panel
and selecting [Rename] from the context menu. Also, the [F2] key can be used to rename.
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• Delete the name, e.g., with [Backspace] to restore the previous name.

3.6.4. Changing Show/Hide Status of Structural Elements

• Check on/off the check box next to the structural group in [Tree (Structure)] panel to
show/hide elements that belong to it.

• Check on/off the check box next to the "Structure" in [Tree (Overview)] panel or [Tree
(Structure)] panel to show/hide all structural elements.

3.6.5. Editing Structural Color

1. Right-click structural group and select [Edit Display Color].

2. "Color" dialog will appear. Specify any color you prefer and click [OK].
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Selected color will be reflected.


Right-click structural group and select [Reset to Default Color] to reset the
display color to the default.
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4. Duct Modeling
This section explains how to manually create, delete, and edit ducts that are automatically
extracted by the function [Extract Planes and Pipes].

Preparing for Duct Modeling

• If planes are not yet extracted, run [Extract Planes and Pipes] first. Refer to "Extracting
Planes Refer to "Extracting Planes and Pipes" in "InfiPoints Operation Manual Vol.1.
Data Pre-processing" for details.

• If ducts are not displayed in the 3D view window, select [Home] tab > [Display Status]
> [Show/Hide Duct Elements] (  ). Similarly, select [Show/Hide Plane] if planes are
not displayed.


Click on the [Show/Hide Duct Elements] to change from [Show Duct
Elements] (  ) to [Hide Duct Elements] (  ).

• Select [Modeling] tab > [Duct] from the Ribbon menu.

The [Duct] tab appears. Users can create duct models using these functions.
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4.1. Creating New Straight Ducts
Ducts can be created from pre-extracted planes.

1. Select [Duct] tab > [Create] > [Create Straight Duct] (  ).

2. Select planes to form a straight duct and press [Done] (  ).


Planes used to create ducts can either be saved or deleted by choosing Keep
or Delete for [Whether to keep original planes] on the [Option] panel.

3. The following dialog will appear. In this example, click [No].
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
By clicking [Yes], the "3D View" window will switch to the Section mode and
you will be able to edit the section of a straight duct. For details refer to
4.2.2, “Editing Straight Duct Sections” for operation procedures.

4. A straight duct is created.

"Duct System" is added to the [Tree (Overview)] panel.
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4.2. Adjusting the Size and Position of Ducts

4.2.1. Editing Straight Duct Length

The following explains how to adjust the length of created straight ducts.

1. Select [Duct] tab > [Edit] > [Edit Duct Length] (  ).

2. Select the straight duct to edit the length, and then the edge to be edited.

3. "Edit Duct Length" dialog will appear. Select "Specify by a point in "3D View"" and click [Edit
in View].

4. Pick a point in the 3D View Window. A preview of the duct with its new edge length will
appear.
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5. When clicking [OK] in "Edit Duct Length" dialog, the length of the duct is confirmed.

4.2.2. Editing Straight Duct Sections

The following explains how to adjust the section of a newly created straight duct.

1. Select [Duct] tab > [Edit] > [Edit Duct Section] (  ).
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2. When you select a straight duct for editing, the 3D View window will switch to the Section
mode. You can then edit the section by dragging the round grip.



◦ In [Option] panel, enable "Length of one step" and drag the round grip
to snap at the specified interval.

◦ Adjust the display area of "3D View" window with the [Display area]
options in the [Section] panel.
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

◦ You can adjust in "3D View" window as well by disabling "Section
Mode" in [Section] panel.

(e.g.,) Section Mode: On →　Section Mode: Off

3. Press [Done] (  ) and the straight duct’s section size will be finalized. The 3D View will
also change from the section mode to the default mode.

4.2.3. Adjusting the Straight Duct Position

The following explains how to adjust the position of a newly created straight duct to align it
with point clouds.

1. Select [Analysis] tab > [Move] > [Move] (  ).
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2. Select the duct group to be moved in the 3D View Window.

"Move" dialog will appear, and the round grip will also appear in the 3D View Window.

3. Press [Rotation move] tab (  ) in "Move" dialog and pick both ends of the duct axis.
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

Change from [Default Color] to [Show Axes of Duct Elements] in the [Home]
tab to better visually check the position of the axes of ducts.

4. Move the round grip in the 3D View Window to adjust the orientation of the duct.
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4.3. Connecting and Adding Duct Elements

4.3.1. Connecting Duct Elements

The following explains how to connect newly created straight ducts. In this example, we will
show you how to connect straight ducts using a duct elbow.

1. Select [Duct] > [Create] > [Connect Ducts] (  ).

2. Select "Duct Elbow" in [Option] panel.

3. Pick two straight ducts to connect on "3D View" window.

A duct elbow is created to form a single duct group.
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4.3.2. Adding Duct Elements

The following explains how to add additional duct elements to newly created duct elements.

1. Select [Duct] > [Create] > [Add Duct] (  ).

2. Select the duct to which you would like to add a new duct element.


◦ Connecting parts cannot be attached in sequence.

◦ If a connecting part is selected, only straight ducts can be created.

◦ Only Straight ducts and duct elbows can be created using this function.

3. In [Option] panel, select "Orientation of layout". Specify other options if necessary.
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A preview of the created duct element is displayed in the 3D View Window. Move the mouse
cursor to check the shape of the duct and left-click at the desired position to place the duct.

(e.g.,) If [A] is chosen in [Orientation of layout]

(e.g.,) If [B] is chosen in [Orientation of layout]

The duct element will be placed. To consecutively place duct elements, continue selecting
the position of choice in the 3D View Window.
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4. To finish adding the duct elements, press [Cancel] (  ).

4.3.3. Merge Coaxial Ducts

The following explains how to connect straight coaxial ducts.

1. Select [Duct] > [Edit] > [Merge Coaxial Ducts] (  ).

2. Pick two or more straight ducts to merge on "3D View" window and press [Done] (  ).
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The selected straight ducts will be merged into a single duct.


Only straight ducts that have comparable axis and are similar in size and
orientation can be merged.
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4.4. Editing Duct Elements

4.4.1. Dividing Straight Ducts

1. Select [Duct] > [Edit] > [Divide Straight Duct] (  ).

2. Select the straight duct you would like to divide.

The selected straight duct will be divided.

4.4.2. Deleting Duct Elements

1. Select [Duct] > [Delete] > [Duct Elements] (  ).
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2. Select the duct element you would like to delete.

The selected duct element will be deleted.

4.4.3. Deleting Duct Groups

1. Select [Duct] > [Delete] > [Duct Groups] (  ).

2. Select the duct group you would like to delete from the 3D View Window.
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The selected duct group will be deleted.

4.4.4. Offsetting Duct Groups

The following explains how to offset duct elements. This can be useful, for example, when you
would like to resize the duct inward to remove the thickness of a heat insulating material.

1. Select [Duct] > [Edit] > [Reduce Section Size by Offset] (  ).

2. On "3D View" window, pick the duct group to offset and press [Done] (  ).

 Use [Smart Filter] to limit your selection.
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3. "Reduce Section Size by Offset" dialog will appear. Specify "Offset by" and click [OK].

The ducts will be offset inwards by the length you entered.
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4.5. Copying and Moving Duct

4.5.1. Copying Duct Elements

The following explains how to copy duct elements or duct groups. This can be useful, for
example, when you would like to create new duct elements or duct groups by copying and
rotating existing components.

1. Select [Duct] > [Edit] > [Copy] (  ).

2. Select the duct element or duct group to copy. A guide will appear in the 3D View Window.



◦ Default setting of [Smart Filter] is "Duct Element". To select a duct
group, switch to "Duct Group".

◦ Please note that the axis of the displayed guide corresponds to the XYZ
direction in the current coordinate system.
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3. Move the mouse cursor along the guide and left-click at any position to confirm.



You can also specify the moving distance of the copied duct numerically in
[Option] panel.

4. Press [Done] (  ) to copy the duct continuously.
Press [Cancel] (  ) to finish copying the duct.

4.5.2. Moving Duct Elements

1. Select [Analysis] tab > [Move] > [Move] (  ).

2. Pick the duct element or duct group you want to move on "3D View" window. Moving handle
will appear.

Elysium InfiPoints Operation Manual Vol.3. Point Cloud Utilization - Modeling -

 © 2022 Elysium Page 131 | 151



3. Drag the move handle to move the duct element or duct group.



It is also possible to move piping group by specifying the value in "Move"
dialog.

4. Press [Cancel] (  ) to confirm the movement.
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4.6. Replacing Ducts with Standard Parts
The following explains how to replace duct elements with registered standard parts.

4.6.1. Setting for Standard Parts

The standard parts setting is optional. Some standard parts are already pre-registered in
InfiPoints.

1. Select [Duct] tab > [Standards Parts] > [Settings on Standard Parts] (  ).

"Setting on Duct Standard" dialog will appear.

◦ Use the [Add] button to add standard parts files.

◦ Use the [Edit] button to edit standard parts files.

◦ Use the [Delete] button to delete standard parts files.

2. Check the checkbox to choose the standard parts file to use.

4.6.2. Replacing Duct Elements Separately

The following explains how to replace a single duct element, or all of the duct elements in a
duct group at once.

1. Select [Duct] tab > [Standards Parts] > [Individual Selection] (  ).
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2. Select the duct element in the 3D View Window.

3. "Replace with Standard Parts Manually One by One" dialog will appear. Select a new duct
standard.



Enable [Replace all duct elements in same path] to replace all duct
elements that are traceable through straight ducts, duct elbows and S-curve
with the identical section dimensions of the selected standard. However, if
a hopper is included, the standard replacement ends at that point as the
section size changes.

4. Click [OK] to replace the duct element with a standard part.
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
Change the display to [Highlight Standard Parts] so that you can easily
identify ducts that were replaced with standard parts. Duct elements not
replaced with standard parts will be displayed in white.

4.6.3. Replacing All Duct Elements

1. Select [Duct] tab > [Standards Parts] > [Replace All] (  ).
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2. "Replace All Elements with Standard Parts" dialog will appear. Set the tolerances for section
size and angles.

3. Click [OK] to replace all duct elements with standard parts.
(Before: Default View) → (After: Highlight Standard Parts)


Change the display to [Highlight Standard Parts] so that you can easily
identify ducts that were replaced with standard parts. Duct elements not
replaced with standard parts will be displayed in white.
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4.7. Aligning Duct Elements

4.7.1. Aligning Duct Groups

The following explains how to align connected duct elements within the same duct group. For
example, if two straight ducts are connected with a duct elbow at an angle close to 45 degree or
90 degree, they will be aligned exactly at either 45 degree or 90 degree.

1. Select [Duct] tab > [Align] > [Align Duct Group] (  ).

2. Select the duct group to align and press [Done] (  ).

3. "Align Duct Group" dialog will appear. Set "Angle tolerance", enable "Also align horizontal
ducts to world coordinate X/Y-axes" if needed, and then click [OK].

The elements in the duct group will be aligned.
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4.7.2. Aligning All Duct Groups

1. Select [Duct] tab > [Align] > [Align All Duct Groups] (  ).

2. "Align Duct Group" dialog will appear. Set "Angle tolerance", enable "Also align horizontal
ducts to world coordinate X/Y-axes" if needed, and click [OK].

All duct elements within the duct groups will be aligned.
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4.8. Generating CAD Models
The following explains how to generate CAD models from duct elements or duct groups. Use this
function, for example, when performing interference check with duct elements or duct group.

(e.g.) Interference check with duct group CAD models

1. Select [Duct] tab > [CAD] > [Generate CAD Model] (  ).

2. Enable "Convert to solid model" in [Option] panel.

3. On "3D View" window, pick a duct element or a duct group to generate a CAD model from
and press [Done] (  ).
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 Use [Smart Filter] to filter elements.

CAD models are generated from the selected duct element or duct group.
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4.9. Editing Duct Tree
Use the [Tree (Duct)] panel to edit duct attributes. Duct geometry and position will not change.
For example, this could be useful in the following cases:

• When classifying duct groups for specific purposes such as "For Air Conditioning" and "For
Ventilation," and then when you would like to hide the "For Air Conditioning" ducts.

• When switching between hide/show for each group in order to export just the "For Air
Conditioning" ducts as CAD files.

4.9.1. Checking Ducts

• The duct structure tree appears when switching to the [Tree (Duct)] panel.

• The selected duct element in the tree is highlighted in the 3D View Window.

◦ When a duct system is selected on [Tree (Duct)] panel

Conversely, if a duct element is selected in the 3D View Window, the corresponding duct
element in the tree will also be highlighted.
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◦ When a duct element is selected on "3D View" window



◦ Use [Pick Filter] to filter duct elements for easier selection.

◦ Hold down [Shift] or [Ctrl] keys to select multiple ducts.

• To check the surrounding point cloud of the selected duct element, right-click on the duct in
[Tree (Duct)] panel, and select [Fit View to Element size] or [Display Surroundings Only]
from the context menu.

• Right-click on an element in [Tree (Duct)] panel, and select [Collapse All Duct Groups] from
the context menu to close the all duct group.
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• Check the duct element or duct group properties in the [Property] panel.

(e.g.,) Selection of a duct group

4.9.2. Grouping Duct Groups

1. Right-click on the duct part named [Duct System] in the [Tree (Duct)] panel and select
[Group Duct Groups] to create a group folder.

2. Drag-and-drop duct groups within the group folder to move to a different group.
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

You can also divide groups into subgroups within the same group.

4.9.3. Renaming Duct Elements and Groups

• Right-click on the grouped duct group, duct group, or duct element in the [Tree (Duct)] panel
and select [Rename] or press the [F2] key to change the name.



◦ Press [Export (CAD Model)] (  ) to export CAD models corresponding
to the tree structure and name set here.

◦ It is recommended to use easy-to-understand names for groups such as
"For Air Conditioning."

◦ Renaming can be done by pressing the [F2] key while you select the
group, duct group, or duct element in the [Tree (Duct)] panel.

◦ Erase the name by pressing the [Backspace] key during edit to return to
the previous name.
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4.9.4. Changing the Show/Hide Status

• Check the box on the left side of the grouped duct group or duct group in the [Tree (Duct)]
panel to switch show/hide status of duct elements.



◦ When one of the duct elements is checked, the entire belonging duct
group will be changed to show status. It is impossible to change the
show status for each duct element.

◦ Check the checkbox of "Duct System" in the [Tree (Overview)] panel or
[Tree (Duct)] panel to switch the show/hide status of duct parts.

4.9.5. Changing Display Method

1. Change the display method of duct elements by selecting from the pull-down list of [Display
Method of Duct Elements] on the [Home] tab.
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◦ There are 4 display modes:

▪ [Default Color] (  )

▪ [Classify by Duct Group] (  )

▪ [Highlight Standard Parts] (  )
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▪ [Show Axes of Duct Elements] (  )

4.9.6. Changing Display Color of a Duct Group

1. Select [Classify by Duct Group] (  ) from the [Display Method of Duct Elements] pull-down
list on the [Home] tab.

2. Right-click on the duct group of grouped duct group and select [Edit Display Color] in the
context menu to change the display color of the [Tree (Duct)] panel .

3. "Color" dialog will appear. Specify any color you prefer and click [OK].
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4. The selected color will be reflected in the tree view.


To clear the selected color, right-click on the plane or plane group and
choose [Reset to Default Color] in the context menu.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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