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Shortened Names for 3DxSUITE Products

In this document, the 3DxSUITE product names are referred to as follows:

• 3DxSUITE Components → Components

• 3DxSUITE Viewer → Viewer

• 3DxSUITE Editor → Editor

• 3DxSUITE SmartLauncher (Standalone) → SmartLauncher (Standalone)

• 3DxSUITE SmartLauncher (Plug-in) → SmartLauncher (Plug-in)

• 3DxSUITE SmartController → SmartController

• 3DxSUITE SmartController Pro → SmartController Pro

• 3DxSUITE TransServer → TransServer

• 3DxSUITE WorkerNode → WorkerNode

• 3DxSUITE ScenarioEditor → ScenarioEditor

• 3DxSUITE Data Package Studio → Data Package Studio

• 3DxSUITE Validation Configurator → Validation Configurator

• 3DxSUITE PDQ Checker Configurator → PDQ Checker Configurator

• 3DxSUITE Setting Utility → Setting Utility
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1. Preface

1.1. About this Tutorial
This tutorial consists of four parts: Beginner, Intermediate, Advanced, and More Advanced. It is
designed to help you learn how to use Editor step by step. Each content will be explained in
detail.

2, Beginner

This level explains the basic operation for translating data in Editor. If the quality of data are
not so bad, translation can be done just with the knowledge of Beginner level.

3, Intermediate

This level explains how to correct errors by using Interactive Healing. Most of the data can
be translated properly with the knowledge of Intermediate level.

4, Advanced / 5, More Advanced

For errors which could not be corrected with the knowledge of Intermediate level are
explained in the form of case studies. Please refer to these case studies whenever necessary.

Furthermore, the functions described in this tutorial are just a part of Editor. Please refer to the
help for other functions.

About Help

For help, select [Help] > [Help Index] from Editor menu. The help provides details about
the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark appears next to the cursor so either double-click the menu or just click the
icon.
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1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

Example:
For example, the "Fit" function is described as [View] > [Fit] ( ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.

1.3. About Explanatory Notes
Explanatory notes are categorized as follows:

 Contains important information. Be sure to check and set this item.

 Warnings are listed. Be sure to check these items.

 This information is useful when using the product.

 Contains information that can be used for reference.

1.4. About Sample Data
The sample data to be used is located in the folder " \document\tutorial_models\standard" inside
the folder where Editor is installed.

1.5. About Images
The images in this document may include slight differences from the ones actually displayed on
your Editor depending on your specific computer hardware and the Editor version.
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2. Beginner
This section will explain the basic operation for translating data in Editor.
If the quality of the data are not so bad, translation can be done just with the knowledge of
Beginner level.

Firstly, this chapter will explain about "Basic Operation" and "File Management." Then to 2.3,
“General Data Translation” which is about the basic translation method, and 2.3, “General Data
Translation” which compares before and after modification of geometries.

2.1. Basic Operation
This section will explain the basic operation of Editor.

2.1.1. User Interface

① Menu bar Displays various commands.
② Toolbar Displays frequently used icons from the menu bar.
③ Main panel Used mainly for basic operations. Run [Check] and [Auto

Heal] for check items displayed in the list.
④ Navigation panel Displays the most suitable tool to modify the check item.

Also, when switching to [Fit], the fitting tools will be
displayed.

⑤ Status bar Displays information such as the current status and a guide
to the next operation.

⑥ "3D View" window Displays the imported model.
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■ Navigation / Guide

Advises the best way to modify the error items.

• Navigation

• Guide (Repair Tool / Auxiliary Tool)

The operation procedure is as follows.

1. In [Main (Work)] panel, select the error item from the category list.

2. The best modification method is displayed on Navigation panel. Press and use the
appropriate one.

◦ Repair Tool: Effective for error modification.

◦ Auxiliary Tool: Creates reference lines, etc. needed for repair tools.

◦ Guide: Explains in detail Repair Tool / Auxiliary Tool on the Navigation panel.
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2.1.2. View Operation

■ Mouse Operation

This section explains how to use the mouse on "3D View" window.

Command Description Mouse / Keyboard Shortcut

 Pan Move the model parallel. Right mouse button + drag

 Rotate 3D Rotate the model in 3D
according to the mouse
movement.

Left mouse button + drag

 Rotate 2D X Rotate around the horizontal
axis of "3D View" window.

(Left and right of the screen)
Left mouse button + drag

 Rotate 2D Y Rotate around the vertical axis
of "3D View" window.

(At the bottom of the screen)
Left mouse button + drag

 Rotate 2D Z Rotate around the depth axis
of "3D View" window.

(At the top of the screen)
Left mouse button + drag

 Fit Automatically adjust all
elements to fit in "3D View"
window.

Ctrl + F

 Zoom The view is zoomed in and out.
(When zoomed in, the vertical
height doesn’t change, but
moves in the depth direction
and the opposite direction.)

• Mouse scroll wheel

• Middle mouse button + drag

• Both mouse button + drag

 Zoom Area Zoom into the area enclosed
by a rectangle. None

 Fix Rotation
Center

Set the specified point as the
center of 3D rotation. Ctrl + Q

 Fix Rotation
Axis

Specify the rotation axis when
rotating the plane. None
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

Please note that the rotation method in "3D View" window will change
depending on where you drag from.

• Drag at the top of "3D View" window: Rotate 2D Z ( )

• Drag at the bottom of "3D View" window: Rotate 2D Y ( )

• Drag at the left of "3D View" window: Rotate 2D X ( )

• Drag at the right of "3D View" window: Rotate 2D X ( )

• Drag at the center of "3D View" window: Rotate 3D ( )

■ Change View

This section will explain how to change the view using the toolbar icons.

Command Description
Snap to Axis Change the current view to the closest

basic axis view, then fit the view.
XY Change the viewing angle toward XY
YX Change the viewing angle toward YX
YZ Change the viewing angle toward YZ
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Command Description
ZY Change the viewing angle toward ZY
ZX Change the viewing angle toward ZX
XZ Change the viewing angle toward XZ
XYZ Change the viewing angle toward XYZ
YXZ Change the viewing angle toward YXZ

Command Description
Rotate 2D X (90 degree) Rotate 90 degrees vertically.
Rotate 2D X (180 degree) Rotate 180 degrees vertically.
Rotate 2D X (270 degree) Rotate 270 degrees vertically.

Command Description
Rotate 2D Y (90 degree) Rotate 90 degrees horizontally.
Rotate 2D Y (180 degree) Rotate 180 degrees horizontally.
Rotate 2D Y (270 degree) Rotate 270 degrees horizontally.

Command Description
Rotate 2D Z (90 degree) 90 degrees plane rotation.
Rotate 2D Z (180 degree) 180 degrees plane rotation.
Rotate 2D Z (270 degree) 270 degrees plane rotation.

■ Display Type
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This section will explain how to change the display type using the icons on the toolbar.

Command Description
Wireframe Display elements in wireframe mode.
Shading + Wireframe Display elements in shading and wireframe mode.
Shading Display elements in shading mode.
Semi Transparent Display elements in semi-transparent mode.

When "3D View" window is coarse

Zooming in and out of "3D View" window may result in a coarse appearance of the model.
In such a case, select [View] > [Regen] from the menu or click [Regen] ( ) on the toolbar.
"3D View" window will be updated.
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Saving View Direction

With Editor View Configuration function, it is possible to register any view direction and
display it again later. View information is held by Editor, not by each model. Therefore,
the registered view direction can be shared between different models.

■ How to Save View Direction

1. Display the model by the view direction that you want to save.

2. Select [View] > [Change View] > [View Config] from the menu.

3. "View Management" dialog will appear. A list of previously saved view names is
displayed. Click [Create] to save new view.

4. "View" dialog will appear. Enter the name to register, then click [OK]. The newly
created view direction is registered.

■ Redisplay with the Saved View Direction

1. Display "View Management" dialog in the same way as you did in "Saving View
Direction".

2. Select the preferred view to display from the list and click [Apply]. Selected view
information is reflected on the screen.

If you save the errors in Editor with this function , the viewpoints can easily be
redisplayed for checking after modification.
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2.2. File Management

2.2.1. Open Files

Open .drfx file that contains the working state of Editor.

1. Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar.

2. "Open" dialog will appear. Specify .drfx file and click [Open].


The sample data used in the tutorial is located in "document" >
"tutorial_models" folder inside the folder where Editor is installed.

2.2.2. Save Files

With Editor, the current working state can be saved as a .drfx file.

1. Select [File] > [Save As] from the menu.

2. "Save As" dialog will appear. Specify the location and file name to save, and then click
[Save].
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
When editing an existing .drfx file, click [Save] ( ) to overwrite the
currently opened .drfx file.

About the sample data in the tutorial

The sample data in the tutorial are "read-only" and cannot be saved.

To save the sample data you are editing, select [Save As] to save it under a different file
name.
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2.3. General Data Translation
When translating data, errors caused by the differences in tolerance and data structure
between the source and target CAD systems need to be corrected.

With Editor, you can correct these errors and translate the data with the following operation
flow.

1. Import file from source CAD system

2. Check and detect errors that may cause problem during translation

3. Correct the detected errors

◦ Auto Stitching

◦ Auto Healing

◦ Interactive Healing

4. Export file to target CAD system

Beginner level follows the above operation flow to translate the sample data.

2.3.1. Mode

Editor has multiple modes that can be switched depending on your purpose. The best choice for
data translation, for example, is "Translation" mode. Modes can be switched on [Main] panel.

In this case, use "Translation" mode which is most suitable for data translation.

1. Click "Translation" from the drop-down list at the upper left of [Main (Work)] panel.


Please note that each mode requires an optional license when switching to
the mode, for example, Simplification mode.
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2.3.2. Import

Import the sample model (SAMPLE1.igs) into Editor.


In some parts of this manual, IGES format files are used to explain the
procedures. To import IGES format files, a dedicated license is required. If you
do not have an IGES license, open a file with the same file name but with a
.drfx extension.

1. Select [File] > [Import] from the menu or click [Import] ( ) on the toolbar.

2. "Open" dialog will appear. Change the type of file to "IGES (.igs, .iges)" and click [Option].

3. "Option" dialog will appear. In "Stitch (Stitch)?", enable "0: Don’t stitch." and click [OK].
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
Please note that "Stitch" is disabled intentionally at this point because it is
necessary in the operation explanation that follows. Normally, you do not
need to disable "Stitch".


In "Open" dialog, click [Option]. Set input option in the format specified in
"Files of type".


Please note that the type of files you can import depends on the licenses
you have.

4. "Open" dialog will appear. Specify SAMPLE1.igs file from the <tutorial> folder and click
[Open]. Specified file is imported and displayed on "3D View" window.
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2.3.3. Data Check

This function checks where the errors exist in the imported data.

[1] Target CAD System

1. In [Main (Work)] panel, specify the output target in "Out". In this case, specify "CATIA V4".


With Editor, it is recommended that you specify the target CAD system at
the time of import. Main options are automatically set for the source /
target CAD system at the time of import. Target CAD system can be changed
before Auto Heal.


Please note that when importing an Elysium Neutral File (*.enf, *.drx,
*.armo), the target CAD system may be selected automatically for you. In
such a case, you do not need to explicitly specify the target CAD system
here.

[2] Check

1. In [Main (Work)] panel, press [Check] ( ).
Check is executed and the check result will be displayed.

[3] Check for Errors
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Confirm the detected errors in order.

1. In [Main (Work)] panel, select "Gap: In loop" in the category list.
The errors are highlighted in red on "3D View" window.
* To make the errors easier to see, the view has been switched to wireframe mode.


Please refer to A.1, “Error Items” in the Appendix for details about error
items.

Confirm the detected errors one by one.

2. In [Main (Work)] panel, press [Zoom current target] ( ).
One of the errors is zoomed up and highlighted.

Press [Next] ( ) to highlight the next error. Also, press [Previous] ( ) to go back to the
previous error.

 Use 2.1.2, “View Operation” to make the errors easier to check.


If you have difficulty moving the model in "3D View" window, you can
specify the center position of 3D rotation.
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

Press [Fix Rotation Center] ( ) and pick a spot for the center.
Alternatively, right-click on "3D View" window and specify from the context
menu.

Press [Deactivate Rotation Setting] ( ) to release the rotation center.

3. In [Main (Work)] panel, press [Show Surrounding] ( ). Only the elements related to the
error are shown in "3D View" window.

Again, press [Show Surrounding] ( ) to undo. This function is useful when there are
numerous elements and it is difficult to see the errors.
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2.3.4. Auto Stitch

In [Main (Work)] panel, press [Auto Stitch] ( ). If there is an element in a model that does not
have adjacency information (topology), the adjacent faces can be combined to have a topology.
This operation is called "Stitch".

By stitching, "Missing face" can be modified.

1. In [Main (Work)] panel, press [Auto Stitch] ( ).

2. "Auto Stitch" dialog will appear. Because the default value will be used in this case, click
[Try].



Please note that the tolerance described in IGES file will be displayed as the
initial value in "Tolerance". For this sample model (SAMPLE1.igs), 0.1mm
will be displayed. If the tolerance is not described in the model, the
specified "Point coincident" value in "Check Options" dialog, which can be
called from [Check] > [Options], will be displayed.

Tolerances specified here is used only for Auto Stitch. It will not affect other
tolerances during modification or check.
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3. The number of free edges is updated. In "Auto Stitch" dialog, confirm that the number of free
edges is "0", then click [Fix].



If free edges still remain after clicking [Fix], loosen the tolerance and try
again. However, note that if the tolerance is loosened too much, an error
such as "Gap: Edge and base surface" may occur.

For topological reasons, there are models whose unused edge does not
become "0". If so, check the location of the free edge and determine
whether you need to retry.
Please refer to 4.1, “Modifying Free Edge” for details about free edge.

Data is updated. At the same time, the check result in [Main] panel is updated.

Flip Face

Orientation of the faces are automatically consistent after stitching; however, in some
cases, the front and back of the faces are reversed.

If the face is in gray, as shown in the lower left figure, the direction of the face is correct
and no modification is necessary. If the face is in khaki, as shown in the lower right
figure, the face is reversed.

In such a case, select [Modify] > [Repair Solid] > [Flip face] from the menu or click [Flip
face] ( ) on the toolbar to correct the direction of the faces.
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2.3.5. Auto Healing

This function can be used to automatically heal errors.

1. In [Main (Work)] panel, press [Auto Heal] ( ).

2. A confirmation dialog will appear. Confirm that the target CAD system is set properly, then
click [OK].

Automatically heal a portion of the errors and the category list is updated.

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 21 | 152




Please note that the icon color of [Auto Heal] will change from "before"
( ) to "after" ( ).

Options for Auto Heal

There are two options for Auto-Heal, "Powerful Healing" and "Minimal Healing".

• With Powerful Healing, the usual powerful healing is applied.

• With Minimal Healing, which can heal faster than Powerful Healing, the healing items
are limited to ones that are required to keep the solid model.

Select [Modify] > [Options] from the menu. "Modification Settings" dialog will appear.
Switch the setting in [Auto-Heal] tab.
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2.3.6. Interactive Healing

When errors still remain after automatic healing, perform interactive healing to modify the
errors.
"Serious" and "critical" level errors may cause missing faces, etc. during data translation.

In this case, the serious level error "Gap: Edge and base surface" will be modified.



Depending on the source and target CAD systems, automatic healing may
modify all errors. This is due to the difference in options, etc. If all errors have
been modified, then skip to 2.3.7, “Export”.

In some cases, errors with a severity of "Minor" may remain, which is a
warning level error. You do not have to modify.
Please refer to A.1, “Error Items” in the Appendix for details about error items.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. On "3D
View" window, the position of the error "Gap: Edge and base surface" is highlighted in red.

Also, Repair icons will appear on Navigation panel. These repair icons can be used to modify
the error "Gap: Edge and base surface".


Repair icons are listed from the left side in the order of highest frequency
of use.

2. In [Main (Work)] panel, press [Zoom current target] ( ).
On "3D View" window, the current target error is zoomed up.
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3. Press [Fit Face to Loops] ( ) located at the farthest left of Repair Tool on Navigation panel.

A new surface is calculated, and the geometry of the surface is displayed and highlighted in
light blue on "3D View" window.

4. A confirmation dialog will appear. Click [OK].

The error is modified, and the category list is updated.

5. Again, press [Zoom current target] ( ) to zoom up the next error.
Modify the remaining "Gap: Edge and base surface" errors with [Fit Face to Loops] ( ).
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

The function [Fit Face to Loops] ( ) is highly versatile, and can be used to
modify almost all "Gap: Edge and base surface".

Please refer to Intermediate: 3.1, “Interactive Healing” for details about
modification functions.

In [Main (Work)] panel, all errors are now "0" in the category list.
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2.3.7. Export

In this section, the sample model (SAMPLE1.igs) will be output in CATIA V4 file format.

1. Select [File] > [Export] from the menu or click [Export] ( ) on the toolbar.

2. "Save As" dialog will appear. Specify "CATIA V4 (*.model)" as the type of file. Enter the file
name and location to save the file, then click [Save].



In "Save As" dialog, click [Option] to set the output options for the format
specified in "Save as type".


Please note that the type of file that can be exported depends on the target
CAD system selected at the time of import and the license you have.
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Check the result

When exporting, if your file type is either "CATIA V4" or "Parasolid", you can confirm the
result from [Main (Result)] panel.

If the data cannot be translated into solid, the [Results] tab becomes active, and a list of
translation errors will appear. (See below figure)

In such a case, confirm the areas around the translation errors on "3D View" window, and
repeat interactive healing on the errors. In addition, the failed errors might only be
identified on a per volume basis.

Nothing will appear in the list of translation errors if you were able to translate into a
solid. The sample model used in this case also does not show any errors in the list;
therefore, you can confirm that it was translated into a solid.

 Please refer to the help for more details about Results tab.
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Translating Large Files

When translating a large file, set the "Reduce Memory Mode". When this mode is set, a
part of the information on memory is saved to a file, so memory usage can be suppressed.

■ How to Set Up

1. Select [File] > [System Preference] from the menu.

2. "System Preference" dialog will appear. In [Miscellaneous] tab, enable "Reduce
Memory Mode".

3. In "System Preference" dialog, specify "Work" from [Path] tab.


Use "Reduce Memory Mode" even if "Work" is not specified, but in
such a case, the default temporary area of Windows will be used.
Therefore, it is recommended that you specify "Work".

4. Click [OK] in "System Preference" dialog. When changing the Work path, reboot the
application to reflect the changes.


◦ Please note that a warning dialog might appear when Work

folder has only 500MB or less storage capacity.
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2.4. Geometry Verification Mode
With Geometry Verification function, you can visualize the differences geometrically and
topologically by comparing the two models in such ways as before and after data translation,
and before and after modification.



Geometry Verification Mode, in which geometry comparison is performed, is
treated as an independent function of Analysis menu. Therefore, operations
that involve modifying elements or models cannot be done in Geometry
Verification Mode. In addition, menus other than view operations to check the
comparison results are restricted.

It is possible to switch to Geometry Verification Mode from any mode. Just select [Geometry
Verification Mode] ( ) from Geometry Verification menu.

Position of Geometry Verification Mode

Geometry Verification Mode has two functions, "Detailed Comparison" and "Quick Comparison",
which can be used according to your purpose.

"Example of Usage"

Quick Comparison: Comparing the design before and after
Detailed Comparison: Comparing the translated model before and after modification
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2.4.1. Operation

1. Select [Geometry Verification] > [Open Comparison Result] ( ) from the menu.

2. "Open" dialog will appear.
Specify SampleResult.gvfx in the <tutorial> folder and click [Open].

This will switch automatically to Geometry Verification Mode. In "3D View" window, the left
sample model, which is before modification, has a soft wavy surface. The right sample
model, which is after modification, is a plane.

Geometry Verification toolbar will appear in the toolbar.
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Immediately after switching to Geometry Verification Mode, since [Synchronize Views] ( )
is enabled, all view operations are synchronized on the left and right models as shown in
the below left figure.

Press [Synchronize Views] ( ) to disable the function. Left and right view windows can be
operated independently as shown in the below right figure.

3. In [Main (Work)] panel, select "Face Distance" from the category list. Distance between the
left and right models is displayed in different colors according to the gap between faces.

By default, "Nearest Point Direction" is set to display by needles the nearest point direction
per point. Small deviations are shown in blue, and large deviations in red.

4. Press [Switch Direction / Contour] ( ) on the toolbar.
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Toggle the viewing mode to contour. [Contour View] will fill in the gap and display the data
based on [Nearest Point Direction].


[Contour View] may take longer and consume more memory than [Nearest
Point Direction]. Therefore, please ensure to have sufficient memory when
running [Contour View] on a large model.



To switch direction / contour or set the displayed color result, press
[Settings] ( ) located at top right of [Main (Work)] panel. "Geometry
Verification Setting" dialog will appear. Specify the preferred setting in
[View Setting (1), (2)] tabs.

For example, change "Mid-range deviation color" from "Green" to "White", then click
[Apply].
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The display color will change as shown below.

Again, set "Mid-range deviation color" to "Green", and press [Switch Direction / Contour]
( ) on the toolbar to switch to [Nearest Point Direction].

5. Press [2View/1View] ( ) on the toolbar.

As shown below, only the left model and the differences are shown in one big view (1View).
[1View] is useful when there is no need to look at the right model to compare with or when
you want to temporary use the full screen to check the left model.


When [2View/1View] ( ) is enabled, [2View] is enabled. When disabled,
then [1View] is enabled. Please note that this function only appears on the
toolbar.

6. Press [Draw 2Model in 1View] ( ) on the toolbar.
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Left and right models are displayed overlapping each other. Depending on the geometry of
the models being compared, it may be easier to see the differences by overlapping them.


Above figure is switched to [Shading + Wireframe] ( ) for easier viewing
on "3D View" window.


When [Draw 2Model in 1View] ( ) is enabled, the models will overlap
each other. When disabled, the models are independently displayed. Please
note that this function only appears on the toolbar.

Besides toggling this function for easier comparison, you can insert indicators as markers.

■ Add and Remove Point Indicator

1. Press [Add Point Indicator] ( ) on the toolbar.

2. Select elements such as vertices and edges, etc. in the left model. Red indicators will be
created at the specified position and likewise for the right model.
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Same operation can be done with the right model except the indicators will be blue.
Indicators will be created in the same position for the left model.

3. Press [Remove All Point Indicators] ( ) on the toolbar to remove all indicators.
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2.4.2. Start Geometry Verification

Using the sample model which has the error "Gap: Edge and base surface", compare the
geometry before and after modification and check how the surface has changed.

1. Refer to 2.2.1, “Open Files” and open SampleM1.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
error is highlighted in red.

3. Click [Fit Face to Loops] ( ) on Navigation panel to modify the error.


Please refer to 3.1.2, “Fit Face to Loops” in Intermediate for details about
operation.

4. Select [Geometry Verification] > [Geometry Verification Mode] ( ) from the menu to
switch to "Geometry Verification Mode".
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Current model is displayed on the left screen as the comparison reference model.

Next, open the model that you want to compare.

5. Press [Open Right Model] ( ) on the toolbar.

6. "Open" dialog will appear. Change the file type to "Editor Files (.drfx)", then open
SampleM1.drfx in the <tutorial> folder.

 Also, to import a model, just drag-and-drop the model onto the right screen.

Sample model will appear on the right screen.

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 37 | 152



Next, set the options for Geometry Verification.

7. Select [Geometry Verification] > [Settings] from the menu or press [Settings] ( ) at the
upper right of [Main (Work)] panel.

8. "Geometry Verification Setting" dialog will appear. From [Verification Setting] tab, select
"Detailed Comparison" in "Comparison Mode", and click [OK].

Next, run Geometry Verification.

9. Press [Begin Verification] ( ) at the lower left of [Main (Work)] panel. Verification
between the modified model on the left screen (current model) and the unmodified model
on the right screen is executed.

10. Select "Face Distance" from the check item in [Main (Work)] panel. Confirm that the surface
has been modified to fit along the curved shape.



Click [Save Comparison Result] ( ) on the toolbar to save the comparison
result.

The saved comparison result file (.gvfx) can be opened by clicking [Open
Comparison Result] ( ) on the toolbar.

11. After confirming the comparison result, select [Geometry Verification] > [Geometry
Verification Mode] ( ) again.
You will return to the state just before entering Geometry Verification Mode.
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2.4.3. Geometry Verification of Whole Model Before and After Auto
Heal

This section will explain how to automatically perform Geometry Verification for models before
and after Auto Heal.

Advantage of this function is that you can shorten the running time rather than if you were to
manually save the drfx file before auto healing and manually compare the geometry
afterwards.

1. Press [Open] ( ) on the toolbar. Open SampleM2.drfx from the <tutorial> folder.

2. Select [Modify] > [Options] from the menu. "Modification Settings" dialog will appear.
In [Auto-Heal(2)] tab, enable the option "Compare to pre-modify model after healing" and
click [OK].
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
Please note that [Setting], which is located on the right of this option, must
be set before auto healing. Settings will not be changed here because the
default values will be used.

3. In [Main (Work)] panel, press [Auto Heal] ( ).

4. After auto healing is completed, "Auto Comparison" dialog will appear. Click [Yes].

When the verification is completed, it automatically switches to Geometry Verification Mode
and the comparison result is displayed.

5. After confirming the check result, once more select [Geometry Verification] > [Geometry
Verification Mode] ( ) from the menu.
Close Geometry Verification Mode and return to where you left off after auto healing.
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2.4.4. Partial Geometry Verification of Interactive Healing (Before
and After)

For a model before and after interactive healing, you can perform partial geometry comparison
on a partially modified part. However, this section will explain how to perform geometry
verification without saving the unmodified drfx file.

Detected error "Gap: Edge and base surface" will be interactively healed, and the geometry
before and after modification will be compared.

1. Press [Open] ( ) on the toolbar. Open SampleM3.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Press
[Zoom current target] ( ).

The error is zoomed up. In this error, the surface is distorted, so modify the error by
replacing the surface.

First of all, store the "before modification" model internally.
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
With Editor, the currently displayed model in "3D View" window is stored
as a geometry data, but a second model can be internally stored as a
separate model. This internally stored data is displayed as "Target model
(on right)" when switching to [Geometry Verification Mode].

3. Select [Geometry Verification] > [Target Model] > [Copy Current Model] ( ) from the
menu.


No change can be seen on Editor, but the displayed model (before
modification model) is stored internally. Also, when selecting [Geometry
Verification] > [Target Model] > [Delete Target Model] ( ), the internally
stored model will be deleted. (*So DON’T select here.)

Next, modify the error.

4. Press [Recalculate Surface] ( ) from Repair Tool on Navigation panel.

5. "Surface Recalculation" dialog will appear. To avoid reflecting the original surface in this
model, set "Original Surface Similarity" to "Less", and click [OK].

6. Recalculated surface will be displayed and a confirmation dialog will appear. Click [OK].
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After completing interactive healing, compare the modified areas.

7. Select [Geometry Verification] > [Geometry Verification Mode] ( ) from the menu.

Switch to Geometry Verification Mode. The model after interactive healing is displayed (on
left), and the unmodified model that was saved internally beforehand is displayed (on right).

Next, specify the face modified by interactive healing as the part to be compared.

8. Select [Geometry Verification] > [Partial Geometry Verification] from the menu.

9. Pick the face for comparison from the left model and press [Done] ( ).
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10. Next, pick the face for comparison from the right model and press [Done] ( ).

Comparison of the two selected faces is executed.

11. In [Main (Work)] panel, select "Face Distance" and press [Zoom current target] ( ).

When checking the differences, it can be confirmed that a maximum of about 0.05 mm of
geometry deformation has occurred.
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
By default setting, the minimum value is 0.005 mm and the maximum
value is 0.5 mm for the difference distance shown by the color bar.
Minimum and maximum values of the color scheme can be changed
according to the range of difference in distance in the displayed area.

The displayed color difference is not set properly, so change the setting.

12. Select [Geometry Verification] > [Settings] from the menu or press [Settings] ( ) located at
top right of [Main (Work)] panel. "Geometry Verification Setting" dialog will appear.
In [Viewing Setting (1)] tab, enable both "Use Custom Color Range" and "Auto Scale Color"
options, and then click [OK].

Color scheme of the color bar changes depending on the range of the difference distance.

13. After confirming the comparison result, once again select [Geometry Verification] >
[Geometry Verification Mode] ( ) from the menu.
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Geometry Verification Mode ends, and you will return to the state after interactive healing.


Please note that when exiting Geometry Verification Mode, the model to be
compared displayed on the right screen is deleted, and at the same time,
the model stored internally is also deleted.



In case you want to keep the internally stored model after exiting
Geometry Verification Mode, select [Geometry Verification Mode] > [Target
Model] > [Store Previous Target Model] ( ).
When exiting Geometry Verification Mode with [Store Previous Target
Model] ( ) enabled, the internally stored model will not be deleted.
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2.4.5. Quick Comparison of Whole Model

By using the function "Quick Comparison" in Geometry Verification, you can quickly see the
differences in the characteristics between models.


Please note that the function "Quick Comparison" compares fewer check items
than "Detailed Comparison".

1. Select [Geometry Verification] > [Open Comparison Result] ( ) from the menu.

2. "Open" dialog will appear. Specify SampleM4.gvfx from the <tutorial> folder, and click [Open].

3. Select [Geometry Verification] > [Settings] from the menu or press [Settings] ( ) located at
top right of [Main (Work)] panel.

4. "Geometry Verification Setting" dialog will appear.
In [Verification Setting] tab, select "Quick Comparison" in Comparison Mode, then click
[Details] located on the right.
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5. [Quick Comparison Setting] tab will appear in "Geometry Verification Setting" dialog. Make
sure that "Begin Feature Recognition" is enabled and click [OK].

6. Select [Geometry Verification] > [Begin Verification] from the menu or select [Begin
Verification] ( ) in [Main (Work)] panel.

7. In [Main (Work)] panel, select "Unique Faces" from the category list. The differences
between the two models are highlighted in red.


Geometry differences can be confirmed using the icon such as [Zoom
current target] ( ) located at the bottom of [Main (Work)] panel as in the
case of the normal comparison function.

Because "Begin Feature Recognition" was enabled in "Quick Comparison Setting" dialog
when running Geometry Verification, "Difference List" was added to [Main] panel.
In Difference List, you can confirm the difference for each recognized feature.
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Furthermore, models that have multiple parts can have their comparison results displayed
according to each part.

8. In [Main (Work)] panel, double-click the part named "block" from the Difference List. The
display switches from the whole model to an individual part. Confirm the difference in each
part.

9. In [Main (Work)] panel, double-click the part named "sheet" from the Difference List. Just
like with the "block", you can quickly see the difference between the parts.
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When confirming [Structure comparison] panel, the background color of the parts with
differences in the assembly tree changes in the list.
Also, when selecting a part in [Structure comparison] panel, the corresponding part is
highlighted in blue on "3D View" window.

By using the function "Quick Comparison", you can easily detect geometric differences in
assembly models.
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3. Intermediate
This chapter will explain in detail how to modify errors using Interactive Healing functions.
With the knowledge you have gained up to this point, Editor will let you translate most of the
data adequately.

3.1. Interactive Healing
This section will explain how to modify the error, "Gap: Edge and base surface", which tends to
occur quite often.

Which Category to Modify From

When errors "Loop with self-intersection" and "Surface with self-intersection" are
detected, these two errors must be modified first before any other error items. If you
modify other error items while these two types of errors exist, the modification function
may not work properly.

When "Loop with self-intersection" and "Surface with self-intersection" are not detected,
you can start modifying from any error items.

"Gap: Edge and base surface" is an error that often occurs during data translation, and there are
many modification functions to use from to modify the error. The characteristics of each
function will be explained so that you can select the most appropriate one for you.



• Please refer to "Check for Errors" in [Beginner] for more details about how
to check detected errors.

• Also, refer to "Interactive Healing" in [Beginner] for more details about the
general operation of interactive healing.

3.1.1. Extend Surface

1. Refer to 2.2.1, “Open Files” and open ExtendSurface.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.
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Confirm the face (red) protruding from the surface (white). In this case, use the function
[Extend Surface].

3. Select [Modify] > [Divide/Extend] > [Extend Surface] from the menu or click [Extend
Surface] ( ) from Repair Tool on Navigation panel. In this case, press [Extend Surface]
( ) on Navigation panel.

4. A new surface is calculated and its boundary is highlighted in light blue on "3D View"
window.

In addition, a "Confirmation" dialog will appear. The maximum value of "Gap: Edge and
base surface" on the new surface will be displayed. Make sure you have made the
appropriate modification, and click [OK].

The error is modified and the category list is updated.
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
Please note that [Extend Surface] ( ) can be used to extend cylindrical
and other analytical surfaces appropriately. Refer to A.2, “Analytic
Surfaces” in the Appendix for more details.

3.1.2. Fit Face to Loops

1. Refer to 2.2.1, “Open Files” and open FitFaceToLoops.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

In this case, use [Fit Face to Loops] to modify the error.


The function [Fit Face to Loops] finely adjusts the position of control points
on the surface or increases the number of control points. This function is
versatile, and it can modify almost all "Gap: Edge and base surface".

3. Select [Modify] > [Gap between Edge and Surface] > [Fit Face to Loops] or click [Fit Face to
Loops] ( ) from Repair Tool on Navigation panel. In this case, press [Fit Face to Loops]
( ) on Navigation panel.

A new surface is calculated and its boundary is highlighted in light blue on "3D View"
window.

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 53 | 152



4. A "Confirmation" dialog will appear. The maximum gap of the new surface will be
displayed. Click [OK].

The error is modified and the category list is updated.


Most of the errors in "Gap: Edge and base surface" can be modified with
[Fit Face to Loops]. However, if you want to keep the shape of design
intentional surface or a cylindrical / spherical surface, use the functions
[Extend Surface] or [Project Edge on Surface] to modify.
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Fit Face to Loops and Control Points

To better understand the function [Fit Face to Loops], compare the control points before
and after modification.
To undo the modification after executing [Fit Face to Loops], select [Edit] > [Undo] ( ).

In this case, select [Analysis] > [Control Points] > [Surface] ( ) and pick the surface with
an error. The control points before modification will appear.
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Next, select [Edit] > [Redo] ( ) to go to the modified state.

Likewise, select [Analysis] > [Control Points] > [Surface] ( ). Pick a modified surface to
show its control points.

When comparing the surfaces before and after modification, you can see that the number
of control points has increased to modify "Gap: Edge and base surface".

Since [Fit Face to Loops] is performed by moving or increasing the number of control
points, it is not suitable for surfaces with poor quality control points.

(Reference) Surface with poor quality control points (Left: Control points + Semi
Transparent, right: Shading)
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3.1.3. Boundaries, Surface → Surface

The function [Boundaries, Surface → Surface] ( ) is used to create a new surface based on the
boundary edges and original surface.
This function is recommended when [Fit Face to Loops] ( ) does not work. Here is just a brief
explanation about the function because it is not used very often.

Below is a comparison result between [Fit Face to Loops] (lower left) and [Boundary, Surface →
Surface] (lower right). The modified surface is shown in light blue and can be previewed.

Since [Fit Face to Loops] manipulates and modifies the control points, the geometry of the
surface hardly changes. On the other hand, [Boundary, Surface → Surface] recalculates to
define a new surface. If the quality of the control points is poor, it may be more appropriate to
use [Boundaries, Surface → Surface].

Furthermore, the function [Boundaries, Surface → Surface] cannot be used for faces with
complex boundary edges.

3.1.4. Boundaries → Surface

The function [Boundaries → Surface] ( ) is used to recreate the surface based on the
geometry of the boundary edges. 
Therefore, unlike [Boundaries, Surface → Surface] ( ), the geometry of the original surface is
not referenced at all.

Following figures show the result of modifying the surface with [Boundaries, Surface→Surface]
(upper right) and [Boundaries →Surface] (lower right) for the surface with bulged center (left).

This function is recommended for modifying the surface with invalid geometry such as
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undulation and self-intersection.

Furthermore, like in the case with [Boundaries, Surface→Surface], the function cannot be used
for faces with complex boundary edges.

3.1.5. Recalculate Surface

The function [Recalculate Surface] ( ) is used to recreate a surface based on a plane or a
cylindrical surface. Therefore, a surface which is closer to a plane or cylinder is better suited for
modification.
This function is mainly used to modify the errors "Surface with self-intersection" and "Surface
with singular point". It is recommended to use on the error "Gap: Edge and base surface" when
other functions cannot modify it.

1. Refer to 2.2.1, “Open Files” and open RecalculateSurface.drfx in the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

The surface (in white) is oscillating greatly. In such a case, use [Recalculate Surface].

3. Press [Recalculate Surface] ( ) on Navigation panel.

4. "Surface Recalculation" dialog will appear. To avoid reflecting the original abnormal
surface, move the slider toward "Less" for "Original Geometry Similarity", and click [OK].
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

The higher the dependency, the more the geometry of the original surface
is reflected, but the time required for calculation increases as well.
Normally, use the default settings, and if you want to reflect the geometry
of the original surface more accurately, increase the dependency.

On the other hand, if you don’t want to reflect the geometry because the
original surface is an invalid geometry, set the dependency toward "Less".

Also, if the quality of the generated surface is poor, adjusting the
dependency may improve the quality.

5. A confirmation dialog will appear. Click [OK].

Faces with "Surface with self-intersection" are replaced and all errors have been modified.
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3.1.6. Project Edge on Surface

While other modifying functions for "Gap: Edge and base surface" modifies "Surfaces", the
function [Project Edge on Surface] ( ) only modifies "Edges". Therefore, please note that this
may cause errors in the related elements.

Mainly used for surface such as design intentional surface, cylindrical surface, and spherical
surface where you want to strictly maintain the geometry.

In the following, the characteristics and notes on [Project Edge on Surface] will be explained
along with examples of usage.

■ Example of "Project Edge on Surface" being used (1)

1. Refer to 2.2.1, “Open Files” and open Projection.drfx in the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

It is possible to confirm that the surface (white) and the curve (red) are apart. In such a case,
use [Project Edge on Surface] to project the curve onto the surface.

3. Press [Project Edge on Surface) ( ) on Navigation panel.

4. Result of the projection can be previewed in white on "3D View" window, and a dialog will
appear to confirm the update of the relevant edges. Click [Yes].
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

Please note that when you click [No] in the confirmation dialog, only the
curves to be modified among the boundaries will be moved. This causes a
separation in the boundary and detected as "Gap: In loop". When the
relevant edges are not updated, the error "Gap: In loop" may occur.

The curve to be modified and its relevant edges are moved.

Because the surface moved upward, there is a new gap between the adjacent edge and the
surface, increasing the number of errors in "Gap: Edge and base surface".
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5. In [Main (Work)] panel, use [Next] ( ) and [Previous] ( ) to switch the following errors.

6. Press [Extend Surface] ( ) on Navigation panel.

7. A new surface is calculated and its geometry is highlighted in light blue on "3D View"
window.

Also, a confirmation dialog will appear. Maximum value of "Gap: Edge and base surface" on
the new surface is displayed. Make sure you have made the appropriate modification and
click [OK].
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The error is modified and the category list is updated.

To modify the remaining errors in "Gap: Edge and base surface", use [Fit Face to Loops] (
) on Navigation panel.
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■ Example of "Project Edge on Surface" being used (2)

1. Refer to 2.2.1, “Open Files” and open Projection2.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

3. Press [Project Edge on Surface] ( ) on Navigation panel.

4. The projection result is previewed in white on "3D View" window, and a dialog confirming
the update of relevant edges will appear. Click [No] in this case.
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

Please note that when an adjacent edge is close, as in the sample model,
and updated together, there is a possibility that the modification is not
adequate.

5. Similarly, modify one more "Gap: Edge and base surface" with [Project Edge on Surface] (
) without updating the relevant edges.

All "Gap: Edge and base surface" will be modified; however, because the relevant edges
have not been updated, a new error "Gap: In loop" is detected.

6. In [Main (Work)] panel, select "Gap: In loop" from the category list. Target position is
highlighted in red on "3D View" window.

7. Press [Merge Edge Terminals] ( ) on Navigation panel. A curve is inserted into the long
and narrow face to modify the error "Gap: In loop".
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Now all the errors have been modified.



The error "Gap: Edge and base surface" can be modified by the function [Fit
Face to Loops] ( ) as well. However, when you modify with [Fit Face to
Loops], the surface may deform slightly and may not be a cylindrical surface.

To keep the cylindrical surface as in the sample model, use [Project edge on
Surface] ( ) to modify the geometry of the surface.

When confirming from [Analysis] > [Info] ( ), you can see that the surface
modified with [Project Edge on Surface] (lower left) has not changed from the
"Cylindrical Surface", while the surface modified with [Fit Face to Loops]
(lower right) has changed to "NURBS".
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3.2. Suitable Method
The following three ways allow you to check whether the appropriate modification method had
been applied to an error.

• Error message during modification

• Surface geometry after modification

• Increase or decrease of detected errors

■ Error message during modification

For example, when using [Boundaries, Surface → Surface] ( ) to modify a face with complex
boundaries, the following error message will appear. You will notice that the method is
inappropriate.

■ Surface geometry after modification

For example, as a result of executing [Fit Face to Loops] ( ) , a large oscillated surface may be
calculated, as shown in the figure below. In such a case, cancel the modification and execute
other modification functions.

■ Increase or decrease of detected errors

Since the error caused by modification is automatically detected, confirm whether the
modification was appropriate by looking at the increase or decrease in the number of errors in
the category list on [Main (Work)] panel.


Please note that just because the number of errors increased does not
necessarily mean that the function is inappropriate. For example, as seen in
[Project Edge on Surface] ( ), an error "Gap: In loop" may be detected after
execution due to the nature of modification.
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When the repair icon does not appear

Although an error item is selected from the category list, the repair icon may not appear
on Navigation panel for the following reasons:

• Before performing Auto Healing

With the exception of some functions, you cannot perform interactive healing before
auto healing.

• Severity is "Minor"

For some minor error items, there aren’t any dedicated modification functions
because the data can be successfully passed to the output system without modifying
the error.
However, try to design the product in such a way as to prevent errors from occurring
because they may cause problems in the post processes such as analyzing,
manufacturing, etc.


Please refer to A.1, “Error Items” in the Appendix for details about
the severity level of error items.

• Errors that can be modified by modifying other error items.

Repair icon may not appear because it is possible to modify an error by modifying
another error. An example would be "Gap: Edge and base surface" which can be
modified by modifying "Gap: Vertex and surface".

• Items that cannot be modified

If there are no appropriate modification function, the repair icon will not appear.
Check the errors and modify them with the source CAD system if necessary. For
example, Editor cannot modify the error where the inner loop protrudes over the
outer boundary. (Below left figure)

Such an error is detected as "Intersecting loops", so make modification such as
changing the size and position of the inner loop in the source CAD system.
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3.3. Useful Tools
This section will show you some useful tools available for Interactive Healing with Editor.

3.3.1. Pick Filter

Pick Filter will allow you to filter the target elements to be selected on "3D View" window. To
multiselect the target elements, it will be easier to select by limiting the target elements in Pick
Filter.

(Example) When deleting unnecessary single points

1. Select [Edit] > [Delete] from the menu or select [Delete] ( ) on the toolbar.

2. In [Option] panel, select "Specify target elements".

3. Switch the Pick Filter to "Vertex".

4. At the upper right of "3D View" window, press [Area Selection Mode] ( ). Left-click and
drag to enclose the points you want to delete.
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
Also, select elements by left-clicking while holding down [Ctrl] key and
dragging to enclose with a rectangle.

5. Press [Done] ( ). Only points within the selected area will be deleted.

3.3.2. Clipping Box

Editor Clipping Box will allow you to display only those elements that are contained in a
rectangle (clipping box) centered at a specified position.

When working with only the elements inside an intricate model, you can easily do so by hiding
the elements outside the target position. The position, shape and angle of Clipping Box can be
adjusted freely.

■ How to Use Clipping Box

1. Select [View] > [Edit Clipping Box] from the menu or select [Edit Clipping Box] ( ) on the
toolbar.

The Clipping Box and "Edit Clipping Box" dialog will appear on "3D View" window.

2. In "Edit Clipping Box" dialog, click [Move Clipping Box] and pick any element on the model.
The element you have picked becomes the center of Clipping Box.
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
Please note that the size of Clipping Box is automatically determined by the
size of "3D View" window.

3. Move the handles inside Clipping Box to adjust the size and orientation of the box.

◦ Yellow handle: Handle for changing the size

◦ Gray handle: Handle for adjusting the angle

After editing, click [Close] in the "Edit Clipping Box" dialog to finish the positioning.

4. Select [View] > [Clipping Box (On/Off] from the menu or enable [Clipping Box (On/Off)] ( )
on the toolbar. Only the elements inside Clipping Box are displayed.

While the displayed area is limited, perform such actions as deleting elements inside the
model.
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4. Advanced
Most CAD data can be properly translated using the modification methods you have learned up
to the "3, Intermediate" level. However, more sophisticated operations may be required
depending on the state of the source data.

This chapter will explain how to modify errors that require technical operations in the form of
case studies.

4.1. Modifying Free Edge
When importing data that do not have connection information between faces, it is possible to
combine free edges by [Auto Stitch] ( ). However, it may not be possible to combine all free
edges.


In each case, [Auto Stitch] ( ) and [Auto Heal] ( ) have already been
performed beforehand.

4.1.1. Case: Missing Face

When importing a file such as IGES, the face may be missing at the fillet position, etc. If the face
is missing, the boundary is recognized as "Free edge".

1. Refer to 2.2.1, “Open Files” and open FillHole.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.


In this sample model, the face is missing in the fillet position. Fill in the face
to modify the error.

3. Press [Fill Hole (Create New Face)] ( ) on Navigation panel.

4. A confirmation dialog will appear. Confirm that the edges you want to fill are highlighted
correctly on "3D View" window, and click [OK].
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A new face is created in the target position, and the category list is updated.

4.1.2. Case: Duplicate Faces

When importing such files as IGES file, the faces may be duplicated.
When the faces are duplicated in this way, the boundaries without adjacent faces are
recognized as free edges.

1. Refer to 2.2.1, “Open Files”, and open RemoveDuplicateFace.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.
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Faces are duplicated in this position. In this case, delete one of the duplicated faces, and
update the connection information between the faces with [Auto Stitch].


When finding the duplicated position is difficult, select [View] > [Regen]
( ) from the menu to update the "3D View" window.

3. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

4. In [Options] panel, select "Specify target elements".

Pick the duplicated face on "3D View" window, and press [Done] ( ).
* In this case, delete either of the face.
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

To specify a face to delete, right-click on the duplicated face and "Pick
Which?" dialog will appear. Specify the candidate in the dialog.

One face has been deleted. Press [Quit (Esc)] ( ) to exit the command.

5. In [Main (Work)] panel, press [Auto Stitch] ( ).

6. "Auto Stitch" dialog will appear. Specify "Tolerance" to 0.01mm and click [Try].

7. Make sure that "After auto-stitch: Free edges" is "0", and click [Fix].
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Auto stitching is executed, and the category list is updated.


After stitching, if the face direction needs to be modified, select [Modify] >
[Repair Solid] > [Flip Face] ( ) to reverse the face. Please refer to "Flip
Face" for more details.

4.1.3. Case: Fail to Trim

When importing files such as IGES, faces which fail to be trimmed may exist. In this case, the
boundary of the face that failed to be trimmed is recognized as a free edge.

1. Refer to 2.2.1, “Open Files” and open FailToTrimSurface.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.

3. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

4. Pick the face that has failed trimming on "3D View" window.
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5. Pick the edges to use as the new boundary, and press [Done] ( ).

6. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].

7. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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The boundary has been modified. Press [Quit (Esc)] ( ) to exit the command.

Finally, update the new boundary’s connection information.

8. In [Main (Work)] panel, press [Auto Stitch] ( ).

9. "Auto Stitch" dialog will appear. Specify "Tolerance" to 0.01mm and click [Try].

10. Confirm that "After auto-stitch: Free edges" is "0", and click [Fix].
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Auto stitching is executed and the free edges are modified.

4.1.4. Case: Huge Gap between Edges

When faces cannot be stitched by auto stitching due to the large gap between the edges, the
position is recognized as a free edge.

1. Refer to 2.2.1, “Open Files” and open EdgeStitch.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.

Auto stitching cannot be used because the gap is too far apart between the edges of two
faces.
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

Shortest distance between the edges is approximately 0.3mm. Select
[Analysis] > [Distance] ( ) to measure the distance between the two
edges.

3. Select [Modify] > [Repair Solid] > [Stitch (pick)] from the menu or click [Stitch (pick)] ( )
on the toolbar.

4. For the first edge, pick both [1] and [2] on "3D View" window.

Next, for the second edge, pick [3] on "3D View" window. Press [Done] ( ).
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

It is also possible to stitch edges that are far apart by loosening the
tolerance and performing auto stitching; however, because auto stitching
covers all edges that have no connection, if the tolerance is too loose, the
edges may be stitched together with the wrong edges than what the
designer intended.

Edges [1]～[3] are stitched together, and the category list is updated.


Please note that for models that are not originally solids, such as an IGES
file output from a surface model, the outer free edges will remain after
auto stitching, but this is not an error and does not need to be modified.

4.1.5. Case: No Adjacent Faces

When a model is not originally a solid, such as an IGES file output from a surface model, the
outer free edges may remain because there are no adjacent faces.

1. Refer to 2.2.1, “Open Files” and open FaceTrim.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.

Because the flat face is not adjacent to the hemispherical protrusions, the position around
the two hemispherical protrusions are recognized as "Free edge". Errors can be modified by
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retrimming the faces so that they are adjacent to the hemispherical protrusions.



Select [Analysis] > [Related Element] from the menu or click [Related
Element] ( ) on the toolbar. Confirm the element related to the specified
element. After modification, you can confirm that both faces are adjacent
to the hemispherical protrusion.

Figure 1. Adjacent relation between face and hemispherical protrusions (Before
> After)

How to modify Face A and B.
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
When the free edge is highlighted on "3D View" window, it is difficult to see
the modification, so press [Zoom current target] (  ) on [Main (Work)]
panel. Detected errors are not selected and highlight will be canceled on
"3D View" window.

■ Change Boundary of Face A

Modify the boundary of Face A according to the geometry of hemispherical protrusion.

1. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

2. Select Face A on "3D View" window.

3. Pick a curve (light blue edge) that intersects the existing boundary, and press [Done] ( ).

4. A confirmation dialog will appear. Confirm that the trimming position is the same as the
image below, and click [Yes].
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5. Select the edge that will be the boundary of the new face (pink edge).

6. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].

7. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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Face A boundary has been modified. Press [Quit (Esc)] ( ) to exit the command.

Figure 2. Adjacent relation of Face A (Before > After)

■ Change Boundary of Face B

As with Face A, modify the boundary of Face B to match the geometry of the hemispherical
protrusion.

1. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

2. Select Face B on "3D View" window.
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3. Pick a curve (light blue edge) which intersects with the existing boundary, and press [Done]
( ).

4. A confirmation dialog will appear. Confirm that the edge highlighted on "3D View" window
is correct, and click [OK].

5. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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Boundary of Face B has been modified.

Figure 3. Adjacent relation of Face B (Before > After)

Finally, use the same procedure to modify Face B so that the hemispherical protrusion at the
bottom right connects with the face.

6. Again, select Face B on "3D View" window.
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7. Pick an edge from the outer boundary of the hemispherical protrusion at the bottom right of
the model, and press [Done] ( ).

8. A confirmation dialog will appear. Confirm that the edge highlighted on "3D View" window
is correct, and click [OK].

9. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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Boundary of Face B has been modified.

Figure 4. Adjacent relation of Face B (Before > After)
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4.2. Modifying Invalid Geometry
In some cases, the imported CAD model may have unpreferable geometry such as wavy curves.
This section will explain how to modify them.

4.2.1. Modify Curve with Oscillation (1)

1. Refer to 2.2.1, “Open Files” and open InvalidGeometry1.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Surface with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

The face in the center of "3D View" window intersects itself. Furthermore, when you zoom
up the tip of that face, you can see the curves oscillating. Such oscillations are undesirable
for data quality.

Create a curve which replaces the oscillating curve on both sides of the surface.

3. Select [Create] > [Curve] > [On Surface] from the menu or click [On Surface] ( ) on the
toolbar.

4. Select the face on the left.
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5. Pick two places on the curve as shown below, and press [Done] ( ).

6. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].

A new curve is created. (The side highlighted in light blue)

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 91 | 152



Next, create a new curve on the right side of the face as well.

7. Select the face on the right.

8. Pick two places on the curve as shown below, and press [Done] ( ).

9. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 92 | 152



A new curve is created. (The side highlighted in light blue)

Next, the two newly created curves will be used to replace the boundaries of adjacent faces.

10. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

11. Select the center face on "3D View" window.
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12. Pick the two newly created curves, and press [Done] ( ).

13. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].

14. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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15. "How to treat detected gap" dialog will appear. Here, select "Ignore gap" and click [OK].

Boundary of the center face has been replaced by the two curves you created.
With the same procedure, replace the two newly created curves as the boundaries of the
adjacent left and right faces.

16. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.
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17. Select the left face on "3D View" window.

18. Pick the edge which will be the boundary of the new face, and press [Done] ( ).

19. A confirmation dialog will appear. Confirm the edges highlighted on "3D View" window are
correct, and click [OK].

20. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].

Boundary of the face will be changed. With the same procedure, replace the boundary of the
right face.
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Two newly created curves have replaced the boundaries of the adjacent faces.

21. In [Main (Work)] panel, select "Surface with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

22. Press [Recalculate Surface] ( ) on Navigation panel.

23. "Surface Recalculation" dialog will appear. Without changing "Original Surface Similarity",
click [OK].
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24. A confirmation dialog will appear. Click [OK] as is.

The face with "Surface with self-intersection" is replaced, and all errors have been modified.

4.2.2. Modify Curve with Oscillation (2)

1. Refer to 2.2.1, “Open Files” and open InvalidGeometry2.drfx from the <tutorial> folder.

Although this model does not have any detected errors in the category list, when visually
observing the geometry on "3D View" window, you can see that some of the edges shared by
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the left and center faces are oscillating. Also, the adjacent faces are oscillating so even if you
create new curves with the function [On Surface] ( ), distorted curves will be created.

In such a case, create curves that replace the oscillating curves on both sides of the surface.

Figure 5. Curve oscillation (Shading and Control Points)

2. Select [Create] > [Point] > [Division] from the menu or click [Division] ( ) on the toolbar.

3. Pick a curve (cyan color) with oscillation on "3D View" window.

4. "Enter Number of Segments" dialog will appear. Enter "10" and click [OK].

Division points are created on the specified curve.
In this case, there are nine points created because "10" was specified as the number of
segments.
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5. Select [Create] > [Curve] > [Interpolation] from the menu or click [Interpolation] ( ) on the
toolbar.

6. On "3D View" window, pick in the order of "Start" point > created points > "End direction"
point, then press [Done] ( ).



Please ensure to exclude the point where the curve is oscillating.

7. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].
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An interpolation curve is created. (Curve on the side highlighted in light blue)

Next, replace the edge shared by the left and center faces with the created interpolation
curve.

8. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

9. On "3D View" window, pick the left face.

10. Pick the edge to use for new boundary, and press [Done] ( ).
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11. A confirmation dialog will appear. Confirm the curve highlighted on "3D View" window is
correct, and click [OK].

12. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].

13. "How to treat detected gap" dialog will appear. Here, select "Ignore gap" and click [OK].

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 102 | 152



Boundary of the left face has been replaced by the interpolation curve you have created.
With the same procedure, replace the created interpolation curve as the boundary of the
center face.

Next, modify the error "Gap: Edge and base surface" which appeared when the face
boundary was replaced.

14. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

15. Press [Boundaries, Surface → Surface] ( ) on Navigation panel.


Please note that due to the poor quality of the original control points, the
function [Boundaries, Surface → Surface] is more suitable than [Fit Face to
Loops].
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16. A confirmation dialog will appear. Click [OK].

Surface is replaced, and the category list is updated.

Finally, delete the unnecessary division points.

17. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

18. In [Options] panel, select "Specify target elements".
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Switch the Pick Filter to "Vertex".

On "3D View" window, press down [Ctrl] key while left-clicking the mouse and drag around
the points to be deleted. Press [Done] ( ).

Points within the selected range have been deleted.
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

Please note that only single elements can be deleted. Following dialog will
appear if the element includes non-single elements.



Elements other than solids can be deleted from the structure tree on [Main
(Structure)] panel. For example, right-click on the single element ( ) you
wish to delete on [Main (Structure)] panel, and click [Remove] from the
context menu.

This is the end of modifying curves with oscillation.
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4.3. Modifying Invalid Topological Structure
Unintended topological structure model may be generated as a result when inappropriate
Boolean operation is executed in the source CAD system. This section will explain how to
modify the errors.

Example of Boolean Operation Generating Unintended Data

■ Logical Negation(NOT)

If there is an area where Solid A (blue) and Solid B (gray) overlap, a Boolean operation
"logical negation (NOT)" produces the result as shown below.

However, if Solid A (blue) and Solid B (gray) do not completely overlap, such as when they
touch each other at the top, tiny areas like the one shown below may remain due to
calculation errors.

■ Logical Disjunction (OR)

If there is an area where Solid A (blue) and Solid B (gray) overlap, a Boolean operation
"logical disjunction (OR)" produces the result as shown below.

However, if the size and position of Solid B (gray) are improper, Solid B may merge
incompletely, resulting in a tiny gap as shown in the figure below.
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To avoid such a result, when using Boolean operation, the solids should have an overlapping
area. Afterward, it is recommended that you visually observe the result.

The following explains how to modify the geometry caused by the Boolean operation.

4.3.1. Modifying Invalid Geometry Caused by Negation

1. Refer to 2.2.1, “Open Files” and open boolean1.drfx from the <tutorial> folder.

Zoom in to the area surrounded by the yellow circles to see where the Boolean operation
was intended and where it failed. In the area surrounded by the yellow circle in the figure
below, the result of the Boolean operation is not as intended and the unnecessary faces
remain.

Remove the remaining faces at the point of failure.

2. Select [Modify] > [Divide / Extend] > [Divide Face] from the menu or click [Divide Face] ( )
on the toolbar.

3. Pick the target face on "3D View" window.
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Left-click the position where you wish to divide on the face.

4. A guide to divide direction will appear. Click the guide at the position where you want to
divide the face, and press [Done] ( ).

5. A confirmation dialog will appear. Enable "Apply to all" and click [Yes].
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6. Repeat the same procedure to divide the other side of the face.

Next, delete the unnecessary face from the divided faces.

7. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

8. In [Options] panel, select "Specify target elements".

Switch the Pick Filter to "Face".

Pick the face to delete on "3D View" window, and press [Done] ( ).
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

Please note that you need to delete the tiny faces hidden under the big face.

Faces are deleted. Press [Quit (Esc)] ( ) to exit the command.

9. In [Main (Work)] panel, select "Short curve" from the category list. Target position is
highlighted in red on "3D View" window.
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10. Press [Remove Short Edge] ( ) on Navigation panel. All errors have been modified.

4.3.2. Modifying Invalid Geometry Caused by Logical Disjunction

Refer to 2.2.1, “Open Files” and open boolean2.drfx from the <tutorial> folder.

When zooming into the yellow circle, the result of the Boolean operation (logical disjunction) is
not as intended and a tiny gap is created, so the face is extended into the gap.

Modify the position where the tiny gap was generated.
Detected error in this sample model can be modified by either [Remove Faces With Fix] ( ) or
[Change Face Boundary] ( ).

■ When modifying with [Remove Faces With Fix] ( )

1. In [Main (Work)] panel, select "Acute face connection" from the category list.
Press [Zoom current target] ( ) to highlight the target position (below figure) on "3D View"
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window.

2. Press [Remove Faces with Fix] ( ) on Navigation panel.
Tiny gaps have been filled in and unnecessary parts of extended faces have been removed.


Please note that items marked as "Minor" in the category list are not errors
and do not need to be modified.

■ When modifying with [Change Face Boundary] ( )

1. In [Main (Work)] panel, select "Acute face connection" from the category list.
Press [Zoom current target] ( ) to highlight the target position on "3D View" window.

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 113 | 152



2. Press [Change Face Boundary] ( ) on Navigation panel.
Pick the face you wish to divide on "3D View" window.

3. On "3D View" window, pick the edge to use for the new boundary, and press [Done] ( ).

4. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].

5. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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The boundary has been modified. Press [Quit (Esc)] ( ) to exit the command.

6. In [Main (Work)] panel, select "Edge used more than twice" from the category list. Target
position is highlighted in red on "3D View" window.

7. Press [Unstitch] ( ). Edges highlighted in red will be unstitched.
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8. In [Main (Work)] panel, select "Free edge" from the category list.

In [Main (Work)] panel, enable [Display Surroundings Only] ( ). To display the position of
errors, use [Next] ( ) and [Previous] ( ) to switch the currently displayed error position.

9. Press [Delete Elements] ( ). On "3D View" window, pick the unnecessary part of the face
you just trimmed, and press [Done] ( ).

The face is deleted. In [Main (Work)] panel, disable [Display Surroundings Only] ( ).
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10. In [Main (Work)] panel, select "Free edge" from the category list.

11. In [Main] panel, press [Auto Stitch] ( ).
"Auto Stitch" dialog will appear. Specify the tolerance to "0.01mm" and click [Try].

Confirm that the number of free edges is "0" and click [Fix].

Connection information between faces has been modified, and all errors have been
modified.
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5. More Advanced
Most CAD data can be translated properly with the modification methods used up to the "3,
Intermediate" level. In addition, even in cases where an element is missing and cannot be easily
modified, you can modify it by combining several functions.

This chapter will explain how to modify errors that require higher technical operations than "4,
Advanced" in the form of case studies.

5.1. Modifying Complex Errors

5.1.1. Case: Complex Face Missing

When importing a file such as IGES, there may be a face missing, and at the same time, there
may be a trimming failure. This section will explain how to modify these errors to make them
into solids.

1. Refer to 2.2.1, “Open Files” and open FillHole2.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.

In this sample model, there is a missing face and an incorrect trimming in the step area.
First of all, modify the area missing a face.
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Begin by creating a curve (auxiliary line) necessary to create the face.

3. Select [Create] > [Curve] > [Perpendicular Line] from the menu or click [Perpendicular Line]
( ) on the toolbar.

4. On "3D View" window, pick a point which will be the tip of the vertical line.

Pick the edge to where you want to extend down the vertical line.

A vertical line is created and the edge to which the line is extended down is divided.

Next, create a curve to divide the face.

5. Select [Create] > [Curve] > [On Surface] from the menu or click [On Surface] ( ) on the
toolbar.

6. On "3D View" window, pick the face you want to divide. (*From here, some faces are hidden.
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Pick two points that will be the end points of the line on surface, and press [Done] ( ).

7. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].
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A new curve is created. Press [Quit (Esc)] ( ) to quit the command.

Next, divide the face with the new created curve.

8. Select [Modify] > [Divide / Extend] > [Divide Face] from the menu or click [Divide Face] ( )
on the toolbar.

9. On "3D View" window, pick the face you wish to divide.

Next, pick the created line on surface, and press [Done] ( ).
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The face has been divided. Press [Quit (Esc)] ( ) to quit the command.

Next, delete the unnecessary face.

10. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

11. On "3D View" window, pick the face to delete, and press [Done] ( ).

The face has been deleted. Press [Quit (Esc)] ( ) to quit the command.
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Finally, create a face where the face is missing.

12. Select [Create] > [Face / Surface] > [Fill Hole (Create New Face)] from the menu or click [Fill
Hole (Create New Face)] ( ) on the toolbar.

13. "Option" dialog will appear. Select "Auto detect".

14. On "3D View" window, pick an edge where the face is missing, and press [Done] ( ).

15. A confirmation dialog will appear. On "3D View" window, confirm that the edges you want
to fill in are highlighted correctly, and click [OK].

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 123 | 152



A new face is created in the target position.
Follow the same procedure to create a face for the other opening.

A new face is created in the target position, and the category list is updated.

This concludes the modification of missing faces.

5.1.2. Case: Overly Shared Edges

*Continue using the sample model FillHole2.drfx which you have just modified the missing
face.

1. In [Main (Work)] panel, select "Edge used more than twice" from the category list. Target
position will be highlighted in red on "3D View" window.
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This edge is shared by three faces. One of these faces is inside the CAD model; therefore, the
face inside the model is not needed.
In this case, delete the unnecessary face existing inside the CAD model for modification.

2. Press [Delete Elements] ( ) in Auxiliary Tool on Navigation panel.

3. If you move the mouse cursor over on the edge highlighted in red on "3D View" window,
"Multiple options" will appear.

Right-click the mouse in that state to display "Pick Which?" dialog.

3DxSUITE Editor Tutorial -Standard function-

 © 2022 Elysium Page 125 | 152



Specify the face existing inside the model in "Pick Which?" dialog, and press [Done] ( ).

Specified face is deleted, and the category list is updated. Press [Quit (Esc)] ( ) to quit the
command.

This concludes the modification of overly shared edges.
Finally, recreate the two divided faces into a single face.

4. Select [Modify] > [Replace Surface] > [Recalculate Surface] from the menu or click
[Recalculate Surface] ( ) on the toolbar.

5. On "3D View" window, pick the two divided faces, and press [Done] ( ).
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6. "Surface Recalculation" dialog will appear. Click [OK] without changing "Original Surface
Similarity".

A confirmation dialog will appear. Click [OK].

Surfaces are swapped, and two faces are replaced with one.
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5.1.3. Case: Loop with Self-intersection

■ Modify with "Clean Self-intersection"

1. Refer to 2.2.1, “Open Files” and open LoopIS.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Loop with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

This model has an elongated face with an edge intersecting in the center, which has been
detected as an error.

3. Press [Clean Self-intersection] ( ) on Navigation panel.
In the position where the edges intersect, the face is divided into two faces, Face [1] and Face
[2].
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Detected error "Loop with self-intersection" has been modified, but another error "Acute
Face Connection" has been detected.

On "3D View" window, the corresponding position is highlighted in red. Confirm that the
elongated face (Face [1]) and the large face on the left are connected at an acute angle.

Delete the elongated face (Face [1]), and connect the large faces on both sides.
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Confirm the positional relation of surrounding elements

a. Select [Analysis] > [Related Element] from the menu or click [Related Element]
( ) on the toolbar.

b. By picking a face, the edges and vertices related to the picked face will be
highlighted.

In the edge (C1) near the center of the figure below, you can see a large face each
on the left and right which are trimmed so that they overlap each other.

When adding "Duplicate Faces" to Check items, you can detect where the faces
overlap.


To add or delete an error in the category list, select [Check] >
[Options] (in Data Translation Mode). In [Check items] tab, set the
preferred setting.

4. Press [Delete Elements] ( ) in Auxiliary Tool on Navigation panel.

5. If you move the mouse cursor over on the edge highlighted in red on "3D View" window,
"Multiple options" will appear.
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Right-click the mouse in that state to display "Pick Which?" dialog.
Specify (Face [1]) in "Pick Which?" dialog, and press [Done] ( ).

6. Specified face is deleted and the category list is updated. Press [Quit (Esc)] ( ) to quit the
command.

7. Select [Modify] > [Repair Solid] > [Stitch (pick)] ( ) from the menu.

8. Pick one of the edges tangent to the deleted (Face [1]), and press [Done] ( ). Similarly, pick
the other edge, and press [Done] ( ).

The edges are connected, and the category list is updated.
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

Please note that although several "Free edge" errors still remain, since they
are the boundaries of the sample model (sheet), these errors do not need to
be modified.

■ Modify with "Divide Face"

1. Refer to 2.2.1, “Open Files” and open LoopIS2.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Loop with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

Confirm the positional relation of surrounding elements around this error.

3. Select [Analysis] > [Related Element] from the menu or click [Related Element] ( ) on the
toolbar.
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4. PIck the vertex that is highlighted in red. Five edges (C0-C4) related with that vertex are
highlighted. Since this point shares the vertex of the edges that make up the loop, it is
detected as "Loop with Self-intersection".

[Clean Self-intersection] ( ) can be used to modify, but in this case, use [Divide Face] ( ).

5. Press [Divide Face] ( ) on Navigation panel.

6. On "3D View" window, pick the vertex highlighted in red.

Two dotted lines are displayed around the picked vertex. Pick the dotted line in the direction
you want to divide the face, and press [Done] ( ).

7. The face is divided by the dotted line, and a confirmation dialog will appear. Enable "Apply
to all", then click [Yes].
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The base surface becomes smaller, and the category list is updated.



Please note that if the four edges that share a vertex result in having
different faces, it’s also possible to modify the position and direction of the
face division as shown below.
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■ Modify with "Recalculate Surface"

1. Refer to 2.2.1, “Open Files” and open LoopIS3.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Loop with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

When zooming into the target, you can see that Edge [1] and Edge [2] are intersecting.

Self-intersection at this position is caused by a distortion of Edge [1]. In this case, Edge [1]
will be modified by recalculation.

3. Press [Recalculate Surface] ( ) in Repair Tool on Navigation panel.

4. In [Option] panel, select "Interpolate".

Pick Edge [1] on "3D View" window.

5. "Input Number of Division" dialog will appear. Use the default value "10", and click [OK].
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6. Nine passing points are shown, dividing Edge [1] into ten segments.
Pick all nine passing points or enclose the area range, and press [Done] ( ).

7. Recalculated Edge [1] is displayed in light blue and can be previewed. A confirmation dialog
will appear. Click [OK].

Edge [1] is replaced, and [Loop with self-intersection] is modified.
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Next, modify the boundary of existing face and fill in the missing parts of the face.
First of all, create an edge that will be the new boundary of the face.

8. Select [Create] > [Curve] > [Interpolation] from the menu or click [Interpolation] ( ) on the
toolbar.

9. On "3D View" window, pick points (Start point / End point) at the position where you want to
create a curve, and press [Done] ( ).

10. "Decide Tangent Vector" dialog will appear. Click [Select edge] next to "Start".

Pick an existing edge that connects to the curve you just created.
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Tangent direction of the new curve is updated to connect smoothly with the existing edge.

Click [OK] in "Decide Tangent Vector" dialog.

11. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

12. On "3D View" window, pick the face whose boundary you wish to change.
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13. Pick the curve you just created and the edges that connect to it, and press [Done] ( ).

14. A confirmation dialog will appear. Confirm that the new boundary edges are highlighted on
"3D View" window, then click [OK].

15. "Change Face Boundary" dialog will appear. Confirm that the face you want to keep is
highlighted in blue on "3D View" window, and click [Keep selected face].
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Boundary of the face has been changed.

16. With the same procedure, use [Interpolation] ( ) and [Change Face Boundary] ( ) to fill
the holes.

When all holes are filled, the number of detected errors is "0" in the category list.
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5.1.4. Modifying Surface with Self-intersection

1. Refer to 2.2.1, “Open Files” and open SurfaceIS.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Surface with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

Zoom into the target position and confirm the face self-intersecting.
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

In the error "Surface with self-intersection", it might be easier to see where
they intersect by checking the control points of the surface. Surface control
points are displayed by selecting [Analysis] > [Control Points] > [Surface]
( ) and picking a face.

Main method to modify "Surface with self-intersection" is the function [Recalculate Surface]
( ); however, in this case, the error will be modified by [Make Base-Surface Smaller].

3. Press [Make Base-Surface Smaller] ( ) in Repair Tool on Navigation panel.

4. On "3D View" window, the reduced base surface is highlighted in light blue. A confirmation
dialog will appear.

Click [OK]. Self-intersection is modified and the category list is updated.
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By reducing the base surface in this way, you can modify self-intersection without changing
the geometry of face.

5.1.5. Modifying Acute Face Connection

1. Refer to 2.2.1, “Open Files” and open FaceCusp.drfx from the <tutorial> folder.

2. In [Main (Work)] panel, select "Acute Face Connection" from the category list. Target position
is highlighted in red on "3D View" window.

3. In [Main (Work)] panel, click [Zoom current target] ( ) to confirm the two faces (yellow
and magenta) that are connected at an acute angle.
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For this sample model, modify the error by deleting the invalid face (yellow) that exists
inside the solid.

The functions [Remove Faces With Fix] ( ) and [Change Face Boundary] ( ) can be used
to modify. Here, use [Change Face Boundary] ( ) to modify.


When using the function [Remove Faces With Fix] ( ), the yellow face is
deleted, and the magenta face boundary is automatically changed so that
there are no unused edges in the boundary with the deleted face.

4. Press [Change Face Boundary] ( ) in Repair Tool on Navigation panel.

5. Pick the magenta face on "3D View" window.

6. To change the boundary of the magenta face, pick the edge that will be the new boundary.
Press [Done] ( ).

A confirmation dialog will appear. Click [Yes}.
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7. A confirmation dialog will appear. Confirm that the new boundary edges are highlighted on
"3D View" window. Click [OK].

8. "Change Face Boundary" dialog will appear. Confirm that the face you wish to keep is
highlighted in blue on "3D View" window, then click [Keep selected face].

Face boundary is changed, and the category list is updated. Press [Quit (Esc)] ( ) to quit
the command.

9. In [Main (Work)] panel, select "Free edge" from the category list. The part where you
changed the boundary of the magenta face is highlighted in red.
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10. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

11. On "3D View" window, pick the face where the boundary of the face has been changed, and
press [Done] ( ).

The face is deleted. Press [Quit (Esc)] ( ) to quit the command.

12. Press [Stitch (pick)] ( ) in Repair Tool on Navigation panel.

13. Pick the edge highlighted in red on "3D View" window, and press [Done] ( ).
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The edge is stitched and the category list is updated.
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Appendix A: Appendix

A.1. Error Items

Category Error Item Description Severity
Tiny
Element

Short Curve Detect a curve that is shorter than the
tolerance in length.

Critical

Sliver Face Detect a face with maximum width less than
the tolerance.

Critical

Tiny Step Free Edge Detect a step-like geometry with a tiny edge
that has been used once on the face.

Minor

Topology Edge Direction Detect an edge whose direction does not
match the direction flag of the belonging
loop.

Critical

Free Edge Detect an edge which is used by a face only
once.

Serious

Missing face Detect an edge loop which contains an edge
used by a face once.

Serious

Edge used more than
twice

Detect an edge that is shared by faces more
than twice.

Serious

Isolated Curve Detect a curve that do not have topological
relation with any faces.

Minor

Gap
around
Vertex

Gap: Terminal Point of
Edges

Detect a gap between end points of edges
linked to the same vertex.

Serious

Gap: In loop Detect a gap between the edge endpoints in
the loop.

Serious

Gap: Edge and Vertex Detect a gap between a vertex and an
endpoint of the edge linked to that vertex.

Serious

Gap: Vertex and
Surface

Detect a gap between the vertex and the
related UV curve at the actual distance.

Serious

Gap
between
Edge and
Surface

Gap: Edge and Base
Surface

Detect a gap between the edge used on the
face and the base surface.

Serious

Gap: Edge and UV
Curve

Detect a gap between the edge used on the
face and UV curve.

Serious

Gap: 2D trimming
curve to 3D

Detect the actual gap of UV curve associated
with one edge.

Serious
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Category Error Item Description Severity
Invalid
Element

Surface with Singular
Point

Detect the surface where U and V directions
are parallel at the corner of the curved
surface and the normal line cannot be
calculated.

Serious

Edge crossing of
Surface Pole

Detect the edges of face passing through the
poles of the base surface.

Critical

Intersecting Loops Detect loops that intersect each other on the
same face.

Critical

Loop with Self-
Intersection

Detect a self-intersection loop. Serious

Surface with Self-
Intersection

Detect a self-intersecting surface. Critical

Continuity Cusp Curve Detect a curve with G1 discontinuity. Critical
Creased Surface Detect a surface with G1 discontinuity.

(Check the discontinuity for both u and v
directions.)

Critical

Quality Curve with Many
Segments

Detect curves with more than a certain
number of segments (control points).

Minor

Surface with Many
Patches

Detect surfaces with more than a certain
number of patches (control points).

Minor

Surface with Small
Patch

Detect small patches on a surface. Serious
(*1)

Curve with Short
Segment

Detect a curve with small segment. Serious
(*1)

Aspect Ratio of Patch Detect a patch with high aspect ratio. Minor
Aspect Ratio of Surface Detect a surface with high aspect ratio. Minor
Curve with Oscillations Detect a curve whose control points form

oscillation.
Minor

Surface with
Oscillations

Detect a surface whose control points form
oscillation.

Minor
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Category Error Item Description Severity
Others Edge Interference Detect interference within tolerance

between edges which belong to the same
volume.

Serious

Duplicated Vertex Detect duplicated vertices which are located
closer to each other than the tolerance.

Serious

Acute Edge Connection Detect where the two edges connect at an
acute angle in the loop.

Minor

Acute Face Connection Detect where the adjacent face and the base
surface is connected at an acute angle in the
loop.

Minor (*2)

Duplicate Faces Detect whether a face completely overlaps
another face within the tolerance.

Minor

Shells interference in a
Part

Detect an intersection between two shells
belonging to the same part.

Minor

(*1) Critical only for NX I-deas
(*2) Serious only for NX

Explanation of Severity Level

The following section describes how error items for each severity affect data translation.

Critical

Serious problems may occur, such as data not being passed to the target CAD system.

Serious

When passing data to the target CAD system, some data may not be passed, or an error
may occur in the operation after being passed.

Minor

This is just a warning. This level hardly affects the data translation. However, it is
recommended to look through the errors because they may cause problems in the post
processes such as analyzing, manufacturing, etc.
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A.2. Analytic Surfaces
In addition to NURBS, which represents general surface, there are surfaces called "Analytical
surfaces," such as spheres and cylinders. Analytical surfaces have the following characteristics.

1. Relatively easy to change the geometry in post-process.
For example, the radius and the height of a cylinder can be changed quite easily.

2. Easy to process with CAM, etc.

3. The center of cylindrical or spherical surface can be determined accurately.



Please note that although analytical surfaces have such characteristics,
depending on the modification function, the surface may slightly deformed
after modification, ending up as a general surface. When passing analytical
surface for post processing, the appropriate modification function must be
used.

■ Relationships between modification functions and analytical surfaces before and after
modification

Function Name Surface Type
Project Edge on Surface ○
Extend Surface ○
Boundaries→Surface ×
Boundaries, Surface→Surface ×
Recalculate Surface ×
Fit Face to Loops ×
Divide Face ○
Approximate Surface ○*[1]

Make Base-Suface Smaller ○
Change Face Boundary ○

Surface Type

◯ : Kept
× : Change to General Surface

*[1] If it’s possible to approximate the surface as an analytical surface, the surface will be
replaced with an analytical one.
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