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Shortened Names for 3DxSUITE Products

In this document, the 3DxSUITE product names are referred to as follows:

• 3DxSUITE Components → Components

• 3DxSUITE Viewer → Viewer

• 3DxSUITE Editor → Editor

• 3DxSUITE SmartLauncher (Standalone) → SmartLauncher (Standalone)

• 3DxSUITE SmartLauncher (Plug-in) → SmartLauncher (Plug-in)

• 3DxSUITE SmartController → SmartController

• 3DxSUITE SmartController Pro → SmartController Pro

• 3DxSUITE TransServer → TransServer

• 3DxSUITE WorkerNode → WorkerNode

• 3DxSUITE ScenarioEditor → ScenarioEditor

• 3DxSUITE Data Package Studio → Data Package Studio

• 3DxSUITE Validation Configurator → Validation Configurator

• 3DxSUITE PDQ Checker Configurator → PDQ Checker Configurator

• 3DxSUITE Setting Utility → Setting Utility
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1. Preface

1.1. About this Tutorial
This tutorial is composed of two parts: "3, Recognize and Remove Feature" and "4, Additional
Simplification Functions". You can learn how to operate Editor (Simplification mode) step by
step.


Simplification mode is a function that performs geometry simplification by
removing characteristic shapes such as fillets, holes, bosses, ribs, and
chamfers.

Furthermore, the features described in this tutorial are just a part of Editor (Simplification
Mode). Please refer to the online help for other features.

About Help

For Editor help, select [Help] > [Help Index] from Editor menu. The help provides details
about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark appears next to the cursor so either click the menu or the icon.


Go through Editor "Tutorial -Standard function-" to learn the basic functions of
Editor before starting this tutorial.


"Geometry Simplifier" license is required to use Editor (Simplification Mode) in
addition to the Editor license.
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1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] ( ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of Simplification is not displayed in the Editor, select [View] >
[Toolbar] > [Simplification].

1.3. About Sample Data
The sample data to be used is located in the folder "\document\tutorial_models\simplification"
inside the folder where Editor is installed.

1.4. About Images
The images in this document may include slight differences from the ones actually displayed on
your Editor depending on your specific computer hardware and Editor version.
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2. Operation Flow
This tutorial will review the standard flow through the use of the simplification tools. As seen in
the table below, this process follows the standard Editor sequence of operations with new
capabilities defined in steps 4, 5 and 6.

Operation Mode
1 File Import

Translation
or
PDQ

2 Model Check
3 Stitch (if free edges exist)
4 Recognize and Remove Feature

Simplification
5 Additional Simplification Functions

6 Auto Heal
Translation
or
PDQ

7 Manual Heal
8 Export File

The following will explain how to use Simplification mode (Steps 4～5 in the above flow) using
sample files. Please refer to the help if you see any unknown terms during the tutorial.
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3. Recognize and Remove Feature

3.1. Summary
Editor can recognize several common types of features including Fillets, Chamfers, holes, Bosses
and Ribs after the recognition of Boundary Geometry. Once these features have been
recognized to your specifications, they can be easily removed. Most operations are automatic;
therefore Simplification can be done very easily.

3.2. Recognize and Remove Fillets
1. Select [File] > [Open] and open " feature.drfx " in <tutorial> folder.

Figure 1. Sample Model for Removing Fillets

2. Select "Fillet" from the feature list to display [Check All Fillets] ( ) in [Main] panel. Press
this icon to automatically recognize fillets. (Double-click "Fillet" from the feature list will
automatically recognize it as well.)
Select [Check All Fillets] (  ) (*1) and the fillets less than 5mm will be found and
highlighted. Here, a fillet radius of 5 mm or less is recognized.


[Check All Fillets] (*1)
Fillet recognition is based on the threshold value displayed in the list. (This
threshold can be changed by right-clicking "Fillet" and selecting "Modify
Threshold" from the context menu.)
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Figure 2. Recognized Fillets



◦ The threshold value to recognize fillets can be specified in the item list
of [Main (Work)] panel.

◦ To recognize the large fillets of the model, change the maximum limit of
the threshold value, and perform automatic recognition again.

3. Press [Remove All (Fillets)] (  ) to remove recognized fillets.

Figure 3. After Removal of Fillets

Also, the operating method of "Recognize and Remove Chamfers" is similar to the above
section, "Recognize and Remove Fillets". The threshold value that can be set is the fillet
radius when recognizing the fillet, whereas the width of chamfer face when recognizing the
chamfer.

3.3. Recognize and Remove Holes
1. Select "Round Hole" from the feature list to display [Check All Round Holes] ( ) in [Main]

panel. Press this icon to automatically recognize holes. (Double-click "Round Hole" from the
feature list to automatically recognize as well.) The number of recognized feature "Round
Hole" is displayed, and the recognized areas are highlighted.
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Figure 4. Recognized Holes


Round holes are recognized based on the threshold values displayed in the
list. In this case, holes with a diameter of 25 mm or less are recognized.
(This threshold can be changed by right-clicking "Round hole" and selecting
"Modify Threshold" from the context menu.)

2. Press [Remove All (Round Holes)] (  ) on Navigation panel to remove recognized holes.

Figure 5. After Hole Removal

3. When rotating the model, semi-circular holes can be seen as below. Non-circular holes can
also be recognized manually. Press [Check/Uncheck Round Hole] (  ) from [Main] panel.
For manual recognition, pick (*1) the face around the hole (In the figure, the face is
highlighted in blue.) and press [Done](  ).
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Figure 6. Manual Hole Recognition

 (*1) To recognize a through hole, pick the faces on both sides of the hole.

4. A confirmation dialog will appear. To recognize the area as a round hole, click [Yes].

Figure 7. Manual Hole Recognition 1

The number of recognized feature "Round Hole" is displayed, and the recognized areas are
highlighted.

Figure 8. Manual Hole Recognition 2

5. Press [Remove All (Round Holes)] ( ) on Navigation panel to remove all recognized round
holes.
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Figure 9. Remove Hole

3.4. Recognize and Remove Boss/Ribs
1. Select "Boss/Rib" from the feature list to display [Check All Bosses/Ribs] ( ) in [Main]

panel. Press this icon to automatically recognize Boss / Rib (*1). (Double-click "Boss/Rib"
from the feature list to automatically recognize as well.) The number of recognized feature
"Boss/Rib" is displayed, and the recognized areas are highlighted.


[Check All Bosses/Ribs] (*1) 
Boss/Rib recognition is performed based on the threshold value displayed
in the list. Please refer to the help for more details about setting the
threshold.

In this tutorial, recognition will be performed according to threshold in the following dialog.

Figure 10. Boss/Rib Threshold Setting dialog, Boss/Rib Recognition

2. Press [Remove All (Bosses/Ribs)] (  ) on Navigation panel to remove all recognized
bosses/ribs.
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Figure 11. After Removal of Bosses/Ribs

3.5. Recognize and Remove Projection
Shapes on the face such as bosses/ribs can also be recognized manually as projections. This
section will explain how to recognize bosses/ribs as projections and remove them.

1. Select [Edit] > [Undo] (  ) to go back to the model with boss/rib.
(Likewise, select [File] > [Open] and open " feature2.drfx " in < tutorial > folder.)

2. Select "Projection" from the feature list to display [Check/Uncheck Projection] ( ) in
[Main] panel. Press this icon. Editor will be in a waiting state for you to pick the face. Pick
the face around the projection (In the figure, the face is highlighted in blue.) and press
[Done] (  ). A confirmation dialog will appear. To recognize the area as a projection, click
[Yes].

Figure 12. Recognized Projection 1

3. The number of recognized feature "Projection" is displayed, and the recognized areas are
highlighted. Similarly, recognize the projection on the opposite side.
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Figure 13. Recognized Projection 2

4. Press [Remove All (Projections)] ( ) on Navigation panel to remove all recognized
projections.

Figure 14. After Removal of Projection

Simplification can be used with a very simple operation.

Figure 15. The Original Model, The Simplified Model

This is the end of removing the recognized feature in Simplification.

3.6. Recognize and Extract Holes
1. Select [File] > [Open] ( ) and open " hole.drfx " in <tutorial> folder.
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Figure 16. After import

2. Select "Round Hole" from the feature list in [Main] panel, and press [Check/Uncheck Round
Hole] (  ).

3. To recognize a through hole, pick the faces on both sides of the hole, and press [Done] ( 
).

Figure 17. Hole Recognition

4. A confirmation dialog will appear. Click [Yes] to recognize the area as a round hole.
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5. Press [Extract All Round Holes] (  ) to extract only the recognized holes as another solid
part.

Figure 18. Extract Hole

3.7. Recognize and Remove Steps
1. Select [File] > [Open] and open " remove_step.drfx " in <tutorial> folder.

Figure 19. After import

2. Select "Step" from the feature to display [Check All Steps] ( ) in [Main] panel. Press this
icon to perform automatic step recognition. (Double-click "Step" from feature list to
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automatically recognize as well.) The number of recognized feature "Step" is displayed, and
the recognized areas are highlighted.

Figure 20. Check All Steps


Step recognition is performed based on the threshold value displayed in
the list. Here, faces with the maximum width of 10 mm or less are
recognized. (To change the threshold, right-click the feature name "Step"
and select [Modify Threshold]. A dialog will appear.)



In this tutorial, set the following option for step ([Simplification] >
[Options]). Please refer to the help for details about the settings.

3. Press [Remove All (Steps)](  ) on Navigation panel to remove all recognized steps.
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Figure 21. After Step removal

The step on top of the model is not recognized automatically because the face width is
greater than the threshold. In this case, perform manual recognition on this step and
remove it.

Figure 22. The step that Editor cannot recognize as step feature automatically

4. Press [Check/Uncheck Step] (  ) in [Main] panel. Pick the face to be recognized as step,
and press [Done] (  ). A confirmation dialog will appear. Click [Yes] to recognize the area
as the step if you prefer.

Figure 23. Selection of the step
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5. Press [Remove Step] (  ) on Navigation panel to remove the recognized step. After
pressing the icon, pick the faces to match after the step is removed. In this case, pick face [1].

Figure 24. Selection of the face to match

The step is removed according to the selected face.

Figure 25. After Step removal

6. Remove the step on the back of the model. Press [Check/Uncheck Step] (  ). Pick the face
pointed by the arrow in the below figure to recognize the step.

Figure 26. The selection of the step

7. Press [Remove Step] (  ) in [Main] panel, and pick the face ([2] or [3]) to match after
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removing the step.

The following are the results when steps are removed using faces [2] and [3] as the base.

Figure 27. After Step removal (Selected face [2])

Figure 28. After Step removal (Selected face [3])
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4. Additional Simplification Functions

4.1. Summary
According to the previous chapter, a large portion of the model can be simplified by removing
features. In this chapter, additional tools are introduced to assist simplifying geometry which
could not be simplified by already introduced methods.

4.2. Fill Crack (Create surface between curve sets)
1. Select [File] > [Open] and open " others.drfx " in <tutorial> folder. This model is similar to

the one used in Chapter 3. Because the deleted part leaves behind an unused edge, create a
face that connects the unused edges.

Figure 29. Sample Model for Fill Crack

2. From the menu, select [Simplification] > [Fill Crack] (  ).


The command [Fill Crack] creates a new connecting face between the two
specified edges.

3. Pick the edges at both ends of the curve group to specify the first set of edges. In this model,
the curve group consists of two edges, so pick the edges at both ends. Refer to the figure
below to specify the first set of edges. A group of curve is highlighted and a confirmation
dialog will appear. Click [Yes].
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Figure 30. Select Edges

4. Similarly, specify the second set of edges, and a confirmation dialog will appear. Click [Yes]
to create a connecting face between the unused edges.


To flip the faces, select [Modify] > [Repair Solid] > [Flip Face] (  ) and
select the face that is incorrect.

Figure 31. Face is Created

4.3. Remove Faces with Fix
This function will remove the selected faces and then repair the geometry using the adjacent
faces as guidelines for the shape.

1. In this example, select [Simplification] > [Remove Faces with Fix] ( ). Referring to the
lower left figure, pick the two faces to delete. When pressing [Done] ( ), the faces are
deleted as shown in the lower right figure.
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Figure 32. Remove Faces with Fix 1

Repeat this step for the other side if desired as below.

Figure 33. Remove Faces with Fix 2

Figure 34. Remove Faces with Fix 3, Simplified Model

4.4. Merge Faces
1. Select "Mergeable Faces" from the feature list to display [Check All Mergeable Faces] ( ) in

[Main] panel. Press this icon to automatically recognize the faces to be merged. (Double-click
"Mergeable Faces" from the feature list to automatically recognize as well.)

2. The number of recognized feature "Mergeable Faces" is displayed, and the recognized areas
are highlighted.

3. Press [Merge All Mergeable Faces] ( ) on Navigation panel to connect (merge) the
recognized connectable faces.
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Figure 35. Merged Face

This completes the introduction of additional Simplification functions.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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