
3DxSUITE Editor
Tutorial -Polygon Check/Healing-

September 2022

Elysium Co. Ltd.



Table of Contents
1. Preface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2

1.1. About this Tutorial. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2

1.2. About the Notations of Menus and Icons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3

1.3. About Sample Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3

1.4. About Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3

2. Operation Flow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4

3. Polygon PDQ. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

3.1. Overview of this Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

3.2. Import STL File as a Polygon Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

3.3. Check Errors in Polygon Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  8

3.4. Heal Polygon Data Automatically . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  10

3.5. Smoothing Polygon . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11

3.6. Manual Healing for Polygon Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  12

3.7. Export STL File after Healing the Polygon Data . . . . . . . . . . . . . . . . . . . . . . . . . . .  14

4. Polygon PDQ (Point Cloud to Polygon). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

4.1. Overview of this Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

4.2. Import Point Cloud Data from .txt File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

4.3. Remove Outliers in Point Cloud Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  18

4.4. Create Polygon from Point Cloud Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  19

4.5. Verification of Distance between Polygon and Point Cloud . . . . . . . . . . . . . . . .  21



Shortened Names for 3DxSUITE Products

In this document, the 3DxSUITE product names are referred to as follows:

• 3DxSUITE Components → Components

• 3DxSUITE Viewer → Viewer

• 3DxSUITE Editor → Editor

• 3DxSUITE SmartLauncher (Standalone) → SmartLauncher (Standalone)

• 3DxSUITE SmartLauncher (Plug-in) → SmartLauncher (Plug-in)

• 3DxSUITE SmartController → SmartController

• 3DxSUITE SmartController Pro → SmartController Pro

• 3DxSUITE TransServer → TransServer

• 3DxSUITE WorkerNode → WorkerNode

• 3DxSUITE ScenarioEditor → ScenarioEditor

• 3DxSUITE Data Package Studio → Data Package Studio

• 3DxSUITE Validation Configurator → Validation Configurator

• 3DxSUITE PDQ Checker Configurator → PDQ Checker Configurator

• 3DxSUITE Setting Utility → Setting Utility
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1. Preface

1.1. About this Tutorial
This tutorial is composed of two parts which are "3, Polygon PDQ" and "4, Polygon PDQ (Point
Cloud to Polygon)" and you can learn how to operate Editor (Polygon PDQ Mode) step by step.

■ Polygon PDQ Mode

This mode allows you to check the quality of polygons (STL data) and heal them. Polygon
smoothing is also possible.

■ Polygon PDQ (Point Cloud to Polygon)

With this function, you can create polygons from the point cloud data. It is possible to
remove noise included in the point cloud as well.

Furthermore, the features described in this tutorial are just a part of Editor (Polygon
Check/Healing). Please refer to the help for additional information.

About Help

For Editor help, select [Help] > [Help Index] from Editor menu. The help provides details
about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of offline help, select [Help] > [Context
Help], and a question mark appears next to the cursor so either double-click the menu or
just click the icon.


Go through Editor "Tutorial -Standard function-" to learn the basic functions of
Editor before starting this tutorial.


"Polygon Optimizer" license is required to use Editor (Polygon PDQ Mode) in
addition to the Editor license.
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1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] ( ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of polygon Check/Healing is not displayed in the Editor, select
[View] > [Toolbar] > [Polygon PDQ].

1.3. About Sample Data
The sample data to be used is located in the folder "\document\tutorial_models\polygon" inside
the folder where Editor is installed.

1.4. About Images
The images in this document may include slight differences from the ones actually displayed on
your Editor depending on your specific computer hardware and Editor version.
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2. Operation Flow
This tutorial will explain about the standard procedure in using the polygon Check/Healing
function.

As seen in the table below, this process follows the standard Editor sequence of operations with
new capabilities described in steps 2 through 5 in Polygon PDQ mode.

Operation Mode
1 File Import

Polygon PDQ

2 Check polygon

3 Auto Heal for Polygon

4 Smoothing Polygon

5 Manual Heal for Polygon

6 File Export

In the following chapters, operation procedures for Polygon PDQ mode (Step 2-5 shown above)
will be explained by using the samples files. Please refer to the help for further information of
the operations used in this tutorial.
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3. Polygon PDQ

3.1. Overview of this Function
This section illustrates the example procedure for Polygon PDQ of Editor.

■ Operation flow

1. 3.2, “Import STL File as a Polygon Data”

2. 3.3, “Check Errors in Polygon Data”

3. 3.4, “Heal Polygon Data Automatically”

4. 3.5, “Smoothing Polygon”

5. 3.6, “Manual Healing for Polygon Data”

6. 3.7, “Export STL File after Healing the Polygon Data”

3.2. Import STL File as a Polygon Data
Import STL file of the polygon data.

1. Select [File] > [Import] from the menu or click [Import] ( ) on the toolbar.
Switch the file type to "STL (*.stl)" in "Open" dialog. Specify "sample_polygon1.STL" in the
<tutorial> folder.

Figure 1. Open dialog

2. Click [Option] in "Open" dialog to display "Option" dialog.
Confirm that the settings are the same as shown below and click [OK].
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Figure 2. Dialog of import option

3. Click [Open] in "Open" dialog to import polygon data.
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

• If the mode is not in "Polygon PDQ", change it to "Polygon PDQ" mode in
[Main (Work)] panel.



• The display mode of polygon can be changed by [Display type(Polygon)](
 ) in the toolbar.

Figure 3. Tool for changing display mode

◦ [Wireframe (Polygon)] ( ): Display wireframe of polygon

◦ [Shading (Polygon)] ( ): Display polygon in shading

Figure 4. Shading and Wireframe display

◦ [Shading + Wireframe (Polygon)] ( ): Display polygons in shading and
wireframe.

◦ [Semi Transparent (Polygon)] ( ): Display polygons in a semi-
transparent shaded view.

Figure 5. Shading + Wireframe and Semi Transparent
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

• If you would like to change the display color of polygon on Editor, select
[File] > [Display Preference] > [Display Attribute] tab > "Polygon Color".

3.3. Check Errors in Polygon Data
Run check on polygon data.



• In "Import / Export Settings" dialog, because "Execute" is enabled by default
in the option "PDQ" of [Import Common] tab, check runs automatically
during import.

• If the result is not displayed, press [Check] ( ) in [Main (Work)] panel.

1. Specify "Sliver Triangle" from the category list in [Main (Work)] panel.
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2. Press [Display Surrounding] (  ) to display on "3D View" window not only the polygon
containing the sliver triangle, but also the surrounding polygons. Also, next to [Display
Surrounding] (  ), the icons [Extend Display Region] (  ) and [Reduce Display Region] (

 ) will appear.

By using [Extend Display Region] and [Reduce Display Region] icons, you can change the
display region of the polygons detected by the "Sliver Triangle".

Figure 6. Control display region

3DxSUITE Editor Tutorial -Polygon Check/Healing-

 © 2022 Elysium Page 9 | 23



3.4. Heal Polygon Data Automatically
Auto heal the polygon data.

1. Select [Polygon PDQ] > [Options] to display "Polygon PDQ option" dialog.

2. Select [Polygon Auto-Heal] tab in "Polygon PDQ option" dialog. Enable the options "Modify
Free Edge" and "Modify Short Edge", and click [OK].

3. Press [Auto Heal] (  ) in [Main (Work)] panel to heal "Free Edge" and "Short Edge".

If several errors are remaining after auto healing, you can also perform interactive healing
on the Work Tab. (Not necessary in this case.)

Figure 7. After healing
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3.5. Smoothing Polygon
Smooth the polygon data.

1. Select [Polygon PDQ] > [Polygon Smoothing] > [All] ( ) to smooth the entire polygon data.

Figure 8. After Polygon Smoothing (All)

Next, smooth the specified region of polygon data.

2. Select [Polygon PDQ] > [Polygon Smoothing] > [Specified Region] from the menu or select
[Specified Region] (  ).

3. As shown in the below figure, pick from point 1 to point 5 in sequence, and press [Done]
( ).

Figure 9. Specified Region (Polygon Smoothing)

Specified region of polygon data will be smooth.
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Figure 10. After smoothing (Specified region)

3.6. Manual Healing for Polygon Data
Manually heal the polygon data. There are two ways of manual healing.

• Change the check items' threshold and heal the errors

• Delete polygon and fill hole

■ Change the check items' threshold and heal the errors (e.g., Long Edge)

1. Select "Long Edge" in the check item and right-click. Select [Modify Threshold] as follows.

Figure 11. Context menu

2. "Long Edge" dialog will appear. Change the threshold as pictured below (0.5mm) and click
[OK].

Figure 12. Change threshold dialog
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3. Press [Check] (  ) in [Main (Work)] panel to detect "Long Edge".

4. Select [Polygon PDQ] > [Repair Errors] > [Repair All Long Edges] from the menu or click
[Repair All Long Edges] ( ) on Navigation panel. Long Edge will be healed by using
"Repair All Long Edges".

Figure 13. After Repair All Long Edges

■ Delete polygon and fill hole

Delete unnecessary polygon and fill hole. This is useful in case you are dealing with rugged
polygon.

1. Select [Polygon PDQ] > [Fill Hole] > [Remove Triangles with Fix] ( ).

2. Pick point 1 to point 4 in sequence on "3D View" window, and press [Done] ( ).
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Figure 14. Manual healing of rugged polygon

3.7. Export STL File after Healing the Polygon Data
Export the healed polygon data as STL file.

1. Select [File] > [Export] or click [Export] (  ) on the toolbar.

2. "Save As" dialog will appear. Switch the file type to "STL (*.stl)". Enter the file name and the
location to save the file, and then click [Save].

Figure 15. "Save As" dialog
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4. Polygon PDQ (Point Cloud to Polygon)

4.1. Overview of this Function
This section illustrates the example procedure to create Polygon from Point Cloud.

■ Operation flow

1. 4.2, “Import Point Cloud Data from .txt File”

2. 4.3, “Remove Outliers in Point Cloud Data”

3. 4.4, “Create Polygon from Point Cloud Data”

4. 4.5, “Verification of Distance between Polygon and Point Cloud”

4.2. Import Point Cloud Data from .txt File
Import text file of point cloud data.

1. Select [File] > [Import] or [Import] ( ) from the toolbar.
Open dialog will appear. Specify the file extension and select "sample_PointCloud.txt" in
<tutorial> folder to import.

Figure 16. Open dialog

2. Click [Option] in "Open" dialog to display "Option" dialog. Confirm that the settings are the
same as shown below and click [OK].
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Figure 17. Option dialog

3. Click [Open] in "Open" dialog to import the point cloud data.
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

Please note that if you haven’t switched to [Polygon PDQ] mode, then switch
the mode in [Main (Work)] panel.

Display setting of Point Cloud

The displayed point cloud density on "3D View" window can be adjusted in [File] >
[Display Preference] > [Tessellation Tol] tab.

Figure 18. Display Setting Dialog (Tessellation Tol tab)

Figure 19. Density differences between 1.33 (units/ pixel) and 0.2 (units/ pixel)
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4.3. Remove Outliers in Point Cloud Data
Depending on the point cloud data, the point cloud may contain outliers (e.g., points with
incorrect coordinate values).
With this function, outliers included in point cloud can be automatically removed.

1. Select [Point Cloud] > [Remove outliers] (  ).

2. Change "Threshold number of points" to 45, and click [Detect].

Figure 20. "Remove Outlier" parameter settings


In this case, the outliers of point cloud data can all be removed by setting
"Threshold number of points" to 45.

Outliers will be detected, and the number of detected points will be displayed in "Remove
Outliers" dialog.

Figure 21. Result of detected outliers

In addition, the outliers will be highlighted in red on "3D View" window.

Figure 22. Outliers highlighted in red

3. Click [Remove] to remove outliers.
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Figure 23. After removing outliers

4.4. Create Polygon from Point Cloud Data
Create polygon data from the point cloud from which outliers were removed in the previous
step.

1. Select [Point Cloud] > [Options].

2. "Point Cloud option" dialog will appear. "Mesh fineness" and "Trimming area" can be
adjusted in "Generate Polygon from Point Cloud". In this case, without changing the settings,
click [OK].

Figure 24. Point Cloud options dialog

3. Select [Point Cloud] > [Generate Polygons from Point Cloud] or click [Generate Polygons
from Point Cloud] ( ) in [Main (Work)] panel.

4. "Generate Polygons from Point Cloud" dialog will appear. In this case, leave the settings as is
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and click [OK].

Polygon data can be created from point cloud data.

Figure 25. After Creation Polygon



Point cloud data and polygon data can be hidden or deleted on the
structure tree of [Main (Structure)] panel.

Figure 26. Point cloud is No show
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4.5. Verification of Distance between Polygon and
Point Cloud
Verify the distance between the created polygon data and point cloud data.

1. Select [Analysis] > [Show Distance] > [Options] or click [Set show difference options] ( )
from the toolbar.

2. "Show difference option" dialog will appear. In this case, disable "Auto" in the range, and
change "Maximum" to 0.02mm, and "Minimum" to -0.02mm. Then click [OK].

3. Select [Analysis] > [Show Distance] > [Point Cloud - Polygon] or click [Show Distance
between Point Cloud and Polygon] (  ) from the toolbar.
It is possible to check the errors between the point group and the polygon on "3D View"
window.

Figure 27. Show distance of Point cloud – Polygon


If you have Editor Reverse Engineering option, you can create B-rep
surface with this polygon model. Please refer to the help and Editor
Reverse Engineering Tutorial for further information of the operations.
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This is the end of Editor Polygon PDQ mode tutorial.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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