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Shortened Names for 3DxSUITE Products

In this document, the 3DxSUITE product names are referred to as follows:

• 3DxSUITE Components → Components

• 3DxSUITE Viewer → Viewer

• 3DxSUITE Editor → Editor

• 3DxSUITE SmartLauncher (Standalone) → SmartLauncher (Standalone)

• 3DxSUITE SmartLauncher (Plug-in) → SmartLauncher (Plug-in)

• 3DxSUITE SmartController → SmartController

• 3DxSUITE SmartController Pro → SmartController Pro

• 3DxSUITE TransServer → TransServer

• 3DxSUITE WorkerNode → WorkerNode

• 3DxSUITE ScenarioEditor → ScenarioEditor

• 3DxSUITE Data Package Studio → Data Package Studio

• 3DxSUITE Validation Configurator → Validation Configurator

• 3DxSUITE PDQ Checker Configurator → PDQ Checker Configurator

• 3DxSUITE Setting Utility → Setting Utility
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1. Preface

1.1. About this Tutorial
This tutorial is composed of four parts and you can learn how to operate Editor (Midsurface
Mode) step by step.

■ Midsurface Mode

With Midsurface option of Editor, you can automatically generate midsurfaces from plate-
like solid models. Automatically generated midsurfaces can be corrected with Interactive
Healing depending on the needs of post-process. By combining this function with Elysium’s
powerful geometry-optimizing technology such as data translation, automatic healing or
geometry simplification, you can generate even higher precision midsurfaces.

Key Feature 1. Advanced Geometry Recognition

Recognize geometry such as fillets or bosses from CAD model without feature histories.

 Simplify complex geometry data with this function.

Key Feature 2. Automatic Generation of High-quality Midsurfaces

Midsurfaces can be generated based on automatically recognized paired faces.

Key Feature 3. Intuitive Interactive Healing

• Automatically recognizes areas to correct

• Generated midsurfaces will keep their association with the original geometries.

• Easy-to-use geometry editing functions, yet at advanced level

Key Feature 4. Proven Data Translation

When combined with Input / Output options, each CAD data can be read and written.

Furthermore, the features described in this tutorial are just a part of Editor (Midsurface Mode).
Please refer to the help for other features.

About Help

For Editor help, select [Help] > [Help Index] from Editor menu. The help provides details
about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark appears next to the cursor so either double-click the menu or just click the
icon.
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
Go through Editor "Tutorial -Standard function-" to learn the basic functions of
Editor before starting this tutorial.


"Mid Surfacer" license is required to use Editor (Midsurface Mode) in addition
to the Editor license.

1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] ( ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of Midsurface is not displayed in Editor, select [View] > [ToolBar]
> [Midsurface].

1.3. About Sample Data
The sample data to be used is located in the folder "\document\tutorial_models\midsurface"
inside the folder where Editor is installed.

1.4. About Images
The images in this document may include slight differences from the ones actually displayed on
your Editor depending on your specific computer hardware and Editor version.
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2. Operation Flow
This tutorial will explain about the standard operations when using the Midsurface functions.

The following are the overall procedures.
Basically, the procedures are the same as in normal data translation, but use Midsurface mode.
* Red text indicates operations to be performed in Midsurface mode.

Operation
1 Import file
2 Set Threshold

3 Automatic Recognition of Face Pair

4 Manual Recognition of Face Pair

5 Change Type of Face Pair

6 Complete Midsurface

7 Manual Healing

In the following chapters, operation procedures for Midsurface mode (Step 2-7 shown above)
will be explained by using the sample files. Please refer to the help if you see any unfamiliar
terms during the tutorial.
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About Twin View

In Midsurface Mode, you can split the view window into two parts to display the CAD
model and the generated midsurface.

Toggle the partitioned view from [View] > [Twin View (Midsurface)] or click [Work in
Twin View] icon on Toolbar.

Figure 1. Twin View (Midsurface) toolbar

Display imported CAD model (e.g., IGES) on the left view.

Display the paired faces or midsurface on the left view.

Switch the view mode between Single View and Twin View.

Display imported CAD model (e.g., IGES) on the right view.

Display the paired faces or midsurface on the right view.

Synchronize the view operation (left and right side).

Display imported original model with wireframe.
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3. Create Midsurface

3.1. Overview of this Chapter
This chapter will explain how to use Midsurface functions to automatically generate and modify
midsurfaces for analysis from solid models.

3.2. Import Files
Import IGES file as CAD model.


In some parts of this manual, IGES format files are used to explain the
procedures. To import IGES format files, a dedicated license is required. If you
do not have an IGES license, open a file with the same file name but with a
.drfx extension.

1. Select [File] > [Import] from the menu or select[Import] ( ) on the toolbar.

Switch the file type to "IGES file (*.igs, *.iges)" in "Open" dialog. Specify the "sample.igs" in
the <tutorial> folder.

Figure 2. "Open" dialog

2. Click [Open] in "Open" dialog to import the IGES file.

3DxSUITE Editor Tutorial -Midsurfacer-

 © 2022 Elysium Page 6 | 38



Figure 3. After importing



Please note that if you haven’t switched to [Midsurface] mode, then switch
the mode in [Main (Work)] panel.

Figure 4. Switch mode
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

◦ Editor can automatically heal the geometry. Depending on the CAD
model, it is possible to reduce the number of failures / manual
corrections by creating a midsurface after changing complex geometry
into simple geometry with the automatically healing functions. Please
refer to the help for more details about Automatic Healing.

◦ Editor can simplify the geometry. Depending on the CAD model, it is
possible to reduce the number of failures / manual corrections by
creating a midsurface after changing complex geometry into simple
geometry with the simplification functions. Please refer to the help for
more details about the simplification functions.

Figure 5. Example: Recognizing a sliver slit semi-automatically and deleting
automatically

3.3. How to Modify Threshold
Set the threshold which will be the basis for recognizing "Face Pair". Two faces will be
recognized as Face Pair when the distance between them is smaller than the threshold you
specified.

1. Right-click "Face Pair" in the Midsurface list of [Main (Work)] panel, and select [Modify
Threshold] from the context menu

2. "Face Pair" dialog will appear. Change the threshold to 5mm and click [OK].
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"Face Pair" threshold in the Midsurface list will be modified.



When clicking [Measure] in "Face Pair" dialog and picking two elements of
the model, you can measure the distance between them and use them as
thresholds.

Figure 6. Pick face and edge
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3.4. Pair Up All Faces
Automatically recognizes the pair relationship of faces which will be used when creating a
midsurface.

1. Press [Pair up All Faces] ( ) in [Main (Work)] panel.


If [Pair up All Faces] ( ) is not displayed, click anywhere in the
Midsurface list to make it active (Background of the list turns white).

2. Automatic recognition of Face Pair will be executed, and the Midsurface list of [Main
(Work)] panel will be updated.

Edit Tool will appear on Navigation panel.

The "3D View" window will switch to Twin View, one for CAD model (Original) and the other
for Face Pair.
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Type of Face Pair

Recognized paired faces are classified as either "Intermediate Face" or "Offset Face"
depending on the calculation method used at the time of generation. Also, there are two
types of "Intermediate Face": "Intermediate Face (constant)" and "Intermediate Face
(variable)".

• Intermediate Face: A midsurface is created between two faces.

◦ When wall thickness is constant: "Intermediate Face (constant)"

◦ When wall thickness changes within the threshold value: "Intermediate Face
(variable)"

• Offset Face: A plane with one side offset is created.

When enabling "Generate Midsurface by using Offset" option in [Generation] tab of
"Midsurface option" dialog, Offset Face will be applied to all paired faces where the wall
thickness changes so that there are no minute steps. When disabled, all pairs will be
determined either "Intermediate Face (constant)" or "Intermediate Face (variable)". In
addition, areas where pairs are not found within the specified threshold range are
classified as "Other".
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3.5. Pair Up
Add pair recognition manually to the area where automatic recognition of paired faces failed.

1. Select "Other" in the Midsurface list of [Main (Work)] panel, and press [Zoom current target]
( ).


Please note that parts where Editor failed to automatically recognize the
paired faces are classified as "Other" in the Midsurface list.

Areas around the target will be enlarged in "3D View" window. The part where Editor failed
to automatically recognize the paired faces will be highlighted in white on the left view.

Figure 7. Corresponding part highlighted in white (Semi transparent)


Switching CAD model to [Semi transparent] ( ) makes it easier to check
the corresponding area．

2. Press [Pair up / Separate Faces] ( ) on Navigation panel.

3. On "3D View" window (left view), pick two faces to pair up.
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Figure 8. Pick the faces to pair up (Left view)

4. "Change Generation Type of Face Pair" dialog will appear. In this case, select "To Offset
Face", but keep the value "0", and then click [OK].



Click [Preview] to preview the paired faces created with the current
settings.

Figure 9. Preview the paired faces (Right view)

The paired faces are created and displayed on "3D View" window (Right view).
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

◦ If you want to change the Midsurface type of the paired faces
(Intermediate Face or Offset Face), select "Face Pair" in the Midsurface
list, and click [Change Paired Faces Type] ( ) on Navigation panel.

◦ To unpair, select "Face Pair" in the Midsurface list, and click [Pair up /
Separate Faces] ( ) on Navigation panel.
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3.6. Complete Midsurface
Midsurfaces are generated automatically from the paired faces.

1. Press [Generate All Midsurfaces] ( ) in [Main (Work)] panel.


When [Generate All Midsurfaces]( ) is not displayed, click anywhere in
the Midsurface list to activate (Background of the list turns white).

Midsurfaces are generated and the faces are automatically connected.

Figure 10. After completing midsurface (Right view)

The Midsurface list in [Main (Work)] panel is updated, and "Need to Connect" areas of
midsurface are displayed.
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3.7. Interactive Healing of Midsurface
For areas where [Generate All Midsurfaces] did not work, modify the midsurfaces manually in
order to connect.

1. Select "Need to Connect" in the Midsurface list of [Main (Work)] panel, and press [Zoom
current target] ( ).

Area around the target area will be enlarged in "3D View" window. Area where midsurface
could not be connected will be highlighted in red on the right view.

Figure 11. Corresponding areas are highlighted in red.


Please note that areas which could not be connected by [Generate All
Midsurfaces] are classified as "Need to Connect" in the Midsurface list.

Edit Tool will appear on Navigation panel.

2. Check the geometry and repeat Interactive Healing for each "Need to Connect" error until
the number becomes "0".
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Figure 12. After Interactive Healing of Midsurface


Please refer to "4, Case Study of Interactive Healing" for more details about
Interactive Healing.
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4. Case Study of Interactive Healing
By using specific examples, this chapter will explain how to interactively heal the midsurface to
connect the parts that could not be connected by generating midsurface automatically.

• 4.1, “Case 1: Uncheck the Recognition of Need to Connect”

• 4.2, “Case 2: Extending 2 Faces to Create a Missing Corner”

• 4.3, “Case 3: Creating a New Offset Face to Fill the Missing Area”

• 4.4, “Case 4: Correct Missing Face”

4.1. Case 1: Uncheck the Recognition of Need to
Connect
When midsurfaces are generated, a part that does not need to be connected may be classified as
needing a connection. It is possible to cancel the misclassification of the part.

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
"Open" dialog will appear. Specify "sample01_mid.drfx" in the <tutorial> folder in the dialog,
and click [Open].

Mode will switch to [Midsurface] and the model will appear on "3D View" window.
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2. Select "Need to Connect" in the Midsurface list of [Main (Work)] panel, and the
corresponding area will be highlighted in red.

3. Press [Uncheck Need-to-Connect Feature] ( ) in [Main (Work)] panel.

4. Pick the corresponding part on "3D View" window (Right view), and press [Done] ( ).

"Need to Connect" error will be unchecked, and the number of recognized errors in "Need to
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Connect" in the Midsurface list will be updated.

4.2. Case 2: Extending 2 Faces to Create a Missing
Corner
Two faces that intersect on the extension line can be extended to the point of intersection to
connect the missing corner.

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. "Open" dialog will
appear. Specify "sample02_mid.drfx" in the <tutorial> folder in the dialog, and click [Open].

Mode will switch to [Midsurface] and the model will appear on "3D View" window.
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2. Select "Need to Connect" in the Midsurface list of [Main (Work)] panel, and the
corresponding areas will be highlighted in red.

3. Press [Fill Between Edges(Intersection)] ( ) on Navigation panel.

4. Pick the first edge of the face to extend on "3D View" window, and press [Done] ( ).
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Similarly, pick the second edge of the face, and press [Done] ( ).

5. In [Option] panel, click [Run].

Two faces will be extended and connected at the intersection.
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6. With the same procedure, extend the faces for other areas.
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4.3. Case 3:  Creating a New Offset Face to Fill the
Missing Area
Generating the midsurface may fail even though the correct pair is specified as the Face Pair to
be recognized manually. In that case, restore the missing part of the face by creating an offset
face from the original CAD model.

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
"Open" dialog will appear. Specify "sample03_mid.drfx" in the <tutorial> folder in the dialog,
and click [Open].

Mode will switch to [Midsurface] and the model will appear on "3D View" window.

2. Select "Need to Connect" in the Midsurface list of [Main (Work)] panel, and the
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corresponding areas will be highlighted in red.

3. Press [Offset Faces] ( ) on the toolbar.

4. Pick the face to offset on "3D View" window (Left view), and press [Done] ( ).

5. "Offset" dialog will appear. In this case, click [Reference] to measure the offset automatically.

Pick the face at the position to offset on "3D View" window (Right view).
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The distance between the two picked faces will be set as the offset amount.

6. In "Offset" dialog, click [OK] to create a new face in the offset position.

Next, extend the existing face until it is connected to the created face, and fill in the missing
part of the face.

7. Press [Extend face and trim] ( ) on Navigation panel.
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8. [Option] panel will appear. Select "Edge Array and Target Faces" and pick three edges where
you wish to extend. Then press [Done] ( ).

9. Pick the face created earlier on "3D View" window (Right view) and press [Done] ( ).

10. In [Option] panel, click [Run].
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The three specified faces will be extended to the created faces at the offset position and
trimmed to match those faces.

Finally, delete unnecessary faces.

11. Press [Delete] ( ) on the toolbar, and switch Pick Filter to "Face".

12. In [Option] panel, keep "Specify target elements" as is, and pick the unnecessary face on "3D
View" window (Right view).
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Press [Done] ( ) to remove the specified face.
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4.4. Case 4: Correct Missing Face
While creating a midsurface, some areas may miss a face. Create and correct a midsurface for
such area.

1. Select [File] > [Open] from the menu or select [Open] (  ) on the toolbar.
"Open" dialog will appear. Specify "sample04_mid.drfx" in the <tutorial> folder in the dialog,
and click [Open].

Mode will switch to [Midsurface] and the model will appear on "3D View" window.

2. Select "Need to Connect" in the Midsurface list of [Main (Work)] panel, and the
corresponding areas will be highlighted in red.
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3. Press [Simplify Loop] ( ) on the toolbar.

4. Pick an edge to delete on the right view, and press [Done] ( ).

5. In [Option] panel, press the green cross button ( ) and the yellow cross button ( ) once
each to expand the target edges.
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6. In [Option] panel, click [Run] to delete all the specified edges.

Next, create a new midsurface from any two faces.

7. Press [Create Midsurface] ( ) on the toolbar.

8. Pick the first face group on "3D View" window (Left view), and press [Done] ( ).
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Next, pick the second face group, and press [Done] ( ).

A new midsurface will be created and displayed on "3D View" window (Right view).

Next, create a midsurface for the area missing faces, which corresponds to fillet.

9. Press [Fill Between Edges(Blend Face)] ( ) on Navigation panel.
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
If no editing icon appears on Navigation panel, select "Need to Connect" in
the Midsurface list of [Main (Work)] panel.

10. Pick the first edge on "3D View" window (Right view), and press [Done] ( ).

Next, pick the second edge, and press [Done] ( ).

11. In [Option] panel, click [Run] and a new blend face will be created.
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12. With the same procedure, create new blend faces for the other three areas.

Furthermore, select an edge of an open area and create a new fillet-corner face.

13. Press [Fill Fillet Corner] ( ) on Navigation panel.
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14. On "3D View" window (right view), pick one edge of the opening, and press [Done] ( ).

15. A confirmation dialog will appear.

On "3D View" window (Right view), a preview of the loop candidate for creating a fillet-
corner face will be displayed, so click [OK].


If the candidate loop to create the fillet-corner face is incorrect, click [Next]
to go to the next candidate.
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A new fillet-corner face will be created.

16. With the same procedure, create new fillet-corner faces for the other three areas.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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