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Shortened Names for 3DxSUITE Products

In this document, the 3DxSUITE product names are referred to as follows:

• 3DxSUITE Components → Components

• 3DxSUITE Viewer → Viewer

• 3DxSUITE Editor → Editor

• 3DxSUITE SmartLauncher (Standalone) → SmartLauncher (Standalone)

• 3DxSUITE SmartLauncher (Plug-in) → SmartLauncher (Plug-in)

• 3DxSUITE SmartController → SmartController

• 3DxSUITE SmartController Pro → SmartController Pro

• 3DxSUITE TransServer → TransServer

• 3DxSUITE WorkerNode → WorkerNode

• 3DxSUITE ScenarioEditor → ScenarioEditor

• 3DxSUITE Data Package Studio → Data Package Studio

• 3DxSUITE Validation Configurator → Validation Configurator

• 3DxSUITE PDQ Checker Configurator → PDQ Checker Configurator

• 3DxSUITE Setting Utility → Setting Utility

3DxSUITE Editor Tutorial -Envelop Solid-

 © 2022 Elysium Page 1 | 57



1. Preface

1.1. About this Tutorial
This tutorial consists of four chapters explaining about "3, Data Size Reduction" and "4, Solid
Enveloping" in [Envelop Solid] mode of Editor.

■ Data size reduction

Create a reduced size model from an assembly model.

■ Solid enveloping

Extract the boundary of the assembly model as a one part solid.

This tutorial covers part of the [Envelop Solid] mode of Editor. Please refer to the help for other
functions.

About Help

For Editor help, select [Help] > [Help Index] from Editor menu. The help provides details
about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark will appear next to the cursor so either click the menu or the icon.


Go through Editor "Tutorial -Standard function-" to learn the basic functions of
Editor before starting this tutorial.


Editor envelop solid is an optional function; therefore, Geometry Simplifier
license is required in addition to Editor standard package.
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1.2. About the notations of menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] ( ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of Envelop is not displayed in the Editor, select [View] > [Toolbar]
> [Envelop].

1.3. About sample data
The sample data to be used is located in the folder "\document\tutorial_models\envelop" inside
the folder where Editor is installed.

1.4. About images
The images in this document may include slight differences from the ones actually displayed on
your Editor depending upon your specific computer hardware and Editor version.
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2. Operation Flow
This tutorial will explain the standard operations when using the Envelop Solid functions.

The overall procedure is as follows.
As you can see in the table below, this process follows the standard Editor sequence of
operations with new capabilities defined in steps 4, 5 and 6.

Operation Mode
1 File Import

Translation
or
PDQ

2 Model Check
3 Stitch (if free edges exist)
4 Feature Recognition and Removal

Simplification
5 Additional Simplification
6 Data Size Reduction Solid Enveloping Envelop Solid

7 Auto Heal
Translation
or
PDQ

8 Manual Heal
9 Export File

The below section explains about the operation in the [Envelop Solid] mode (step 6) using
sample models. Please refer to the help if you see any unfamiliar terms during the tutorial.
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3. Data Size Reduction

3.1. Overview
This chapter will explain how to utilize the data size reduction functionality in the Envelop
Solid mode to create a reduced size data.
Data size reduction is executed in either "face units" or "volume units".



Please note that you need to switch to [Envelop Solid] mode to use the function.

3.2. Data Size Reduction in Face Units
Extract visible faces in face units and create a lightweight sheet model.

Figure 1. Example of data size reduction in face units (Left: Before, Right: After)

3.2.1. Open File

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
Specify "extract.drfx" in the <tutorial> folder in the dialog and click [Open].
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2. Select [Envelop Solid] > [Options] from the menu. Specify "Data size reduction" in [Common]
tab from "Envelop option" dialog, and click [OK].

3.2.2. Execute Data Size Reduction

1. Select [Envelop Solid] > [Reduce Data Size] from the menu or select [Reduce Data Size] icon
( ) in [Main] panel.

2. "How to Reduce the Data Size" dialog will appear. Select "By extracting visible faces only
(Result in sheet model)" and click [Next].
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3. The "Extract Visible Face" dialog will appear. Select "6 directions" for basic directions in
"Define View Directions".

Basic direction axes (XYZ axes) will appear in "3D View" window.
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
If the basic direction axes do not appear on "3D View" window, select "6
directions" radio button again.

4. Remove unnecessary view direction.
In "Extract Visible Face" dialog, click [Remove] in "Edit view directions".

Pick an axis other than the X axis positive direction (Axis 1) in "3D View" window.

 Use [Area Selection Mode] ( ) in Smart Filter to select multiple axes.

Press [Done] ( ) to remove the picked axis.
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5. In "Extract Visible Face" dialog, specify the behavior after extraction from the below three
options in "How to Treat Invisible Faces".

◦ Hide all invisible faces: Hide faces that are not going to be extracted.

◦ Delete all invisible faces: Delete faces that are not going to be extracted.

◦ Add a face attribute: Add "Unextracted face" attribute to the faces that are not going to
be extracted.

In this case, to check the face to be extracted from the X axis direction, select "Add a face
attribute" and click [Execute].

Only faces that are visible from the X axis direction are extracted, and invisible faces
(unextracted faces) are marked pink and "Unextracted face" attribute added.

Figure 2. The result of Extract Visible Face (X axis direction)


Depending on the environment, the result of "Extract Visible Face" may
differ.

For the face with an unextracted face attribute, perform "Set/Unset Attribute", "Hide All
Unextracted Faces", and "Remove all Unextracted Faces" from [Extract Solid] > [Extract
Visible Faces].
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In this case, use the function below to manually change the unextracted faces as an
extraction target and remove the unextracted face.

6. Select [Envelop Solid] > [Extract Visible Faces] > [Set/Unset Attribute] and pick a face without
the unextracted face attribute. Unextracted face attribute is added to the picked face.

Figure 3. Example of unextracted face attribute change (Before and After)

If you pick a face which already has an unextracted face attribute, the attribute will be
removed.

Figure 4. Example of unextracted face attribute change (Left: Before, Right: After)

3DxSUITE Editor Tutorial -Envelop Solid-

 © 2022 Elysium Page 10 | 57



7. Select [Envelop Solid] > [Extract Visible Faces] > [Remove All Unextracted Faces] to remove
faces with unextracted face attributes.

Figure 5. Example of removing unextracted face (Left: Before, Right: After)
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3.3. Data Size Reduction in Volume Units
Create a lightweight model maintaining the solid state by deleting invisible volumes, removing
small volumes/parts, or replacing with simple shapes in volume units.

Figure 6. Example of lightweight model creation maintaining a solid (Left: Before, Right: After)

3.3.1. Open File

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
Specify "envelop.drfx" in the <tutorial> folder and click [Open].

2. Select [Envelop Solid] > [Options] from the menu. In "Envelop option" dialog, select "Data
size reduction" in [Common] tab, and click [OK].
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

Please note that when enabling "Only visible elements" option from [Envelop
Solid] > [Options] > [Common] tab, only the elements displayed on "3D View"
window are targeted for Solid enveloping.

To switch the display on "3D View" window for each part, [Show/No-Show
Parts] command is effective.
Select [View] > [Show Elements] > [Show/No-Show Parts] from the menu or
select [Show/No-Show Parts] ( ) on the toolbar. "Show/No-Show Parts" dialog
will appear.

Enter the condition in the filter box, and the part(s) that meet those condition
will be highlighted in green and listed at the top of the list.
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

Select part(s) in the list, and the corresponding parts will be highlighted in blue
in "3D View" window. Also, select a part on "3D View" window, and the
corresponding part will be highlighted in blue in the list. Select while pressing
down [Ctrl] key or [Shift] key to multi-select.

Either enable the checkbox at the left end of the list or select an item in the list
to activate the Show/Hide button. Click [Show] / [No Show] to change the
show/hide status of the parts.

3.3.2. Execute Data Size Reduction (1)

1. Select [Envelop Solid] > [Reduce Data Size] from the menu or select [Reduce Data Size] ( )
in [Main] panel.
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2. "How to Reduce the Data Size" dialog will appear. Select "By simplifying the geometry
(Result in solid model)" and click [Next].

3. The "Data Size Reduction" dialog will appear.
Enable "Delete Invisible Volumes", "Delete Small Volumes", "Delete Small Parts", and
"Remove All Holes/Grooves/Protrusions" and click [Execute].

4. Invisible Volumes, Small Volumes, Small Parts and All Holes/Grooves/Protrusions are
removed, and data size is reduced.
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Check structure tree in [Main] panel to confirm that part structure is maintained.

3.3.3. Execute Data Size Reduction (2)

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. Specify
"envelop.drfx" in the <tutorial> folder and select [Open].

2. Select [Envelop Solid] > [Reduce Data Size] from the menu or select [Reduce Data Size] ( )
in [Main] panel.

3. The "How to Reduce the Data Size" dialog will appear. Select "By simplifying the geometry
(Result in solid model)" and click [Next].
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4. The "Data Size Reduction" dialog will appear.



Uncheck [Enable] for "Delete Invisible Volumes", "Delete Small Volumes",
"Delete Small Parts", and "Remove All Holes/Grooves/Protrusions" if
checked.

Check [Enable] for "Replace Volume with Simple Shape".
Check "Cuboid", "Cylinder", "Extruded shape" for "Replace with either" and select "No
restriction (Target all)" for "Restrict by size".
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Click [Execute] after the settings.

5. A lightweight model with replaced simple shapes is created.
Since it was executed without removing "Invisible Volumes", "Small Volumes", "Small Parts",
and "All Holes/Grooves/Protrusions", you can check to see that the internal geometry
remains.

Check structure tree in [Main] panel to confirm that part structure is maintained.
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

Selected volumes will be replaced as follows:

• By cylinder when seen as a circle-shape from a certain angle. By tube when
seen as a circle-shape from a certain angle, and has a concentric through
hole

◦ Cylinder

◦ Tube

• By extruded shape when seen as a rectangle from certain two angles

◦ Extruded shape

• By cuboid which is the same size as the bounding box of the original
volume if none of the above

◦ Cuboid
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4. Solid Enveloping

4.1. Overview
In this chapter, you can extract one solid from assembly models with the function of check
round hole, remove round hole, check generic hole, remove generic hole, etc. for Envelop Solid.

Execute "Extract Envelop Solid" function effectively by recognizing and removing features
before executing "Extract Envelop Solid" function.



Please note that you need to switch to [Envelop Solid] mode to use the function.

4.2. Preprocess for Enveloping: Feature Recognition
Prior to enveloping, use "Feature Recognition" function to recognize all the features inside the
assembly models and delete recognized features automatically. If feature recognition is
incomplete, the "Solid enveloping" function may not work as intended.

In this section, "Round Hole" and "Generic Hole" will be used as examples. Please refer to Editor
help for details about deleting other features.

4.2.1. Open File

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
Specify "envelop.drfx" in the <tutorial> folder and click [Open].
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2. Select [Envelop Solid] > [Options] from the menu. In "Envelop option" dialog, select "Solid
enveloping" in [Common] tab, and then click [OK].

4.2.2. Recognize Round Holes

1. Select "Round Hole" in [Main (Work)] panel > [category list].

2. Press [Check All Round Holes] ( ) in [Main (Work)] panel to automatically recognize the
round holes. Once completed, the number of recognized features will be displayed in the
category list.


Double-clicking "Round Hole" in [Main (Work)] panel > [category list] will
also run the feature recognition on round holes.

Recognized round holes will be highlighted in "3D View" window.

Figure 7. Recognizing round holes automatically
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

Feature recognition is performed based on the threshold displayed in the
category list. Round holes whose diameter is 200 mm or smaller will be
recognized by default settings.
To change the threshold, right-click "Round Hole" in the category list and
select [Modify Threshold] from the context menu.

4.2.3. Recognize Generic Holes

1. Select "Generic Hole" in [Main (Work)] panel > [category list].

2. Press [Check All Generic Holes] ( ) in [Main (Work)] panel to automatically recognize the
generic holes. Once completed, the number of recognized features will be displayed in the
category list.


Double-clicking "Generic Hole" in [Main (Work)] panel > [category list] will
also run the feature recognition.

Recognized generic holes (holes which are not categorized as round holes) will be
highlighted in "3D View" window.
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Figure 8. Recognize generic holes



Feature recognition is performed based on the threshold displayed in the
category list. If the opening contour has a maximum width of 200 mm or
less (by default setting) and the shape is not a round hole, then it is
recognized as a generic hole. To change the threshold, right-click "Generic
Hole" in the category list and select [Modify Threshold] from the context
menu.

3. If not automatically recognized, press [Check/Uncheck Generic Hole] ( ) to pick the faces
around the hole you want to recognize.

4. Press [Done] ( ) and a confirmation dialog will appear. Click [Yes] to recognize the
selected face (highlighted in "3D View" window) as a generic hole.

Figure 9. Manually recognize generic holes

4.3. Enveloping
After recognizing "Round Hole" and "Generic Hole" through the above steps, the model should
look like below (recognized features are highlighted). Run envelop extraction to this model.
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Figure 10. Recognized features highlighted

1. Select [Envelop Solid] > [Extract Envelop Solid] from the menu or press [Extract Envelop
Solid] ( ) on [Main (Work)] panel.

2. A dialog will appear. In this case, click [Continue] to apply the default settings.

Figure 11. Dialog for optional settings before enveloping


Check "Fill gaps while enveloping" and specify the threshold (minimum
and maximum values) in the dialog if you would like to fill the gaps.

3. A single solid model will be created while deleting all the recognized features. Confirm that
the assembly model has become a single solid model in [Main (Structure)] panel.

Figure 12. After enveloping ([Main (Structure)] panel)

3DxSUITE Editor Tutorial -Envelop Solid-

 © 2022 Elysium Page 24 | 57





Change the view settings from [View] > [Display type] > [Semi Transparent]
from the menu or click [Semi Transparent] ( ) on the toolbar to see the
model before and after enveloping clearly.

Figure 13. Before and After Enveloping


Please note that Editor may fail to create a single solid volume depending
on the original geometry. In that case, it is often effective to fill the gaps
between volumes before and/or after enveloping. Please refer to 4.5, “Fill
Gap” for details.

4.4. Void with Openings
This section will explain the function of Editor Envelop Solid by taking a case of enveloping
without any preprocess prior to enveloping as an example.

Figure 14. Before and After Enveloping

In the images above, there are some interior parts remaining even after enveloping. This
happens because Editor does not delete the interior parts when they have connection with
exterior parts (can be seen from outside). If a geometry still remains inside, after executing
envelop solid, recognize and delete "void with opening". The following image describes how
Editor extracts an envelop solid. If a geometry still remains inside, after executing envelop solid,
recognize and delete "void with opening".
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How Editor Extracts an Envelop Solid

When none of the interior parts can been seen from outside.
⇒ Deletes all the interior parts. (Interior parts will be filled automatically.)

When there are some interior parts which can be seen from outside.
⇒ The parts which can be seen from outside will remain.

4.4.1. Open File

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
Specify "envelop.drfx" in the <tutorial> folder and click [Open].

2. Select [Envelop Solid] > [Options] from the menu. In "Envelop option" dialog, select "Solid
enveloping" in [Common] tab and click [OK].
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4.4.2. Execute Envelop Solid without Feature Recognition

1. Select [Envelop Solid] > [Extract Envelop Solid] from the menu or press [Extract Envelop
Solid] ( ) in [Main] panel.

2. Below dialog will appear. Execute envelop solid with the default settings by clicking
[Continue]. There is no need to recognize features such as round holes beforehand.

Figure 15. Extract envelop solid dialog (Default settings)

Figure 16. After envelop solid execution (no feature recognition)

4.4.3. Recognize and Delete Voids with Openings

This section will explain how to delete inner voids with openings which remains even after
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enveloping.

1. Select "Void with Opening" in [Main (Work)] panel > [category list]. "Check All (Void with
Opening)" ( ) will appear.



In case "Void with Opening" is not displayed in the category list, add it
according to the following procedure, and then run the feature recognition.

1. Press [Check Options] ( ) located above [Main (Work)] panel.

2. "Check Options" dialog will appear so switch to [Check items] tab.

3. Set the category filter to "All" and enable "Void with Opening" at the
bottom of the list, and click [OK]. "Void with Opening" will appear in the
category list.

2. Press [Check All (Void with Opening)] ( ) in [Main (Work)] panel to automatically
recognize the voids with opening. Once completed, the number of recognized voids with
opening will be displayed in the feature list.

3DxSUITE Editor Tutorial -Envelop Solid-

 © 2022 Elysium Page 28 | 57



The areas recognized as voids with opening are highlighted in "3D View" window.

Figure 17. Recognized void with openings


Double-click "Void with Opening" in the feature list to automatically
recognize void with opening as well.

By pressing "Check/Uncheck (Void with Opening)" ( ) in [Main] panel, you can also add or
release the feature recognition manually. (* No work is required here)

3. Press "Fill All (Void with Opening)" ( ) in Navigation panel to delete all the recognized
voids with openings.

Figure 18. Filled voids with openings (No interior parts remain)
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

Press [Extract Faces of Selected Void with Openings] ( ) in Navigation
panel to extract faces that are recognized as Void with Openings and
currently the targets.

This is useful when you wish to fix the error (Void with Openings) while
maintaining the intended outline using editing tools.

Figure 19. Recognized Void with Opening (on left); and what was Extracted (on
right).

The face extracted with [Extract Faces of Selected Void with Openings] ( )
will appear as "FaceOfVoidWithOpening" in the structure tree.
To show only the extracted face, right-click on "FaceOfVoidWithOpening" in
the structure tree and select "Exclusive Show" from the context menu.

4.5. Fill Gap
Gaps recognized when enveloping can be filled automatically, but depending on the shape, the
gaps may not be filled automatically.

This section will explain how to manually fill gaps which still remain after automatic deletion
in enveloping.
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Figure 20. Extract envelop solid dialog

4.5.1. Recognize and Delete Gap

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar.
Specify "envelop02.drfx" in the <tutorial> folder and click [Open].

Figure 21. Just opened the file

2. Right-click "Gap" in the category list and select [Modify Threshold] from the context menu to
change threshold for gap recognition. Set the range from 0.1mm to 2mm as the threshold
and click [OK].

Figure 22. Modify Threshold for Gap Recognition
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
If "Gap" does not appear in the category list, press [Check Options] ( ) to
open "Check Options" dialog. Enable "Gap" from [Check items] tab.

3. Press [Check All Gaps] ( ) in [Main (Work)] panel to automatically recognize gaps. Once
completed, the number of recognized features will be displayed in the category list.

Figure 23. Recognizing gaps between volumes

The areas recognized as gaps are highlighted in "3D View" window.

The functions [Fill All Gaps] ( ) and [Fill Gaps] ( ) will appear in Navigation panel.
These icons can be used to fill in the recognized "gaps".

4. Press [Fill All Gaps] ( ) in Navigation panel to fill the recognized gaps.

Figure 24. Eliminating gaps between volumes by filling the recognized gaps

5. Select [Envelop Solid] > [Extract Envelop Solid] from the menu or press [Extract Envelop
Solid] ( ) in [Main] panel to extract a model as a single solid.
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Figure 25. After extracting envelop solid



As an alternative method, you can click [Fill Gap by Primitive] ( ) to
create new cuboid or cylinder which fills the gap automatically. This
method might be useful in a situation where [Fill All Gaps] ( ) or [Fill
Gap] ( ) does not work well. Use this method when some extent of
deformation is allowed as long as gaps are filled.

4.5.2. Create Primitive

If you want to create a new primitive by specifying the kind of primitive or the position of
primitive, use [Create Primitive] functionality in [Envelop Solid] menu. Please note that this
functionality is different from that described in the earlier section 4.5.1, “Recognize and Delete
Gap”.

In this case, create a cylindrical volume to fill the gap using the function [Create Primitive].

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. In "Open" dialog,
reopen "envelop02.drfx" in "tutorial" folder.

Figure 26. Just imported

When creating a cylinder with [Create Primitive], a cylinder is created based on the
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specified existing arc or the center of the cylinder. In this case, specify an arc to create a
cylinder.

2. Select [Envelop Solid] > [Create Primitive], and in "Option" dialog, select "Cylinder (By using
existing arc or cylinder)".

Figure 27. Option for Create Primitive

3. Pick a reference arc for the primitive you want to create in "3D View" window.

Figure 28. Specify Base of Primitive

 Switch [Pick Filter] to [Edge] to pick the arc easily.

Pick a point on the bottom face under the existing cylinder to specify the height of the
primitive. New primitive is created as in the below right.

Figure 29. Specify Height of Primitive

4. Move the viewpoint and pick the arc at the bottom of the geometry as the reference for the
primitive you want to create.
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Figure 30. Specify Base of Primitive

Similar to the previous procedure, pick a point on the top face to specify the height of
primitive. New filling primitive is created.

Figure 31. Specify Height of Primitive

Confirm a new cylinder added to the tree in [Main (Structure)] panel.

Figure 32. Created Primitive (Showing the cylinder only)

5. Select [Envelop Solid] > [Merge Volumes] > [Merge All] to create a single solid model by
merging volumes. All volumes can be merged into one solid.
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Figure 33. Merged Model

4.5.3. Extract Faces Surrounding Gaps

If you prefer to fill the gap between volumes while maintaining the original shape as much as
possible, it is recommended to create a new volume manually instead of using [Create
Primitive] function which aims to fill complex gaps automatically.

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. In "Open" dialog,
select "Surrounding.drfx" in "tutorial" folder.

Figure 34. Just After File Open

2. Select "Gap" in [Main (Work)] panel > [category list] to check the gap.
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3. Press [Extract Faces around Gaps] ( ) in Navigation panel to switch to Twin View display
and extract the faces surrounding the recognized gaps (*1).



(*1): Decide whether to extract the neighboring faces. ([Envelop Solid] >
[Options] > [Envelop (Gap)] tab > "Faces around the gap only" or "Faces
around the gap + Neighboring faces" option.)

Left view shows the original geometry with the extracted faces (*2), and Right view shows
the extracted faces only.

Figure 35. Extracting Faces Surrounding Gaps
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

(*2): Use [Show Extracted Faces in Left View] ( ) or [View] > [Twin View
(Envelop)] > [Show Extracted Faces in Left View] to show (overlay) / hide
the extracted faces in Left view.
When it is difficult to visually check the gaps in the original model on the
left view, it may be easier to visually check by hiding the extracted faces on
the left view.

Following description explains how to extend extracted faces and how to remove
unnecessary faces to create new geometry which fills the gap.

4. Press [Extend Face and Trim] ( ) from Navigation panel.
Pick the edges that make up the boundary in order, as shown below in blue lines, and then
press [Done] ( ).

Figure 36. Select the Edge of Face to be Extended

Next, pick the bottom large face as depicted below and press [Done] ( ).

Figure 37. Select the Face to be Trimmed

 You can pick a face by clicking around the red circle.

Finally, click [Run] in [Option] panel to extend and trim the face at the specified position.
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Figure 38. Run Extending Face and Trim

5. Press [Divide Faces by Intersection] ( ) from Navigation panel.
Pick a side face as depicted below and press [Done] ( ).

Figure 39. Select the Face to be Divided

Next, pick the face you have created previously by [Extend Face and Trim] and press [Done]
( ). The face you selected first is divided at the intersection curve between the faces.

Figure 40. Select the Divider Face

6. Similarly, pick each face in [Divide Faces By Intersection] ( ) and press [Done] ( ). The
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selected faces are divided at the intersection line.

Figure 41. Divide Another Face

7. Select [Edit] > [Delete] from the menu or select [Delete] ( ) on the toolbar. Pick the
unnecessary face (area in blue) as shown below.

Press [Done] ( ) to delete the picked face.

Figure 42. Remove Unnecessary Face

8. Press [Work in Twin View] ( ) to exit Twin View. Confirm that the created geometry is
filling the gap.
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Figure 43. Gap is Filled by Created Solid

9. Select [Envelop Solid] > [Merge Volumes] > [Merge All] to create a single solid model by
merging volumes.

Figure 44. Merged Solid

4.5.4. Move Volume

Primitives can be moved using [Create Primitive] functionality of [Envelop Solid] or those
created automatically by Editor based on recognized gaps. Overview of the function, "Move
Volume" is provided at the end of this section.

This section will explain how to move primitives when there are misalignment between those
primitives and surrounding geometries.

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. Open "gap.drfx"
in <tutorial> folder.
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Figure 45. Sample Model for Move Volume

2. Make sure that the threshold of "Gap" in the category list of [Main (Work)] panel is set as 0.1-
7mm. Press [Check All Gaps] ( ). One "Gap" is recognized.

Figure 46. Recognized Gap

3. Press [Fill Gap by Primitive] ( ) in Navigation panel to automatically create a filling
primitive. (This time, a rectangular cuboid.)

Figure 47. Created Primitive
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

The position of the created primitive is slightly diagonal in relation to the
original shape, so the corners will not match.

Figure 48. Primitive is not Aligned to the Original Geometry

Next, adjust the angle and position of the primitive (cuboid) to be aligned with the largest
face of the original geometry as shown in the upper right figure.

4. Select [Envelop Solid] > [Move Volume] > [Align by Axis] from the menu and pick the
primitive (cuboid) to be moved.

Figure 49. Pick the Primitive to be Moved

Next, pick the edge (the one shown in light blue) of the primitive (cuboid) to be moved.

Figure 50. Pick the Edge of the Primitive
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Then, pick the edge (below left in light blue) of the existing geometry. (Below right figure
shows only the geometry that contains the picked target for clarity.)

Figure 51. Pick the Edge of Existing Geometry

Misalignment in Z axis direction is now fixed.

Next, fix the misalignment in Y axis direction and the angle by parallel shift and rotation.

5. Select [Envelop Solid] > [Move Volume] > [Align by 2 Axes] from the menu and pick the same
primitive.

Pick the edge that is the preferred axis from the primitive (cuboid) as shown by the light
blue line in the below left figure. Then pick the edge that is the preferred axis from the
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original geometry as shown by the light blue line in the below right figure.

Figure 52. Specify the Axis around which the Primitive Rotates


The primitives (cuboids) will move by the shortest distance so that the
priority axes specified here are placed on the same straight line with each
other.

Select the edge of the primitive (cuboid) as depicted left below and then select the edge of
the original geometry as depicted right below to specify how much and which direction the
primitive rotates.

Figure 53. Specify How Much and Which Direction the Primitive Rotates


It rotates around the priority axis of the primitive (cuboid) so that the
auxiliary axes specified here are placed on the same plane.

Direction and angle of the primitive (cuboid) are now aligned.

3DxSUITE Editor Tutorial -Envelop Solid-

 © 2022 Elysium Page 45 | 57



Figure 54. After Move Volume

Finally, merge the volumes and merge the face groups.

6. Select [Envelop Solid] > [Merge Volumes] > [Merge All] to create a single solid model by
merging volumes.

Figure 55. Merge Volume

7. Press [Face Merge] ( ) on Navigation panel.
Pick all the faces on the top side of the original geometry and press [Done] ( ).

Figure 56. Faces before merge
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Faces are merged. Now the upper face of the created primitive becomes a part of upper face
of the original geometry.

Figure 57. Faces after merge

In the above steps, two methods [Align by Axis] and [Align by 2 Axes] of [Move Volume]
have been used. In addition to these two methods, two other methods, [Match Points] and
[Align by Planes] are available in [Move Volume]. Followings are the explanation of these
four methods.

■ Overview of Move Volume

With [Envelop Solid] > [Move Volume] function, it is possible to align by [Align by Axis] or
[Match Points] when the volume to be moved is not tilted with respect to the base volume. Also,
if the volume is tilted, the method [Align by Planes] to rotate the volume and then [Match
Points] is effective. [Align by 2 Axes] is effective when a complex relative position exist between
the two volumes that cannot be perfectly aligned by either [Align by Axis] or [Align by Planes].

Move Volume 1 (Match Points)

The volume will move to match the two specified points. The volume does not rotate.

Figure 58. Match Points
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Move Volume 2 (Align by Axis)

Geometry moves to align the selected edge of itself to the edge of target geometry. If
necessary, Moving Volume rotates around the axis which is defined automatically based
on the selected edges.

• Pattern 1: Rotation is not necessary

Figure 59. Move Volume (Align by Axis) - without Rotation

• Pattern 2: Rotation is necessary

Figure 60. Move Volume (Align by Axis) - rotates then shifts

Figure 61. Align by Axis (with Rotation)
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Move Volume 3  (Align by Planes)

Volume moves to align selected planes. To align planes, Moving Volume parallel shifts and
then rotates.


With [Align by Planes], the edges of the specified faces are not aligned.
After using [Align by Planes], use the function [Align by Axis] to match
the edges.

Figure 62. Before and After Align by Planes

Figure 63. After Align by Axis
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Move Volume 4 (Align by 2 Axes)

Geometry moves to align virtual faces of Moving Volume to that of Target Volume. Virtual
faces are defined based on Primary Axis and Secondary Axis you selected.

1. For both Moving Volume and Target Volume, specify Primary and Secondary Axes.
Secondary Axis must be parallel to Primary Axis.

Figure 64. Specify Primary Axis (Red) and Secondary Axis (Yellow)

With the same logic as [Move Volume (Align by Axis)], Moving Volume moves first to
align its Primary Axis to the Primary Axis of Target Volume.

Figure 65. After Align by Primary Axis

Afterward, Moving Volume rotates around Primary Axis so that the plane composed
of Primary Axis and Secondary Axis of each volume is located on the same plane.

Figure 66. Two virtual faces created by Primary and Secondary Axes and direction of
rotation
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Figure 67. After Rotation

4.5.5. Create Solid by Extrusion

Fill the gap of a geometry by extruding a face. By using this functionality, you might be able to
fill the gap better than [Create Primitive].

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. Select
"extrusion.drfx" in <tutorial> folder.

Figure 68. Sample Model for Create Solid by Extrusion

First of all, remove the fillets associated with the plane you want to extrude.

2. Select "Fillet" from the category list in [Main (Work)] panel. [Check/Uncheck Fillet] (  ) will
appear.
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3. Press [Check/Uncheck Fillet](  ) and pick fillets around the gap in order as shown below.
Then press [Done] ( ).

Figure 69. Select Fillets to be Removed

4. A confirmation dialog will appear. Enable "Apply to all places" and click [Yes].

Two fillets are recognized.
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5. Click [Remove All (Fillets)]( ) in Navigation panel to remove recognized fillets. Two fillets
are removed.

Figure 70. Fillets are Removed

6. Select [Envelop Solid] > [Create Solid by Extrusion]. Select the lower face around the gap as
depicted left below to specify the face to extrude. Then select a point near the upper face to
specify the direction of extrusion as depicted right below.

Figure 71. Specify How Extrude Face

The gap is filled in by the extruded geometry.
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Figure 72. Gap is Filled by Created Solid

7. Select [Envelop Solid] > [Merge Volumes] > [Merge All] from the menu to create a single solid
model by merging volumes.



Please note that this step can be skipped by checking "Merge the extruded
volume and the original volume" option displayed at the lower left of the
window during extrusion.

Figure 73. [Merge the extruded volume and the original volume] option

4.5.6. Create Solid between Selected Faces

Fill the gap between selected faces by creating new solid. The shape of new solid is defined as
the intersection of the solids which are extrusion of selected faces. This functionality might be
useful in case [Create Solid by Extrusion] creates a solid which includes unnecessary portion.

1. Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. Open
"facegap.drfx" in <tutorial> folder.
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Figure 74. Sample Model for Create Solid between Selected Faces

2. Select [Envelop Solid] > [Create Solid between Selected Faces], and select "By offsetting
selected face" in [Option] panel.

Figure 75. Options for Extrusion Direction


When you check "By axis connecting 2 points", the face is extruded to the
direction of the axis connecting selected 2 points. When you check "By
plane", the face is extruded to the direction of normal of selected face.

3. Select the face. Pick the face under the cylinder as depicted below and press [Done] ( ).

Figure 76. Pick Face under the Right Cylinder

4. Pick the left side face of cylinder as depicted below and press [Done] ( ).
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Figure 77. Pick Left Side Face of Cylinder

The specified face is offset and a new solid is created to fill the gap between the two faces.

Figure 78. Created Solid between Faces

This is the end of Editor Envelop Solid Tutorial.
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