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Shortened Names for 3DxSUITE Products

In this document, the 3DxSUITE product names are referred to as follows:

• 3DxSUITE Components → Components

• 3DxSUITE Viewer → Viewer

• 3DxSUITE Editor → Editor

• 3DxSUITE SmartLauncher (Standalone) → SmartLauncher (Standalone)

• 3DxSUITE SmartLauncher (Plug-in) → SmartLauncher (Plug-in)

• 3DxSUITE SmartController → SmartController

• 3DxSUITE SmartController Pro → SmartController Pro

• 3DxSUITE TransServer → TransServer

• 3DxSUITE WorkerNode → WorkerNode

• 3DxSUITE ScenarioEditor → ScenarioEditor

• 3DxSUITE Data Package Studio → Data Package Studio

• 3DxSUITE Validation Configurator → Validation Configurator

• 3DxSUITE PDQ Checker Configurator → PDQ Checker Configurator

• 3DxSUITE Setting Utility → Setting Utility
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1. Preface

1.1. About this Tutorial
This tutorial is composed of two parts and you can learn how to operation Editor (Reverse
Engineering Mode) step by step.

■ Reverse Engineering

This function generates B-rep data from polygon.

• 3, Generate B-rep by Extracting Fillets

• 4, Generate B-rep by Global Segmentation

Furthermore, the features described in this tutorial are just a part of Editor (Reverse
Engineering Mode). Please refer to the help for other features.

About Help

For Editor help, select [Help] > [Help Index] from Editor menu. The help provides details
about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of offline help, select [Help] > [Context
Help], and a question mark appears next to the cursor so either double-click the menu or
just click the icon.


Go through Editor "Tutorial -Standard function-" to learn the basic functions of
Editor before starting this tutorial.


An optional license is required to use Editor (Reverse Engineering Mode) in
addition to the Editor license.

3DxSUITE Editor Tutorial -Reverse Engineering-

 © 2022 Elysium Page 2 | 33



1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] ( ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of Reverse Engineering is not displayed in Editor, select [View] >
[ToolBar] > [Reverse Engineering].

1.3. About Sample Data
The sample data to be used is located in the folder "\document\tutorial_models\reverse-
engineering" inside the folder where Editor is installed.

1.4. About Images
The images in this document may include slight differences from the ones actually displayed on
your Editor depending on your specific computer hardware and Editor version.
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2. Operation Flow
This tutorial will explain the standard operations when using the Reverse Engineering
functions. The following are the overall procedures.

• Reverse Engineering Mode:

Basically, the procedures are the same as in normal data translation, but use Reverse
Engineering mode.
*Red text indicates operations to be performed in Reverse Engineering mode.

Operation
1 Import

2 Select "Create B-rep method" (Extract fillets or Global segmentation)

3

Extract fillets

Generate B-rep

Global
segmentation

Segmentation

4
Interactive
Healing

Manual Segmentation

5 Generate B-rep
surface

6 Modify Surface
7 File Export

Select the method to generate a surface by setting the options in "Reverse Engineering
option" dialog.

Extract fillets:

Recognize fillets from polygon shape automatically, and create B-rep geometry based on
fillet recognition.
This method is suitable for polygon data whose base surface and fillet is clear to some
extent.

Global segmentation:

Create segmentation from polygon shape, and create B-rep geometry based on
segmentation (same as CADdoctor EX5.2). This method is suitable for the polygon data
that has vague shape.

The below chapters will explain the operations in Reverse Engineering mode using sample files.
Please refer to the help if you see any unfamiliar terms during the tutorial.
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About Twin View

In Reverse Engineering mode, the view window can be divided in half to display a
polygon model and a generated surface.

You can toggle the partitioned view from [View] > [Twin View (Reverse Engineering)] in
the menu or click [Work in Twin View] icon on toolbar.

Figure 1. Twin View (Reverse Engineering) toolbar

Display imported CAD model (e.g., IGES) on the left view

Display Point Cloud model on the left view

Display polygon model on the left view

Display generated B-rep model on the left view

Switch the view mode between Single View and Twin View

Display imported CAD model (e.g., IGES) on the right view

Display polygon model on the right view

Display Point Cloud model on the right view

Display generated B-rep model on the right view

Synchronize the view operation (left and right side)
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3. Generate B-rep by Extracting Fillets

3.1. Overview of this Chapter
This chapter will explain how to extract fillets from polygon models and create surfaces using
Reverse Engineering functions.

3.2. Import File
Import .stl file as a polygon model.

1. Select [File] > [Import] from the menu or click [Import] ( ) on the toolbar.

2. "Open" dialog will appear. Switch the file type to "STL (*.stl)" and specify "sample_RE1.stl" in
the <tutorial> folder.

Figure 2. "Open" dialog

3. Click [Option] in "Open" dialog to display "Option" dialog. Confirm that the settings are the
same as shown below and click [OK].
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Figure 3. Option dialog

4. Click [Open] in "Open" dialog to import the polygon file.

Figure 4. After importing



Please note that if you haven’t switched to [Reverse Engineering] mode, then
switch the mode in [Main (Work)] panel.
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Toggle Display Type (Polygon)

• Display type of polygon data can be switched by [Display type (Polygon)] (  ) on
the toolbar.

Figure 5. Display type (Polygon) Toolbar

◦ [Shading (Polygon)] ( ): Polygon is displayed in shading mode.

◦ [Wireframe (Polygon)] ( ): Polygon is displayed by wireframe mode.

Figure 6. Shading display and Wireframe display

• You can change the face color of polygon in [File] > [Display Preference] > [Display
Attribute] tab > "Polygon Color".
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• Basic method for checking the error location is the same as in the normal mode;
however, in Polygon PDQ, when pressing [Display Surrounding] (  ), the icons to
extend (  ) / reduce (  ) are additionally displayed. These functionalities make it
possible to adjust the area.

Figure 7. Adjust Area


Instead of extending / reducing the regions, the function [Clipping
Box (On/Off)] (  ) can be used to limit the displayed range on "3D
View" window. Please refer to "Editor Tutorial -Standard function-"
for more details about the operation.

3DxSUITE Editor Tutorial -Reverse Engineering-

 © 2022 Elysium Page 9 | 33



3.3. Generate B-rep
1. Select [Reverse Engineering] > [Options] from the menu.

2. "Reverse Engineering option" dialog will appear. Select "Extract fillets" as the method to
generate B-rep in [Common Settings] tab.

Enable "Model contains nearly parallel fillets over a short distance" option in [Create B-rep
(Extract fillets)] tab, and click [OK].

Figure 8. Model contains nearly parallel fillets over a short distance

3. Select [Reverse Engineering] > [Generate B-rep] from the menu or select [Generate B-rep]
( ) in [Main (Work)] panel.

4. "Reverse" dialog will appear. Select "Input after calculating curvatures" of "Maximum radius
of fillet", and click [Run].
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
Please note that the settings you changed in this dialog are valid only this
time. The changes made will not be reflected in "Reverse engineering
option" dialog.

5. "Maximum fillet R" dialog will appear. Also, on the "3D View" window, the fillet candidate is
highlighted in red. Move the slide bar to adjust the highlighted area, and click [OK].

Figure 9. Adjust fillet radius

A surface is generated and "3D View" window switches to Twin View.
Polygon is displayed on the left view, and the surface on the right.
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Figure 10. Result of B-rep generation



Elements to be displayed in the left and right views of "3D View" window
can be toggled in [Work in Twin View] of Reverse Engineering toolbar.
Please refer to "2, Operation Flow" for more details about "Twin View".

Figure 11. Twin View (Reverse Engineering) toolbar
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3.4. Modify B-rep
When there is a problem with the geometry of the generated surface, such as a cracked surface,
you can repair it manually.

Figure 12. Areas to repair

1. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

2. Pick the unnecessary face on "3D View" window, and press [Done] ( ).



Switching Pick Filter to "Face" makes it easier to pick the face you want to
delete.
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3. Select [Reverse Engineering] > [Create Dividing Curve] from the menu or click [Create
Dividing Curve] ( ) on the toolbar.

4. Check "Specify Tangent Vector" in [Option] panel.

5. Pick the starting point and the end point of the edge on "3D View" window and press [Done]
( ).

6. "Decide Tangent Vector" dialog will appear. Click [Select edge] of "Start" direction.

Pick the adjacent edge of the starting point.
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7. "Decide Tangent Vector" dialog will appear. Click [Select edge] of "End direction".

Pick the adjacent edge of the end point.

8. In "Decide Tangent Vector" dialog, click [OK].

The adjacent edge becomes smooth by the created dividing curve.

9. Create dividing curves in the same way for other areas. Press [Quit] ( ) to exit.
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Next, create a face that is not a fillet part.

1. Select [Reverse Engineering] > [Create Base Face] from the menu or click [Create Base Face]
( ) on the toolbar.

2. Pick a free edge where you want to create a face on "3D View" window and press [Done]
( ).

3. The loop is auto detected and the candidate for the face boundary is highlighted on "3D
View" window. In the confirmation dialog, if the candidate of face boundary is correct, click
[Yes].
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
If the candidate of the face boundary is incorrect, click [Next] in the
confirmation dialog.

A base plane is created. Press [Quit] ( ) to exit.

Finally, create the fillet corner face.

1. Select [Reverse Engineering] > [Create Fillet Corner] from the menu or click [Create Fillet
Corner] ( ) on the toolbar.

2. Pick a free edge where you want to create a face on "3D View" window and press [Done]
( ).

3. The loop is auto detected and the candidate for the face boundary is highlighted on "3D
View" window. In the confirmation dialog, if the candidate of boundary of face is correct,
click [Yes].
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Fillet corner face is created.

4. Create fillet corner faces in the same way for other areas. Press [Quit] ( ) to exit.
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3.5. Auto Heal Generated B-rep
Repair the generated surface using the standard Auto Healing / Interactive Healing functions.

1. Specify the target CAD system and press [Auto Heal] ( ) in [Main (Work)] panel.



◦ When the category list is not displayed on [Main (Work)] panel, click the
drop-down list of the category list and enable "Show Category list".

◦ If [Auto Heal] ( ) does not appear on [Main (Work)] panel, click
anywhere within the category list (upper list).

[Auto Heal] will be executed.
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Figure 13. After auto healing
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3.6. Recognize and Remove Fillets
Automatically recognize the generated surface with a fillet radius of 10 mm or less, and remove
the recognized fillets at once.

1. Right-click the feature name "Fillet" in [Main (Work)] panel, and select [Modify Threshold]
from the context menu.

2. "Fillet" dialog will appear. Set "Max radius for fillet (mm)" to 10, and click [OK].

Threshold range in the feature list will be updated.

3. Press [Check All Fillets] (  ) in [Main (Work)] panel.
Fillets will be automatically recognized, and the number of recognized fillets in the feature
list will be updated.
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Also, the areas recognized as fillet will be highlighted on "3D View" window.

Figure 14. Recognize Fillets

 Double-click "Fillet" in Feature List to recognize automatically as well.

4. Press [Remove All (Fillets)] ( ) on Navigation panel to remove all recognized fillets.

Figure 15. Remove Fillets
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3.7. Confirm the Distance between Polygon and
Surface
Confirm the distance between the polygon and the generated surface.

1. Select [Analysis] > [Show Distance] > [Polygon - B-rep] from the menu or click [Polygon - B-
rep] ( ) on the menu bar.

2. "3D View" window switches to a Twin View display of the polygon model and the generated
surface. The gap size between the polygon model and the surface will be displayed in color.

Figure 16. Show distance

3. Select [Analysis] > [Show Distance] > [Options] from the menu or click [Set show difference
options] ( ) on the toolbar.

4. "Show difference option" dialog will appear. Enable "Show histogram" and click [OK].

Figure 17. Set "Show histogram" (in [Show difference option] dialog)

It is possible to confirm visually the value range where the gap differences are concentrated.
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Figure 18. Show difference (Show histogram)



"Show histogram" displays what percentage of the total data fits into the
range between the upper and the lower limit of the scale, and displays the
point with the largest gap (Max Dist.) in the positive and negative directions
of the entire model.

Figure 19. Percentage of gap distances displayed

Figure 20. Maximum (Max) and Minimum (Min) gap values
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4. Generate B-rep by Global Segmentation

4.1. Overview of this Chapter
This chapter will explain how to generate a surface from a polygon that has been divided into
segments using Reverse Engineering functions.

4.2. Import File
Import .stl file as a polygon model.
Import "sample_RE2.stl" in <tutorial> folder by referring to 3.2, “Import File”.

Figure 21. "Open" dialog

4.3. Segmentation
1. Select [Reverse Engineering] > [Options] from the menu.

2. "Reverse Engineering option" dialog will appear. Select "Global segmentation" as the method
to generate B-rep in [Common Settings] tab, and click [OK].

3. Press [Segmentation] ( ) in [Main (Work)] panel.
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Polygons are segmented (grouped) into the units of generating surfaces.

Figure 22. After Segmentation



The sample data (.stl data) in this tutorial does not have a severe error, so
the surface is generated without healing the polygon.
When a severe error exists in other .stl data, it is required to heal the
polygon first to eliminate the severe error, and then perform segmentation.

Please refer the tutorial, "Editor Polygon Check / Healing Tutorial" for more
details.
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4.4. Edit Segment
Modify segments manually after the automatic segmentation. Here, for the finely divided
segments on the fillet parts and such, connect the segments, and then delete the unnecessary
ones.


The following is an example. Depending on the version used, the result of
segmentation may vary.

1. Select "Segment (No Surface)" in the feature list of [Main (Work)] panel.

Figure 23. Segment (No Surface)

2. Select [Reverse Engineering] > [Edit Segment] > [Connect] from the menu or click [Connect]
( ) on Navigation panel.

3. Pick the segments to connect on "3D View" window, and press [Done] ( ).

Segments are connected, and the feature list is updated. Continue the same procedure to
connect the segments in other places.
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

When the automatically created segment is too large, select [Reverse
Engineering] > [Edit Segment] > [Divide] from the menu or click [Divide]
( ) on Navigation panel to divide the segment.

Next, confirm where the segments are not set. All segments that are not set in this sample
data are unnecessary, so delete them.

4. Select "Out Of Segment" in the feature list of [Main (Work)] panel, and press [Zoom current
target] ( ).
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"3D View" window will zoom into the current target position. Switch to [Semi Transparent
(Polygon)] ( ) to confirm the tiny segments overlapping. Delete these tiny segments
because they are unnecessary.

5. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

6. Right-click on the segment you want to delete in "3D View" window. "Pick Which?" dialog
will appear. Pick the item that highlights the target segment, and then press [Done] ( ).

The selected segment is deleted and the feature list is updated.

7. Select "Out Of Segment" in the feature list of [Main (Work)] panel, and then press [Next] (
). Continue deleting the segments until the number of recogition for "Out Of Segment"

becomes "0".
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4.5. Generate B-rep Surface from Polygon
Generate B-rep surface for each segment.

1. Press [Generate B-rep] ( ) in [Main (Work)] panel.



If "Out Of Segment" remains in the feature list, the following dialog will
appear. Depending on the geometry, select [Connect] ( ) or [Delete] ( ).

Surface is generated and "3D View" window switches to Twin View, one for the polygon and
the other for generated B-rep (surface).

Figure 24. After generating B-rep
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4.6. Heal Generated B-rep Surface
Repair the generated surface using the Auto Healing and Interactive Healing functions.



• If [Auto Heal] ( ) does not appear on [Main (Work)] panel, click
anywhere within the category list (upper list).

• When the category list is not displayed on [Main (Work)] panel, click the
drop-down list of the category list and enable "Show Category list".

1. Click the target CAD system, and press [Auto Heal] ( ) in [Main (Work)] panel.

Auto healing will be executed, and the number of errors in the category list will be updated.
Perform manual healing if errors still remain after auto healing.
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Figure 25. After auto healing



◦ The function [Generate B-rep] ( ) can be performed again even after
healing.

◦ Please refer to "Show distance" to confirm the errors between the
polygon and the generated surface.
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be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
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